1

I'm clueless about how to make sound work in Xubuntu 18.04.

Previous versions with older kernels didn't detect most of my hardware, new 18.04 with 4.15 Linux Kernel detected all the hardware, except the sound card. On the OEM Windows 10, the sound is working fine and it's described as Intel SST Audio Device WDM.

~$ sudo lshw -C sound

*-multimedia NO RECLAMADO
descripción: Multimedia controller
producto: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit
fabricante: Intel Corporation
id físico: 3
información del bus: pci@0000:00:03.0
versión: 36
anchura: 32 bits
reloj: 33MHz
capacidades: pm msi cap_list
configuración: latency=0
recursos: memoria:91000000-913fffff
*-usb:1
descripción: Vídeo
producto: USB Camera
fabricante: Generic
id físico: 4
información del bus: usb@1:4
versión: 1.07
serie: 200901010001
capacidades: usb-2.00
configuración: driver=uvcvideo maxpower=500mA speed=480Mbit/s

~$ lspci
00:00.0 Host bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series SoC Transaction Register (rev 36)
00:02.0 VGA compatible controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCI Configuration Registers (rev 36)
00:03.0 Multimedia controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit (rev 36)
00:0b.0 Signal processing controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Power Management Controller (rev 36)
00:14.0 USB controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series USB xHCI Controller (rev 36)
00:16.0 USB controller: Intel Corporation Device 22b7 (rev 36)
00:1a.0 Encryption controller: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Trusted Execution Engine (rev 36)
00:1f.0 ISA bridge: Intel Corporation Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series PCU (rev 36)

$ lsmod | grep "sst"
snd_soc_sst_cht_bsw_nau8824    16384  0
snd_intel_sst_acpi     16384  1
snd_intel_sst_core     53248  1 snd_intel_sst_acpi
snd_soc_sst_atom_hifi2_platform   102400  2 snd_intel_sst_core
snd_soc_acpi           16384  1 snd_intel_sst_acpi
snd_soc_nau8824        57344  2 snd_soc_sst_cht_bsw_nau8824
snd_soc_acpi_intel_match    20480  1 snd_intel_sst_acpi
snd_soc_core          241664  3 
snd_soc_sst_cht_bsw_nau8824,snd_soc_nau8824,snd_soc_sst_atom_hifi2_platform
snd_pcm                98304  6    
snd_soc_sst_cht_bsw_nau8824,snd_soc_nau8824,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm_dmaengine
snd                    81920  10     
snd_seq,snd_soc_sst_cht_bsw_nau8824,snd_seq_device,snd_timer,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm,snd_rawmidi

$ dmesg | grep "sst"
[    7.042875] intel_sst_acpi 808622A8:00: LPE base: 0x91600000 size:0x200000
[    7.042880] intel_sst_acpi 808622A8:00: IRAM base: 0x916c0000
[    7.042931] intel_sst_acpi 808622A8:00: DRAM base: 0x91700000
[    7.042941] intel_sst_acpi 808622A8:00: SHIM base: 0x91740000
[    7.042981] intel_sst_acpi 808622A8:00: Mailbox base: 0x91744000
[    7.042990] intel_sst_acpi 808622A8:00: DDR base: 0x20000000
[    7.043126] intel_sst_acpi 808622A8:00: Got drv data max stream 25
[   67.472476] intel_sst_acpi 808622A8:00: FW Version 01.0b.02.02

$ ls /sys/class/sound
card0  comprC1D2  controlC1  pcmC0D1p  pcmC1D0c  pcmC1D1p  timer
card1  controlC0  pcmC0D0p   pcmC0D2p  pcmC1D0p  seq
1

I don't know if this is going to help you, because I have no idea of what your hardware is, but on my setup (Arch Linux k4.17) the sound worked somewhat OutOfTheBox. The kernel driver bytcrrt5640 is responsible of this miracle (You know BayTrail + Linux). I just had to add bytcr-rt5640 UCM config files to /usr/share/alsa/ucm, and everything worked.

For you to make sure you can see the card, look at the output of these commands:

lsmod | grep "sst"

Looks for sst in loaded modules list

dmesg | grep "sst"

Looks for sst in the current boot log

ls /sys/class/sound

This informs you if there are any cards recognized by the kernel

If you see the card in sysfs, read the file driver in that device (/sys/class/sound/cardX/driver or name or something like that), that should show you if the card is recognized by your kernel.

If you find the card, but you can't see it in for example pavucontrol, then you have to copy the UCM files from this GitHub repository. Just download it, cd into the right folder and read the README file. It should tell you the rest. After you have installed the configs, reboot (easiest way), and you should be able to see the device in pavucontrol.

EDIT#1 (After additional details)

Oh, I see. You should copy the directory chtnau8824 (as you can see in the lsmod output). Enter the UCM-files repo you downloaded and run this command: sudo cp -r chtnau8824 /usr/share/alsa/ucm/ and it should work as expected. Anyways thank you for your kind comment and supplying additional details that helped to solve (hopefully) this issue.

EDIT#2 cht_bsw_nau8824

I still don't know exactly what your other hardware is (like tablet model), but what I found is repository with UCM files specifically for your sound card (if my assumptions are right). The repository is here. Download it, enter the directory and replace your current UCM configuration with the new config. sudo rm -r /usr/share/alsa/ucm/chtnau8824 and then sudo cp -r ucm /usr/share/alsa/ucm/chtnau8824

| improve this answer | |
  • Thanks for your answer, I tried to follow your advice with no results, maybe I'm not understanding. I downloaded the repository you suggested, but I don't know which folder I should copy to /usr/share/alsa/ucm ... I added the output of the three commands you mentioned in the original question, maybe that will help. Thanks in advance. – Juanse Jul 1 '18 at 4:20
  • I copied the folder and rebooted; I still have no sound. Which command should I run in order to diagnose the problem? I tried: $ pulseaudio and the output is: W: [pulseaudio] pid.c: Stale PID file, overwriting. E: [pulseaudio] alsa-ucm.c: Failed to get the verb HiFi E: [pulseaudio] alsa-ucm.c: No UCM verb is valid for chtnau8824 Terminado (killed) Thanks again for your time. – Juanse Jul 2 '18 at 2:58
  • Please post the output of cat /sys/class/card*/id It should tell you the right driver ID. At least you can be sure the firmware works. You're only missing the UCM config files. This is the better case. – Enginecrafter77 Jul 2 '18 at 7:58
  • This command outputs an error, no card* folder in /sys/class. Instead, I tried: cat /sys/class/sound/card0/id Outputs: Audio And cat /sys/class/sound/card1/id outputs chtnau8824 so I think your assumptions were right. – Juanse Jul 2 '18 at 12:49
  • About EDIT#2 it is a tablet-like model, marketing name "2 in 1". It has a 32-bit UEFI but 64-bit proccessor, it was not easy to get Xubuntu installed. Please let me know if I can run some other command to get more info. I followed the instructions in EDIT#2, still no sound, but now pulseaudio outputs E: [pulseaudio] pid.c: Daemon already running. E: [pulseaudio] main.c: Ha fallado pa_pid_file_create(). ("Ha fallado" == "Has failed") Thanks once again for your help. – Juanse Jul 2 '18 at 12:49
0

I have another generic "2 in 1" which reports results from commands:

lsmod | grep "sst"

dmesg | grep "sst"

ls /sys/class/sound

all exactly the same outputs as the OP. I followed only the steps of EDIT#1 (After additional details).

One thing I may have done additionally was match the root user folder permissions to the same as all other entries in /usr/share/alsa/ucm/. After a reboot sound plays and "speakers, headphones and microphone" entries appear in pavucontrol along with "Built-In Audio" in KDE Plasma Settings.

| improve this answer | |
0

After some months during which I didn't have time to try new solutions, I updated the kernel from 4.15.X to 4.19.X using ukuu.

Following the steps in EDIT#1 of M. H.'s answer, sound worked on reboot. Thanks for your time on answering my question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.