4

When I try to boot my freshly burned Ubuntu 18.04 from a pen drive in UEFI mode on a Dell Latitude laptop, I get

Failed to set MokListRT: Out of Resources

In addition, I see some random colorful pixels appearing on the upper part of the screen.

In Legacy mode everything goes smoothly, and with the same burning method and configuration Ubuntu 17.10 also boots up without any disruptions – both in Legacy and in UEFI modes.

Is it a bug, a hardware incompatibility issue or am I simply doing something in the wrong way?

1

2 Answers 2

9

I have solved the problem by creating a new boot option, using grubx64.efi loader.


By default, there weren't any EFI loaders selected on the installation media, so that's why BIOS could have some trouble selecting the proper one.

For others strugglng with the same problem on a Dell Latitude, here it is a short guide:

  1. Enter BIOS setup.
  2. Select General > Boot Sequence on the left.
  3. Ensure UEFI is selected and click Add Boot Option.
  4. Enter some name and browse for grubx64.efi on the right file system (in my case it was FS1).
  5. Click Ok, save the settings and that's it!
1
  • I can confirm that this also works with Ubuntu 20 on a Dell Precision. My fresh Ubuntu USB drive had been booting great for days until I finally connected to the internet and updated Ubuntu. After updating I had this exact same problem.
    – Blackwood
    Jun 17, 2021 at 14:58
0

I had the same message, but a different underlying problem, so I thought I'd tack this on in case someone else winds up here. My machine was also a Dell, but a different model (Optiplex 990). BIOS navigation was slightly different, but the differences were fairly easy to navigate.

In my case, I had a machine with two drives, but was copying and changing them out. I got the SATA data cables reversed, and it was trying to boot from the second disk which was not set up for that.

Two solutions worked equally well: create a new boot option as you suggested. or just switch the cables back to the right drives.

Not the answer you're looking for? Browse other questions tagged or ask your own question.