1

I have installed Ubuntu 18.04 LTS on my HP zbook studio g4. This laptop comes with a nvidia quadro M1200 and is enabled in the BIOS as dedicated card.

I have found this answer: Backlight not working on Ubuntu 17.10, Lenovo P51, Xorg, NVIDIA Quadro M1200

But this worked not for me. The xbacklight does not respond when I do this in the terminal:

xbacklight =50

Then I tried to get the value which is the backlight at the moment, to see if the package responded:

xbacklight -get

but then there was no response.

The package is installed using

sudo apt install xbacklight

So I assumed that that is what I need to do.

I tried everything after a reboot after the grub was changed and the package was installed.

Is there someone who found already a solution for this problem?

0

i had the same problem some years ago and was having the same problem again after installing ubuntu 18.04. it was a kernel problem then, and i think it may be a kernel problem now.

after updating the kernel the problem was fixed for me.

to update kernel see: Updating kernel question

to download last stable kernel (which worked for me): http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16.6/

in my case i downloaded:

linux-headers-4.16.6-041606_4.16.6-041606.201804300418_all.deb

linux-headers-4.16.6-041606-generic_4.16.6-041606.201804300418_amd64.deb

linux-image-unsigned-4.16.6-041606-generic_4.16.6-041606.201804300418_amd64.deb

linux-modules-4.16.6-041606-generic_4.16.6-041606.201804300418_amd64.deb

4
  • Note that switching to the upstream "stable kernels" is the same as being on the Mainline kernels; you do this at your own risk, and your mileage may vary with regards to success. (This is usually only done as a 'debugging' step to determine if the issue is in the current kernel on the system, and these don't usually receive any updates at all later for security or other issues) – Thomas Ward Apr 30 '18 at 23:55
  • Thomas, thanks for the information! I prefer using "ubuntu's standard kernel", but it is not working well in my computer. – user824210 May 1 '18 at 0:46
  • Following a suggestion I wrote with more details in: askubuntu.com/questions/1030043/… – user824210 May 1 '18 at 1:00
  • 1
    Hi, thank you for your answer, but I just found this morning my own solution without switching kernels (which I prefer to make sure I receive updates). I had to enable the nvidia driver from "software &updates". In the tab "additional drivers" I choose there NVIDIA instead of X.org X server. Now I can use the command "xbacklight", and I think it is possible to assign the command to the keyboard as shortcuts, but at the moment I just use the command in the terminal. – pepijntje02 May 1 '18 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.