1

The command /usr/bin/compton -I 0.04 -O 0.04 -D 10 -m 1.0 -C -f -i 1.0 -e 1.0 -G --vsync none --unredir-if-possible --unredir-if-possible-delay 0 -b does exactly what I want, when I run it from a terminal after booting my system as usual. However, putting this command into autostart, causes Lubuntu to fail loading the graphical environment after boot, i.e. no taskbar appears, no windows can be opened using shortcuts, rightclick on the desktop does nothing, etc. Only the default desktop background remains visible (I haven't changed it), but that's all.

It seems to be completely irrelevant, which of the multiple options for autostarting I use, at least I tried:

  • The graphical wizard from Preferences -> Default applications for LXSession -> Autostart -> Manual autostarted applications -> Add

  • Adding the command to ~/.config/openbox/autostart

  • Adding the command to ~/.config/lxsession/Lubuntu/autostart

  • Placing a compton.desktop file in ~/.config/autostart/ (this works for me with other applications)

  • Using systemd as explained in this highly related question (works for me with other applications, but gives me exact same error here as described in the question)

I assume that my command is correct, because it does what it should when being run from a terminal after boot is complete, and I assume that my error is not related to my use of autostart, because it works for me just fine with other applications.

I'm also using a freshly set up and updated Lubuntu 16.04 LTS VM under Virtualbox to make sure it does not interfer with other configurations on my productive system.

  • Each line, including the last line, in ~/.config/openbox/autostart has to end with a space followed by &. You could also insert sleep ns (where n is the number of seconds) at the start of a line and that may help. – DK Bose Apr 29 '18 at 17:21
  • @DKBose Alright - now my grapical interface does appear again. But it seems, that compton hasn't started at all, no effects are present, and ps -e doesn't list it either. – Wanderer Apr 29 '18 at 18:09
0

The experienced behavior consists of two separate problems.

  1. The problem with the disappearing graphical interface is related to the use of the option --unredir-if-possible. While this option works fine if used when invoking compton after boot, it causes the graphical interface to disappear if used when compton is invoked as part of the autostart procedure. I think this is an undocumented bug, at least I haven't found any note (while similar notes appear to indicate that this option has been proven to be problematic already). I haven't found a workaround, except for not using this option as part of the compton autostart command. So far, it appears that applications in fullscreen mode work fine anyways, therefore this solution appears to be acceptable.

  2. The problem with compton not starting or not showing the expected effects seems to be related to the point where compton gets invoked during the autostart procedure. The only point I have found that appears to work consistently, is via an entry in ~/.config/lxsession/Lubuntu/autostart. Here it is important, to write neither a leading @ nor a trailing &, despite what can be found amongst various examples on the web.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.