4

Good evening, morning or day to you, fellow Ubuntu users!

I have encountered a problem when trying to run Minecraft on Ubuntu MATE 18.04. I followed the instruction given on the website How to Geek How to Install Minecraft on Ubuntu or Any Other Linux Distribution, adding the repository for Oracle Java 8 etc. After downloading Minecraft.jar from www.minecraft.net I executed the file (java -jar Minecraft.jar), but...it didn't go exactly as expected. The output I got was:

Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma Exception: javax.net.ssl.SSLException: java.lang.RuntimeException: Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma (try 2/10)

...and so on.

Do you perhaps know how to solve this problem?

This information, displayed while launching Minecraft, may be of use:

System.getProperty('os.name') == 'Linux' System.getProperty('os.version') == '4.15.0-20-generic' System.getProperty('os.arch') == 'amd64' System.getProperty('java.version') == '1.8.0_171' System.getProperty('java.vendor') == 'Oracle Corporation' System.getProperty('sun.arch.data.model') == '64'

Any advice on this topic will be appreciated! Thank you in advance!

/Robert.

  • Maybe this will work for you? There are other suggestions in this question as well. – Hee Jin Apr 29 '18 at 17:16
  • Have a look at this question over at StackOverflow: stackoverflow.com/questions/6784463/…. It may be of help. I would try the suggestion to issue the command sudo /var/lib/dpkg/info/ca-certificates-java.postinst configure to setup your certificate trust store. – Malte Skoruppa Apr 29 '18 at 19:31
3

I had this same exact problem. What I did to fix it was:

sudo apt-get update & sudo apt-get install ca-certificates-java
sudo update-ca-certificates -f

Go to the Java website and download the .tar.gz linux file. Extract the file from the archive:

jdk-10.0.1_linux-x64_bin.tar.gz/jdk-10.0.1_linux-x64_bin.tar/jdk-10.0.1/lib/security/cacerts

Copy the file to

/etc/ssl/certs/java/cacerts
  • Worked perfectly! I didn't want to have to use snapcraft (personal technical preference more than anything), so I'm glad this worked! – CodeMouse92 Jun 27 '18 at 13:38
2

Just install Minecraft from Snap store-

sudo snap install mc-installer

Start the app after installation.

  • This was very quick and easy. Normally no need to reboot though. – Ian Petts Jun 21 '18 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.