10

I've had some weird internet issues since upgrading.

First of all, my wifi USB dongle stopped working so I thought it was broken, I replaced it and was getting speeds of under 1 Mbps.

Since then I have had very poor download speeds, and surfing has been a bit hit and miss with some sites loading instantly, and others crawling. everything was fine using the same hardware on 16.04

What can I do to speed things up?

Thanks!

  • Hi Syteanric, can you add some more information to your question? 1) The output of dmesg | grep Linux 2) The output of lshw -C network 3) The output of lsusb – Hee Jin Apr 29 '18 at 16:31
13

I just fixed this on ubuntu 18.04 - turns out there is some kind of issue with 802.11n and iwlwifi Intel chips. The solution is to turn it off.
Check if it works first with:

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi 11n_disable=1

Make it permanent with this command:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf

I did this and my wifi speeds instantly went back to normal.

  • This disables support for n-band wireless connections, correct? That should be noted in this answer if so. wiki.debian.org/iwlwifi – ckeeney Aug 21 '18 at 17:04
  • I changed the value 11n_disable=10 for obtaining maximum speeds on my Intel Wifi 5000 series card ... (Dell E6500 Latitude standard wifi card) . Also I turned off the 5Ghz option (dualband 2.4 / 5 Ghz) in the routersoftware and forced 1 channel only instead of automatic. This solved totally my problems with iwlwifi driver and dropping speeds . I did not tweak the powersave function (so as it is with Ubuntu ootb) . – Joris Donders Sep 27 at 8:25
0

I just fixed this on ubuntu 18.04 - turns out there is some kind of issue with 802.11n and iwlwifi Intel chips.

That's for sure 8-) ! With a Advanced-N 6200 in a computer I just picked up, I was getting freezes (no LEDs so I don't know if the kernel paniced..) within a minute or two once I started rsync'ing some files over. 11n_disable=1 solved this for me.

Update: Actually I had freezes with 11n_disable=1 also; I popped my case open and found the card was not fully seated!

Not the answer you're looking for? Browse other questions tagged or ask your own question.