5

I really love Ubuntu 18.04, but something is driving me nuts. Every time I'm typing and I accidentally touch the touchpad, my typing cursor jumps. On another post I found that this behavior can be solved in two ways:

  • By using syndaemon
  • By using the touchbar-indicator plugin

But on my system both methods seem to fail. For the touchbar-indicator, I just enabled the "auto disable touchpad" option, but that doesn't do anything. Then I configured syndaemon as a startup application like this:

/bin/bash -c "sleep 15 && syndaemon -i .8 -K -t -R -d"

If anyone knows what I can do about this behavior please tell me since I'm going mad. :p

Thanks a lot in advance

System info: - Intel® Core™ i7-6700HQ CPU @ 2.60GHz × 8 - HP Zbook G3 Studion

5

I solved my problem as follows:

  1. By using this forum post I fully reinstalled my xserver drivers.
  2. I then reinstalled the drivers following this forum post.
  3. I then added the following command to my startup applications:
    • syndaemon -i .5 -K -t -R -d

This disables tapping (-t) on my trackpad for half a second (-i) after any non-modifier+ (Shift,Ctrl,Alt,Super) (-K, vs -k) with the XRecord extension (-R), and to keep this service running in the background (-d).

You may try adjusting to your liking, and dropping the -R flag.

1
  • 1
    FYI, my Toshiba R705-P35 (Debian Jessie) required the -R option. Said command is in a file named /etc/X11/Xsession.d/98x11-syndaemon... – Digger Dec 5 '20 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.