25

How can I disable password request after suspend in v. 18.04? I have already turned off the screen lock but that didn't fix it.

I am brand new using Ubuntu. There seems to be lots of info on how to fix this in older versions.

  • 1
    Were are you turning off the screen lock? – L. D. James Apr 29 '18 at 13:58
  • 1
    Settings -> Privacy -> Screen Lock – Rookie Apr 29 '18 at 20:21
32

For most Ubuntu distributions and versions try this in the terminal:

gsettings get org.gnome.desktop.screensaver ubuntu-lock-on-suspend
true

If the result is true then set it to false using:

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend false

Just remember to reset it before your cleaning person comes over for monthly work.

  • Thanks for your response. I followed your directions. The result was true. I put in the command you provided and it responded command not found Did I do something wrong? – Rookie Apr 29 '18 at 20:19
  • @Rookie Don't put in the $ that represents what your display is asking you to enter. I modified the answer to reduce confusion. If this works for you don't forget to accept the answer so others know it works. As a new user you may not be away you can click the check mark beside the answer. – WinEunuuchs2Unix Apr 29 '18 at 20:20
  • thank you this works.when you press windows key (super) and l it will lock the system so you can lock it after this. – Dummyxl Jun 30 '18 at 21:17
  • Thank you so much been trying to figure this for months :) – Jinx13 Jul 3 '18 at 22:37
  • hmm. This didn't work for me on ubuntu 18.10. The commands described above didn't seem to have any problem. The first returned a true, I changed it to false, ran the first again and it returned false. I still have to type in my password when I wake the computer up from a blanked screen. – Selwyn Polit Feb 6 at 3:22
7

Disable screen lock after suspend by installing dconf-editor

sudo apt install dconf-editor

then navigate to

org/gnome/desktop/screensaver and turn off ubuntu-lock-on-suspend.

enter image description here

4

You can disable the password from suspend in 18.04 by going into Settings -> Privacy -> Screen Lock -> [Click he Slider from On to Off]

  • Did not work for me. WinEunuuchs2Unix's method worked, but as he notes, one has to remember this. – Keith McClary Apr 29 '18 at 19:46
  • this does not stop the screen lock activating when resuming from suspend. – Tim Richardson May 25 '18 at 3:13
  • For me the settings were all gayed out and inaccessible in 18.04. I resolved that by "gsettings set org.gnome.desktop.lockdown disable-lock-screen false" to make the settings changeable again. – Bim Jul 29 '18 at 16:32
  • This doesn't work – Kennet Celeste Sep 7 '18 at 13:12
  • I am using Ubuntu 18.04 LTS and it did work for me -after following the steps it did not prompt me for my password which is what I wanted – Shew Feb 23 at 12:17
0

In Ubuntu 19.04, there is finally a method to configure this without executing commands:

  1. Open the "Settings" program, or start it with gnome-control-center.

  2. Navigate to "Privacy" and click on "Screen locking".

  3. Disable "Lock the screen in standby".

Internally, it has just the same effect as the command mentioned in another answer here:

gsettings set org.gnome.desktop.screensaver ubuntu-lock-on-suspend false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.