4

After I upgraded from 17.10, right click behaves like left click.

I'm using Dell Vostro 14.

It's always getting this error when I install Ubuntu starting from 16.04 yesterday, the error is still the same... touchpad and click.

Here's the output when I type xinput in my terminal

$ xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Sleep Button                              id=8    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD: Integrate           id=9    [slave  keyboard (3)]
    ↳ Intel HID events                          id=10   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
  • Same problem on my asus box after upgrading to 18.04. Trying to figure out how to resolve.. – g_p Apr 29 '18 at 12:15
  • Check 'System Settings > Mouse & Trackpad > Primary button > ' whether it is set as you would expect: Left or Right. – Hannu Apr 29 '18 at 12:39
  • 1
    See if these are helpful: askubuntu.com/questions/1029444/… askubuntu.com/questions/1028776/… – pomsky Apr 29 '18 at 13:02
  • @pomsky already try, but still doesn't work – iColdPlayer Apr 29 '18 at 14:22
  • I was checking for any issues by live-booting Ubuntu 18.04 on my Asus laptop. The secondary click button on the touchpad is not working. I always have to tap with two fingers to emulate secondary click functionality. – Shubham Apr 30 '18 at 9:43
1

I also encountered the same problem after upgrading from 16.04 to 18.04. I figured out that there was something wrong with settings.

Mouse & Touchpad settings

Just change primary button to left.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.