My system is booting from the USB drive the problem is that after booting it shows the menu to select an option. And on selecting any option it leads to a blank screen.

I am trying to boot Ubuntu 18.04 from a USB live stick. I waited for about half an hour too after selecting install Ubuntu option, but it's not working. I have Dell Vostro 3568 8GB RAM, i5 7gen with AMD Radeon. I have made the live USB from startup disk creator which is preinstalled in Ubuntu.

marked as duplicate by Eric Carvalho, George Udosen, Warren Hill, Elder Geek, Community May 1 at 22:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @karel my system is booting from USB. It is also showing options from grub menu i.e. trying without installing, install ubuntu etc. But on selecting any of the options it leads to a blank screen. – Kuldeep Pisda Apr 29 at 10:25
  • @karel ok trying mini.iso – Kuldeep Pisda Apr 29 at 10:37
  • 1
    Same happened to me on a Dell XPS 13 9370 as explained @KuldeepPisda – Amir Karimi Apr 29 at 14:56
  • @karel I got success but half I booted in legacy mode. And was only able to install and I had to change boot option to legacy. Now on loading it hangs to Ubuntu logo screen. And I tried mini.iso file too but it is not even loading. – Kuldeep Pisda Apr 29 at 15:11
  • I tried that but unable to access any of them. I tried advanced option too but it too sucks after selecting any option either recovery mode or generic. @karel – Kuldeep Pisda Apr 29 at 15:53
up vote 8 down vote accepted

So after much googling, I got the solution. It was very simple to fix that issue. It is about nomodeset.

  1. When the USB/CD boots press E on grub menu it will lead to edit the grub.

  2. Find the line which ends with quiet splash and add nomodeset in front of it. So it becomes nomodeset quiet splash. Whatever is there in front of it leave it as it is just add nomodeset in front of quiet splash.

    Grub edit menu

  3. Now press Ctrl+X to boot it normally. It will lead you to Try Ubuntu Without installing option. Now from here too you can install Ubuntu. As install Ubuntu option is always there in the live session. Now after installing Ubuntu we need to change nomodeset thing permanently so that we don't have to do it again.

  4. After successfully installing the system will reboot. Press shift button for 5 seconds to get the grub menu after the system starts. If it does not work then try the same with Esc. The most important thing is that it is all about timing.

  5. Now again repeat step 2 so that we can login in the system.

  6. Now open a terminal and type sudo nano /etc/default/grub it will be having contents similar to this.

    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    GRUB_CMDLINE_LINUX=""
    
  7. Find the line having quiet splash and add nomodeset in front of it.

  8. Now save it with Ctrl+O and exit it with Ctrl+X. In order to update grub menu enter:

    sudo update-grub
    

Source and credits

Update and Edit 1

After the above, I was able to boot and install Ubuntu 18.04. I was not able to control screen brightness after installing and setting grub setting as nomodeset so after searching on StackOverflow further I came across this question and I also got to know that nomodeset is a temporary fix. I updated my kernel and after this, I changed grub setting as it was earlier, i. e. removing nomodeset in /etc/default/grub and updated grub. Now it's working awesome.

Try Display brightness cannot be adjusted 18.04 if you face issues such as unable to control screen brightness.

  • So the real fix was to update the kernel after installation? can you specify on how – pantos27 May 21 at 13:10
  • 1
    @pantos27 yes I have attached that question too. Click on Read Here to read the steps to update the kernel. – Kuldeep Pisda May 21 at 14:46
  • are you using a Dell laptop by chance? if so which kernel did you use? – pantos27 May 22 at 10:18
  • 1
    @pantos27 yes I am still using a Dell Laptop and my kernel version is 4.16.6-041606-generic – Kuldeep Pisda Jun 1 at 8:18
  • 1
    Note: Whatever is there in front of it leave it as it is just add monodeset in front of quiet splash – drescherjm Jun 24 at 14:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.