2

I upgraded Ubuntu 17.10 to version 18.04 LTS .... and unfortunately I encountered a problem with the network card / driver: sky2

sky2 ethernet stops working after system resume from suspend !

I returned again from backup to version 17.10 .....

but I checked a few releases of Ubuntu LTS for example Xubuntu 18.04 / Lubuntu 18.04 / mod Voyager LTS 18.04 in LIVE version Everywhere this error occurs:

sky2 ethernet stops working after system resume from suspend !

help trick / script / entry in the terminal:

..........................

sleep 5
case $1/$2 in
post/*)
sudo systemctl restart network-manager.service
modprobe -r sky2
modprobe sky2
;;
esac

chmod +x !

..................................

this is probably related to the kernel version on Ubuntu 17.10 is: 4.13.0-39 on version LTS 18.04 kernel 4.15.0-20

06:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] [11ab:4381] (rev 11)
    Subsystem: Samsung Electronics Co Ltd Yukon Optima 88E8059 [PCIe Gigabit Ethernet Controller with AVB] [144d:c06a]
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 24
    Region 0: Memory at f5420000 (64-bit, non-prefetchable) [size=16K]
    Region 2: I/O ports at b000 [size=256]
    Expansion ROM at f5400000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: sky2
    Kernel modules: sky2
1
  • will there be a patch like kernel or do I need to use this script fix? – kris777 Apr 29 '18 at 11:19
0

This problem is discussed on the bug reporter at: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1758507

According to the thread, a solution should be coming soon. :)

-1

OK ...problem solved I checked dmesg .....error: [ 380.567633] do_IRQ: 3.34 No irq handler for vector

I applied fix to grub file : pci=nomsi,noaer

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nomsi,noaer"

update-grub / reboot and everything works fine ??? :-)

1
  • or GRUB_CMDLINE_LINUX_DEFAULT="quiet splash sky2.disable_msi=1" – kris777 Sep 10 '19 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.