0

I just assembled a new computer with an Intel Core i7-2600K CPU and I am using the integrated Intel HD Graphics 3000 graphics processor. I have an Asus P8Z68V-LE mother board that has a VGA, DVI and HDMI output. I have a Samsung monitor to the DVI port and an Acer monitor connected to the HDMI port. Both monitors are detected by the Displays utility and the Acer monitor works just fine, but I can't get the Samsung monitor to work when I am at my Unity desktop.

When I first installed Ubuntu, the Displays utility showed both monitors as enabled with mirrored displays. The Samsung monitor appeared to be getting a video signal, but the display was blank.

At the moment, I have the Acer monitor enabled and Samsung monitor disabled in the Displays utility and the Samsung monitor has gone to sleep. If I try and enable both monitors with a mirrored display again (using a resolution of 1680x1050), I get a dialog box showing with the error "could not assign CRTCs to outputs".

If I try and enable the Samsung monitor and use and extended desktop across the two displays, the Samsung monitor wakes up and I can drag windows over to it, but it shows nothing on the screen.

When the computer boots, both monitors show the same content at the EFI screen and at the GRUB screen. Both monitors show a light purple background while Ubuntu loads. I only seem to have a problem with the second monitor after I get to the desktop screen. Additionally, if I boot into Windows, both monitors work with an extended desktop without any problem.

Hopefully someone can shed some light on this issue. I thought I better post here before reporting a bug against xserver-xorg-video-intel. Thanks! :)

0

Answer: Yes, it's supported, but as James Henstridge pointed out, there is a bug in the driver when the HDMI port is used. Use the VGA + DVI ports for two monitors as a workaround until the bug gets fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.