115

Can I use Ctrl+Shift for changing languages? I can't set this hotkey for changing keyboard languages.

At this moment Alt+Shift switch languages, but I can't see this hotkey in keyboard hotkeys list or in

gsettings list-recursively  org.gnome.desktop.wm.keybindings | sort | more

output.

219

You can set such keyboard shortcut as follows:

  • On Ubuntu 18.04 LTS, 19.10 and 20.04 LTS with GNOME desktop from GNOME Tweaks.

    1. Install it

      sudo apt-get install gnome-tweaks
      
    2. Then open GNOME Tweaks (gnome-tweaks).

    3. Select Keyboard & Mouse tab
    4. Click Additional Layout Options button
    5. Expand Switching to another layout
    6. Select Ctrl + Shift here

    See screenshot below:

    GNOME Tweaks - set <Ctrl+Shift>

    Or simply:

    gsettings set org.gnome.desktop.input-sources xkb-options \
    "['grp:ctrl_shift_toggle']"
    

    If you do not like Super + Space and Shift+Super+Space you can disable them with

    gsettings set org.gnome.desktop.wm.keybindings switch-input-source "['']"
    gsettings set org.gnome.desktop.wm.keybindings switch-input-source-backward  "['']"
    gsettings set org.freedesktop.ibus.general.hotkey triggers "['']"
    

    Note: you will face interference problem as Ctrl+Shift+T in GNOME Terminal will switch language at once with opening new tab. It is known bug 1683383.

  • On Ubuntu MATE 18.04 LTS and newer versions this is possible from mate-keyboard-properties:

    1. Open MATE Control Center
    2. Click Keyboard
    3. Go to Layouts tab
    4. Click Options
    5. Expand Switching to another layout
    6. Select Ctrl + Shift here

      See screenshot below:

      MATE Control Center keyboard

      Or simply:

      gsettings set org.mate.peripherals-keyboard-xkb.kbd options \
      "['grp\tgrp:ctrl_shift_toggle']"
      

      Note: here bug 1683383 is fixed by packages from my PPA :

      sudo add-apt-repository ppa:nrbrtx/xorg-hotkeys
      sudo apt-get update
      sudo apt-get dist-upgrade
      

      So Ctrl + Shift keyboard layout switcher will work normally on MATE DE after applying patch from ArchLinux AUR "for freedesktop bug 865 (need to kick hotkeys on release, not press)".

      Warranty disclaimer: packages were tested in

      • 16.04 LTS with HWE (Unity, MATE, Xfce)
      • 18.04 LTS (Cinnamon, KDE, MATE, Xfce)
      • 18.10 (Cinnamon, KDE, MATE, Xfce)
      • 19.04 (Cinnamon, KDE, MATE, Unity, Xfce).
      • 19.10 (Cinnamon, KDE, MATE, Unity, Xfce)
      • 20.04 LTS (Cinnamon, KDE, MATE, Unity, Xfce)

      However other desktops may have issues even after applying the patch.
      These packages do not fix problems for GNOME Shell (18.04 LTS, 18.10, 19.04, 19.10 and 20.04 LTS) and Unity (in 18.04 LTS and 18.10).


If you are interested you can participate in poll and discussion on community.ubuntu.com.

| improve this answer | |
  • 6
    gnome-tweaks broke text selection via ctrl+shift+arrow :( Does another solutions allow such text selection? – Hayate Apr 30 '18 at 5:34
  • 3
    Works fine on Ubuntu 18.04.1 LTS. – Hemã Vidal Sep 10 '18 at 0:46
  • 2
    Thanks, it works fine :) It is really sad that you can't do that without installing a program, bad UX. – gdaras Nov 24 '18 at 13:15
  • 2
    @MikhailBoyarsky the solution is to ignore GNOME and use any other DE instead. The packages from my PPA was tested on Cinnamon, KDE, MATE, Unity, Xfce. – N0rbert Feb 28 at 13:47
  • 1
    I read your thread, indeed it is very huevo that gnome maintainers dont pick existing patches about shift alt or so. It is totally doable and worked forever on windows. – Mikhail Boyarsky Feb 29 at 1:49
16

I found a partial workaround based on other answers for using Ctrl+Shift and shortcuts for GNOME in Ubuntu 18.04:

  1. Install GNOME Tweaks as proposed in N0rbert's anwser:

    sudo apt install gnome-tweaks
    

    then:

    • run it;
    • open "Keyboard & Mouse" tab;
    • click "Additional Layout Options" button;
    • instead of selecting Ctrl+Shift key combination in "Switching to another layout" of "Additional Layout Options" window simply untick all checkboxes:

    Additional Layout Options

  2. Open "Settings" application from "Show applications" menu at the left bottom corner. Alternatively run a command in terminal:

    gnome-control-center
    

    then

    • go to "Devices" > "Keyboard" tab;
    • scroll to "Typing" group;
    • set shortcuts for "Switch to next input source" and "Switch to previous input source" (an order of keys DOES MATTER!!!):

    Keyboard settings

    If setting Ctrl+Shift or Shift+Ctrl shortcuts is impossible using this dialog (as it was in my case), then you can change these parameters in an alternative way:

    • install dconf-editor:

      sudo apt install dconf-editor
      
    • run it from terminal:

      dconf-editor
      
    • go to org > gnome > desktop > wm > keybindings;

    • select switch-input-source or switch-input-source-backward;
    • switch off "Use default value" and input "Custom Value": <Control>Shift_L for changing layout with Ctrl+Shift or <Shift>Control_L — for changing layout with Shift+Ctrl:

    dconf-editor

    Another way is to use gsettings set console command as proposed here:

    gsettings set org.gnome.desktop.wm.keybindings \
    switch-input-source "['<Control>Shift_L']"
    

A limitation of this solution is that an order of keys pressed is important. If you set Ctrl+Shift to change keyboard layout then it will work only when you press Ctrl key first, and then Shift key. Pressing Shift key first and Ctrl after will not work in this case. But this fact allows to use shortcuts containing Shift and Ctrl keys combination in different applications , for example:

  • Shift+Ctrl+T to open new tab in Terminal;
  • Shift+Ctrl+E to export image in Gimp;
  • Shift+Ctrl+F to open search dialog in WebStorm/PhpStorm.
| improve this answer | |
  • Thanks for the note about Shift and Ctrl ordering – reddot Mar 13 '19 at 9:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.