9

I installed Ubuntu 18.04 on VirtualBox and then set the 3D acceleration ON and when I try to start it, it shows and stays like this:

Screenshot

It worked fine with Ubuntu 16.04 and 17.10 but doesn't work with 18.04. I have Windows 10, Nvidia GPU, latest Virtualbox and drivers. I'm using GNOME with Xorg.

1

Using the .iso provided in the Ubuntu repository (https://packages.ubuntu.com/bionic/all/virtualbox-guest-additions-iso/download) resolved this issue for me on Virtualbox 5.2.8. On Windows just download and extract the .iso using 7zip or similar.

0

Check the version of VirtualBox you're running. Upgrading to the latest version (5.2.10) of VirtualBox as well as the guest additions package resolved the issue for me.

  • I thought I had the latest version because when I checked for new updates it said I was running the latest version. I'll try the new version – Venoox Apr 30 '18 at 8:29
  • 1
    Ok, so seems like the reason why it works on VB 5.2.10 is because there is no 3D acceleration happening in Ubuntu (even though it's enabled on the VM). So this resolved my problem only to the same extent as would disabling 3D acceleration. – jakri Apr 30 '18 at 8:41
  • 1
    I'm using v5.2.10 with Ubuntu 16.04 as host and 18.04 as guest. I still see the option to enable 3D support for the guest which keeps causing the same problem. Upgrading didn't solve anything but disabling 3D support did – Felipe May 1 '18 at 17:18
  • 2
    5.2.10, same issue. – Diesel May 2 '18 at 3:19
0

see also https://forums.virtualbox.org/viewtopic.php?f=3&t=87919

... or to choose Gnome Classic from the login cog. That works too.

Worth reading: https://www.virtualbox.org/wiki/X11Guest3D

  • so, what is the solution? – Sebastian Stark May 10 '18 at 21:22
  • VirtualBpx 5.2.12 has fixed the issue – Edoardo Comar May 10 '18 at 22:14
  • 1
    Upgrading to 5.2.12 Did not fix for me... it is still slow and when I call `glxgears' it hangs the interface while the gears keep spinning. – rodvlopes May 11 '18 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.