I just installed Ubuntu 18.04 after deleting Ubuntu 17.10, I created a back up on my usb drive but Ubuntu 18.04 won't restore the files as it says "RESTORE FAILED Failed to execute child process “duplicity” (No such file or directory)"

I do not have any other copies of my ancient files and those are very important to me, can you help get my files restored, please?

Thank you very much.

2 Answers 2


After installing a new copy of Ubuntu 18.04 you need to install duplicity before the files can be restored. Use this command:

sudo apt install duplicity

Disclaimer: I don't use duplicity myself.

  • I thought that came pre-installed on Ubuntus? Apr 29, 2018 at 5:25
  • @GeorgeUdosen I'll have to reboot to try 18.04 but typing $ duplicity on 16.04 it says: The program 'duplicity' is currently not installed. You can install it by typing: sudo apt install duplicity Apr 29, 2018 at 5:27
  • Good to know never knew! Apr 29, 2018 at 6:20
  • @WinEunuuchs2Unix, thank you very much, it solved the problem but now, it says "STORAGE LOCATION NOT AVAILABLE, Waiting for Google to be configured in your backup settings..." Apr 29, 2018 at 15:40
  • @HarpartapSC Glad that part got fixed. You'll need to post a new question on the second problem. Be sure to put the "Duplicity - storage location not available, waiting for Google" in the title. Someone who uses Duplicity can tell you how to configure that part. Apr 29, 2018 at 15:47

I did install "duplicity" but it still not works. I am not new to Ubuntu and all the previous upgrades, backup and restore work perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.