As mentioned in the title. Was upgrading from 17.10. Having this screen flickering.

My GPU is AMD RX480

What I did:

  • Search for similar issues for 18.04, can't find any
  • Perform fresh install. Still the same.

Please help. It is very annoying. I can't work.

up vote 5 down vote accepted

I solved it myself by using amdgpu.dc=0 as a boot parameter.

To do this, edit the file /etc/default/grub, for example using

sudoedit /etc/default/grub

Find the line beginning GRUB_CMDLINE_LINUX_DEFAULT and add the text amdgpu.dc=0 between the double quotes (""). Leave any other parameters as they are. For example, you may end up with a line like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.dc=0"

Save the file and exit, and then run

sudo update-grub

to write the configuration, and reboot.

  • Getting a black screen, answer doesn't work any more? – Gabor May 9 at 2:17
  • I had this problem and your solution worked! +1 – I. Renk May 17 at 19:20

I've no answer here, but some observation and confirmation of problem. If someone finds this text: please stick to ubuntu 17.10 if you have radeon rx 580 (may be 480 and vegas)

Got myself to very same situation with 18.04 (upgrade, then fresh install). Amd rx 580 here, kernel 4.15.0-20.

What did not help:

  • fresh install after upgrade
  • oibaf drivers
  • M-Bab custom kernel
  • 4.17-rc3 kernel from main line ppa.
  • amdgpu.dc=1 as boot parameter (/etc/default/grub)

Update: Apparently older kernel works. I've been tinkering with other distibutions and found that kernel 4.15.14 works for rx 580, you may want to try it from mainline ppa.

  • Hi, try amdgpu.dc=0. It solves the problem. – nschong May 5 at 1:57
  • Kernel 4.15 is no longer maintained by Linux Kernel developers. You can also try the 4.14 chain from the same mainline PPA. It is maintained for 5 or 6 years. I'm using 4.14.34 myself as 4.14.36 and 4.14.37had symbolic link bugs which prevented installing. – WinEunuuchs2Unix May 12 at 22:31

I have screen flickering problem when I'm connecting my laptop to my TV. I found that when I change the refresh rate from 60Hz to 59Hz this problem disappear.


Within Xorg (as I know 18.04 uses it by default) you can change the refresh rate by the help of xrandr:

0. First you must find the video output name to which you should assing the new mode. Just type xrandr and investigate which one is it. In my case this is HDMI-1.

1. Generate new modeline using cvt:

$ cvt 1920 1080 59
# 1920x1080 58.94 Hz (CVT) hsync: 66.02 kHz; pclk: 169.00 MHz
Modeline "1920x1080_59.00"  169.00  1920 2040 2240 2560  1080 1083 1088 1120 -hsync +vsync
  • 1920 and 1080 are the horizontal and vertical resolution's values.
  • 59 is the value of the refresh rate.

2. Create the new mode:

xrandr --newmode 1920x1080_59.00  169.00  1920 2040 2240 2560  1080 1083 1088 1120 -hsync +vsync

3. Assign the new mode to the video output:

xrandr --addmode HDMI-1 1920x1080_59.00

4. Activate the new mode:

xrandr --output HDMI-1 --mode 1920x1080_59.00

If the above works and the problem disappear, you should find a proper way to add and set this mode at the system startup. Here are few references about that:

Turn off the automatic brightness control to fix this.

I faced a similar problem,I wasn't able to log in with the graphical mode at all, I solved it by :
1- enter to tty mode (ctrl+alt+f5, en my case)
2- adding open grafic Drivers (https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers):

      sudo add-apt-repository ppa:oibaf/graphics-drivers
      sudo apt-get update

3- reboot
4- enter into tty mode again
5-

 sudo apt update && sudo apt full-upgrade
6- reboot and it works fine!!
hope it helps.

  • Thank you very much @Hassan for sharing the instructions. In my case I cannot get into the tty. Just to make sure, where do you ctrl+alt+f5? Does your computer have a fn key? – Delosari Jul 14 at 23:01

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.