30

The audio on everything is gone, nothing in browsers or viewers. I just downloaded 18.04, but it didn't work on 16.04 either. I can watch videos fine but only with missing sound.

These are my specifications:

  • Details: Memory-3.8 Gib
  • Processor-Intel® Atom™ x5-Z8350 CPU @ 1.44GHz × 4
  • Graphics-Intel® HD Graphics (Cherrytrail)
  • GNOME- 3.28.1
  • OS Type-64bit
  • Disk-61.3Gib
  • Have you chosen the right output in Settings > Sound? – Nis Apr 29 '18 at 6:47
  • there are no options there – Shane.D Apr 29 '18 at 7:42
40

This worked just fine for me :

  1. Open a terminal :

    sudo apt-get install pavucontrol
    pavucontrol
    
  2. Go to configuration and set the Profile to: Analog Stereo Out

Then enjoy :)

| improve this answer | |
  • 2
    This work for me, i have a monitor hdmi, and I put configuration > Digital stereo HDMI – DarckBlezzer Oct 19 '18 at 5:16
  • In configuration i havent option for HDMI,i try on hundred ways,does Analog stereo out give us sound through HDMI? – Goran_Ilic_Ilke Jul 29 '19 at 11:12
  • Is there any way to write a batch script that will do this? It happens to me just about every time I unplug and plug in my monitor to my laptop. It is not optimal to do this every time – Jac Frall Oct 17 '19 at 14:27
  • Tried everything related to this question but still no sound. :( – CodeRunner Jan 11 at 7:49
  • It worked for me but it is a BUG because yesterday I was using the HDMI cable to duplicate the monitor in the tv and play sound with the tv by selecting HDMI exit sound in ubuntu settings. With the pc turned off I removed the HDMI from the tv but since that ubuntu doesn't automatically setted the exit sound to the default till in the settings there is only that option and till I selected it, ubuntu was still trying to reproduce the audio via HDMI... – user2342558 Feb 22 at 10:02
15

This tutorial worked for me when I had 16.04. It also worked for me with 18.04, but I didn't do all of the steps.

What I did was to skip all of the steps, tried this in terminal that I saw in another posting.

pulseaudio --start

and then went straight to step 6.

sudo apt-get install pavucontrol

then run

pavucontrol

With this opened, I went to the Output Devices tab and changed the Port to Line Out (unplugged). And then I saved the icon in the launcher to add to favorites. Whenever you restart or start up your system, you might need to set this setting. I wish there was an automated setting where it is always set. I also changed my configuration to analog stereo output and then moved the slider under the port setting in the Output Devices tab from Silence to 100% (0dB).

To automate it, after setting volumes through pavucontrol, from terminal:

alsactl store

and autorun at login the restore command (probably both by sudo, whitelisting the command on sudoers to not ask password)

alsactl restore

Let me know if this helps.

| improve this answer | |
  • 2
    As I pressed enter on pulseaudio --start, it says Daemon startup failed. I then did sudo pulseaudio --start and it said "This program is not intended to be run as root (unless --system is specified). – Shane.D May 5 '18 at 3:44
4

I had this problem when I connected my Computer to TV through HDMI, and then I turned-off the TV or disconnected the HDMI cable.

To fix it, I connected again the HDMI cable and went to settings, I chose PC's speakers to develop sound instead of TV's speakers.

| improve this answer | |
  • 2
    I have the exact same issue but was wondering if this is fixable without an HDMI cable – evan54 Jan 5 '19 at 14:32
  • Echoing @evan54. I've same issue and wondering the same.. – Arya May 22 '19 at 22:25
1

I had this same situation.

I looked for software solutions to this for days.

Tried a new HDMI cable... that fixed the problem.

Just sayin': that might work for you, too.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.