24

The audio on everything is gone, nothing in browsers or viewers. I just downloaded 18.04, but it didn't work on 16.04 either. I can watch videos fine but only with missing sound.

These are my specifications:

  • Details: Memory-3.8 Gib
  • Processor-Intel® Atom™ x5-Z8350 CPU @ 1.44GHz × 4
  • Graphics-Intel® HD Graphics (Cherrytrail)
  • GNOME- 3.28.1
  • OS Type-64bit
  • Disk-61.3Gib
  • Have you chosen the right output in Settings > Sound? – Nis Apr 29 '18 at 6:47
  • there are no options there – Shane.D Apr 29 '18 at 7:42
30

This worked just fine for me :

  1. Open a terminal :

    sudo apt-get install pavucontrol
    pavucontrol
    
  2. Go to configuration and set the Profile to: Analog Stereo Out

Then enjoy :)

  • 1
    This work for me, i have a monitor hdmi, and I put configuration > Digital stereo HDMI – DarckBlezzer Oct 19 '18 at 5:16
  • 1
    works for me.. thanks! – imsrgadich Mar 6 at 14:59
  • In configuration i havent option for HDMI,i try on hundred ways,does Analog stereo out give us sound through HDMI? – Goran7777 Jul 29 at 11:12
  • Is there any way to write a batch script that will do this? It happens to me just about every time I unplug and plug in my monitor to my laptop. It is not optimal to do this every time – Jac Frall Oct 17 at 14:27
10

This tutorial worked for me when I had 16.04. It also worked for me with 18.04, but I didn't do all of the steps.

What I did was to skip all of the steps, tried this in terminal that I saw in another posting.

pulseaudio --start

and then went straight to step 6.

sudo apt-get install pavucontrol

then run

pavucontrol

With this opened, I went to the Output Devices tab and changed the Port to Line Out (unplugged). And then I saved the icon in the launcher to add to favorites. Whenever you restart or start up your system, you might need to set this setting. I wish there was an automated setting where it is always set. I also changed my configuration to analog stereo output and then moved the slider under the port setting in the Output Devices tab from Silence to 100% (0dB).

To automate it, after setting volumes through pavucontrol, from terminal:

alsactl store

and autorun at login the restore command (probably both by sudo, whitelisting the command on sudoers to not ask password)

alsactl restore

Let me know if this helps.

  • 2
    As I pressed enter on pulseaudio --start, it says Daemon startup failed. I then did sudo pulseaudio --start and it said "This program is not intended to be run as root (unless --system is specified). – Shane.D May 5 '18 at 3:44
4

I had this problem when I connected my Computer to TV through HDMI, and then I turned-off the TV or disconnected the HDMI cable.

To fix it, I connected again the HDMI cable and went to settings, I chose PC's speakers to develop sound instead of TV's speakers.

  • 2
    I have the exact same issue but was wondering if this is fixable without an HDMI cable – evan54 Jan 5 at 14:32
  • Echoing @evan54. I've same issue and wondering the same.. – Arya May 22 at 22:25

protected by Community Aug 15 '18 at 15:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.