I have installed Ubuntu 18.04 LTS on my HP Pavilion series laptop. After installing this version of Ubuntu, right click is not working of my touchpad. How can I solve this? BTW: This question does not have any solution which which is working for me.
PS:- Problem remains after selection area in gnome-tweak-tool

  • See if this helps: askubuntu.com/questions/1028776/…
    – pomsky
    Apr 28, 2018 at 22:05
  • Would you be so kind as to expand your question with further detail? I see that the called duplicate didn't have any solutions that worked for you, but what I can't see is exactly what happened for each of the 2 solutions in the accepted answer that you tried. Thank your for helping us help you!
    – Elder Geek
    May 1, 2018 at 23:10
  • I have the same problem, and I followed the tutorial on this website and proved successful siskom.xyz/2018/05/…
    – Kirana
    May 7, 2018 at 13:17
  • I have the same problem on a system76 computer. tweaks has an option that doesn't seem to work for me when selected and I'd rather have both behaviors instead of choosing one or the other. any other ideas?
    – neuromage
    May 11, 2018 at 21:44
  • so the tweaks works I needed to log out and log in again for the effect to work. But I'd really rather have both options on at the same time is there any way to do that?
    – neuromage
    May 11, 2018 at 21:50

3 Answers 3


For instance, to right-click method on touchpads without a physical button you need to perform a two-finger click (just tap anywhere with two fingers). Clicking in the bottom right area of the touchpad no longer works.

If you don’t like this behaviour — and there’s a fair chance you might not — you can use the Tweaks app (see step #5) to change the setting.

Source: OMG Ubuntu (see link for how to fix it)

  • 13
    stuff like this really needs to be highlighted in the changelog May 11, 2018 at 13:27
  • 2
    I take it back - the multi click emulation still works even when I switch back to using click emulation, so I still have both :)
    – El Yobo
    May 15, 2018 at 0:44
  • 1
    woow!!! I thought my update is corrupt but this is awesome I love ubuntu May 29, 2018 at 7:10
  • 1
    Even though I have a physical mouse button it was not working. However, selecting Area mouse click emulation in Gnome Tweaks solved the issue. The physical button now works as right clicking.
    – Kvothe
    Jun 12, 2018 at 14:27
  • 1
    Thank you @OrganicMarble It was a great relief. I liked this new feature though this change would have been highlighted while installation.
    – Gagan
    Jan 8, 2019 at 16:06

I too had this issue with an HP Omen.. I downloaded the gnome tweaks and it fixed the problem.

Open Ubuntu software (orange briefcase) and type in the search "gnome tweaks".. launch the program and under keyboard and mouse tab>Mouse click emulation> choose AREA..click bottom right.....

Log out and re-login if the change didn't take effect right away.

screen shot

  • Which problem did it fix? Did it switch from two-finger tap to bottom-right click or enable both? Oct 15, 2018 at 21:02
  • 1
    Randy.. for me it fixed the R click on my touchpad (there are no R or L buttons on the touchpad). At the bottom of Gnome Tweaks, it has "Area" section that I clicked on (put a check mark to enable). And now the touchpad works as it should.
    – Wr3nch3r
    Oct 15, 2018 at 23:46
  • This works for me! upgrade from ubuntu 17.10 to 18.04, then right click of my laptop(ASUS ROG series) touchpad broken. Dec 13, 2018 at 3:34
  • @Wr3nch3r There was no need of logout Mar 26, 2019 at 8:31
  • This worked, but I did have to completely reboot. Restarting gnome-shell didn't apply the change.
    – Cerin
    Apr 4, 2019 at 17:33


sudo vi /etc/X11/xorg.conf


Section "InputClass"
  Identifier "libinput touchpad catchall"
  MatchIsTouchpad "on"
  MatchDevicePath "/dev/input/event*"
  Driver "libinput"
  Option "Tapping" "True"
  Option "NaturalScrolling" "True"
  • if you're missing xorg.conf consider the following which works on ubuntu-based builds: sudo mkdir /etc/X11/xorg.conf.d; cd /etc/X11/xorg.conf.d; sudo nano 01-input.conf; then copy/paste the Section configuration listed above
    – henry74
    Mar 24, 2020 at 0:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .