I recently installed Ubuntu 18.04 and discovered that the fractional scaling option that was in 16.04 is no longer there. 200% is too big for my display, and this answer didn't work for me (the options didn't change after running the command).

Is there another way to get fractional scaling?

  • 6
    This seems to be a problem especially for laptop users. Just downloaded 18.04 on a desktop and laptop. Laptop has a hi-res lcd screen which means 100% is far too small or 200% far too big. If dynamic scaling is out of the question 150% option would be an okay palliative. – Andrew Apr 29 at 17:17
  • 1
    This isn't a proper answer to your question, but I tried Ubuntu MATE today and I've been astonished by how good the HiDPI support is. It literally Just Worked for me. – N3dst4 Apr 29 at 18:18
  • 2
    16.04 just had this. Upgrade to the next LTS and it feels like one big downgrade :( WTF – Sentient May 23 at 20:18
  • 1
    Be aware that snap apps, which Canonical seem to think are the future, do not respect your theme. Which includes font scaling (I don't know about display scaling). They need to realize the theme is not just about looking pretty, it can be about usability. Most snap apps are unusable on my Dell XPS 13 due to this. Same problem with wine. – B.Tanner Aug 23 at 5:58
  • 1
    We have to wait for the issues in gnome-shell and mutter to be resolved and for the changes to be merged. – caw Dec 6 at 17:23

10 Answers 10

gsettings set org.gnome.desktop.interface text-scaling-factor 1.2

This command is not display scaling. Just a little text-scaling trick for solving HiDP problem on Ubuntu. Still finding for the perfect solution.

  • Great! This works for me, too!! Thank you!!! – William DeMeo Jun 16 at 3:11
  • 1
    ...but I'll never remember that. Here's a thought: define function setzoom() { gsettings set org.gnome.desktop.interface text-scaling-factor "$@"; } (say, in your bash config file), then you can simply type setzoom 1.2 in the future. – William DeMeo Jun 16 at 7:01
  • This is font scaling not display scaling the OP is asking about. – Basel Shishani Aug 22 at 7:55
  • Yes, you are right. It's not display Scaling. I should state clearly about that. I will update the answer. Thanks for pointing this out. :D – Min San Aug 23 at 4:16
  • will this persist after reboot? – dan carter Oct 18 at 8:08

Solution 1

The Archwiki proposes a solution (or rather a hack) with xrandr (if you use standard Ubuntu 18.04 with xorg):

ArchWiki - HiDPI - fractional scaling

Fractional Scaling

A setting of 2, 3, etc., which is all you can do with scaling-factor, may not be ideal for certain HiDPI displays and smaller screens (e.g. small tablets).

xorg

You can achieve any non-integer scale factor by using a combination of GNOME's scaling-factor and xrandr. This combination keeps the TTF fonts properly scaled so that they do not become blurry if using xrandr alone. You specify zoom-in factor with gsettings and zoom-out factor with xrandr.

First scale GNOME up to the minimum size which is too big. Usually "2" is already too big, otherwise try "3" etc. Then start scaling down by setting zoom-out factor with xrandr. First get the relevant output name, the examples below use eDP1. Start e.g. with zoom-out 1.25 times. If the UI is still too big, increase the scale factor; if it's too small decrease the scale factor.

xrandr --output eDP1 --scale 1.25x1.25

Solution 2: Wayland session

At the login prompt choose Settings -> 'Ubuntu with Wayland' and enable experimental fractional scaling:

wayland

Enable fractional Scaling experimental-feature:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

Then open Settings -> Devices -> Displays

  • 1
    How do you get the relevant output name? And where do you put this xrandr command so it's run automatically at the right time? – Gervase Markham Apr 30 at 15:33
  • The hack with xrandr works event though is not natural. – Sasha MaximAL May 3 at 7:01
  • 2
    The display looks nice, with the xrandr fix, however I can't move my mouse over the whole screen. Any Idea to fix this? – flocki May 10 at 8:48
  • 4
    Solution 2 (Wayland) worked, but only showed options: 125%, 150%, and 175% after a reboot. – david6 Jun 20 at 23:57
  • 1
    You could find relevant output from xrandr -q, output wich is 'connected'. For the mouse 'invisible boundaries', you should add --panning 1920x1080 option (with you resolution) – Adara Hv Sep 17 at 18:21

Install Gnome Tweak Tools => Fonts => Scaling Factor

At least it help to scale text bigger.

Actually I like this approach, it keeps other things at scaling 1, I only need the texts to be bigger.

enter image description here

  • Worked great for me. I can see the difference between scaling 1.00 and 1.01. – Gene Olson Sep 23 at 2:32

I used Unity Tweak Tool in Ubuntu 16.04. I'm running now a test environment where 16.04 was upgraded to Ubuntu 18.04 LTS. I just checked and Unity Tweak Tool is still there and scaling my High DPI screens properly. The settings I'm using for scaling on a 1920x1080 monitor are:

Tweak fonts.png

The Text scaling factor scales both fonts and UI elements like title bars, buttons, etc.


Icon size is preset but the text size under it increases giving the illusion the icon size changed:

UbuntuTweakFonts.gif

In the .gif above scaling starts at 1.38 on a 1920x1080 monitor. Then it is changed to 1 and everything gets tiny, which is normal. Then it is changed to 2 which is ideal for the visually challenged. Once again the icons have fixed pixel size and the font shrinking or expanding under the icon gives the illusion their size is changing.


To install Unity Tweak Tool use:

sudo apt install unity-tweak-tool

Others may be interested in the full suite of tools available in 18.04 LTS:

$ apt list | grep tweak
gajim-rostertweaks/bionic,bionic 1.0.0-3 all
gnome-tweak-tool/bionic,bionic 3.28.1-1 all
gnome-tweaks/bionic,bionic 3.28.1-1 all
mate-tweak/bionic,bionic 18.04.16-1 all
mousetweaks/bionic,bionic,now 3.12.0-4 amd64 [installed]
tweak/bionic 3.02-2 amd64
unity-tweak-tool/bionic,bionic,now 0.0.7ubuntu4 all [installed]
  • Is there a general scale setting, not just a setting for fonts? – Mitch Apr 29 at 19:05
  • @Mitch The text scaling factor scales the icons at the same time. I clarified that in the answer. – WinEunuuchs2Unix Apr 29 at 19:10
  • Sorry, should have been more specific: I meant does it also apply for the size of other UI elements like title bars, buttons, etc. – Mitch Apr 29 at 19:54
  • @Mitch Yes it does. I've rolled up your last comment as an answer sentence. – WinEunuuchs2Unix Apr 29 at 20:04
  • 1
    @Mitch My humble apologies Icons are prepackaged for pixel size and do not scale. I've updated the answer with a .gif that shows the illusion icons were changing size but it was the text below the icon shrinking/expanding in size that gave the illusion the icon was changing. – WinEunuuchs2Unix May 7 at 23:30

I run a shell script on login (using Startup Applications control panel) to set my desired scaling.

Determine your output device (mine is DP-1) by running xrandr on its own.

Then put an executable script somewhere (I have it in my home directory) containing the following:

#!/bin/bash

gsettings set org.gnome.desktop.interface scaling-factor 2
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gdk/WindowScalingFactor': <2>}"
xrandr --output DP-1 --scale 1.5x1.5
xrandr --output DP-1 --panning 3840x2160

You cant because Ubuntu switched back to Xorg as the default display. A lot of people are searching for a solution, and this thread is the top result on Google. Unfortunately there is still no fractional scaling in Xorg.

  • 1
    I don't understand this answer. Ubuntu 16.04 ran on Xorg and yet it had support for fractional scaling. – Beevik Jul 1 at 16:12
  • It’s that Ubuntu has switched from Unity (which had it) to GNOME (which doesn’t have it yet). – caw Sep 19 at 5:42

I am currently experimenting with a fix for this (still using Ubuntu 16.04 admittedly, but I'm pretty sure the same options are available in 18.04) which keeps the scaling at 1, but uses the resolution selector in the "Screen Display" part of System Settings to drop the resolution of the panel. You would think this would make everything blurry, but it seems to be doing a fine job for me. YMMV.

My screen (X1 Carbon 4th Gen) is 2560x1440, a 16:9 ratio. 2x zoom would make it effectively 1280x720, which is too small. Instead, I pick 2048x1152 (also a 16:9 ratio) from the selector. For me at least, it also offers 1920x1080, 1600x900 and 1368x768 as options depending on how much downscaling you want.

I might end up going with 1920x1080 as 2048x1152 still has a few things a little bit small.

You can use 1600x900 (16:9) from dropdown to increase scaling. enter image description here

The solution with the Gnome Tweak Tool works well for me with Ubuntu 18.04 with a 3840 x 2160 resolution display. After setting only the scale factor to 1.5 and leaving the font sizes unchanged the screen display was great for me. Additionally I had to adjust the size of the dock symbol size in the gnome settings. That seems to me the least intrusive solution.

  • This is the best solution for most people. Thanks, mgorriz. – Gene Olson Sep 23 at 2:29

The 18.04 desktop is fitting wallpaper images according to width, so if you resize your images for the width of the screen (regardless the absolute size of the image) your wallpapers will fit. To fit the tall images I go into "alter image/change canvass size" and add wide borders on either side using Pinta. (or Gimp or whatever you've got)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.