2

After dist-upgrade my system on 16.04 I've received such problems - some gui's don't appear correctly, can't install new packages and after command apt-get -f install received such printing

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 appmenu-qt5 : Depends: qtbase-abi-5-5-1 but it is not installable
 checkbox-converged : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 evolution-data-server : Depends: evolution-data-server-common (= 3.18.5-1ubuntu1) but 3.28.1-1ubuntu1 is installed
 gnome-calendar : Depends: gsettings-desktop-schemas (>= 3.21.2) but 3.18.1-1ubuntu1 is installed
 gnome-shell : Depends: libgjs0-libmozjs-24-0 but it is not installable
               Depends: libgjs0e (>= 1.44.0) but it is not installable
               Recommends: gnome-themes-standard-data but it is not installed
 hplip : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 libc-dev-bin : Depends: libc6 (< 2.24) but 2.27-3ubuntu1 is installed
 libc6-amd64:i386 : Depends: libc6:i386 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libc6-dbg : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libc6-dev : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libc6-i386 : Depends: libc6 (= 2.23-0ubuntu10) but 2.27-3ubuntu1 is installed
 libglib2.0-bin : Depends: libglib2.0-0 (= 2.48.2-0ubuntu1) but 2.56.1-2ubuntu1 is installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.48.2-0ubuntu1) but 2.56.1-2ubuntu1 is installed
 libglvnd-dev : Depends: libegl1 (= 1.0.0-2ubuntu2) but it is not installed
 libgoa-1.0-0b : Depends: libgoa-1.0-common (= 3.18.3-1ubuntu2) but 3.28.0-0ubuntu2 is installed
 libgoa-backend-1.0-1 : Depends: libgoa-1.0-0b (>= 3.25.4) but 3.18.3-1ubuntu2 is installed
 libkf5declarative5 : Depends: qtbase-abi-5-5-1 but it is not installable
 liboxideqtcore0 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt53dcore5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt53dinput5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt53dquick5 : Depends: qtbase-abi-5-5-1 but it is not installable
                  Depends: qtdeclarative-abi-5-5-0 but it is not installable
 libqt53dquickrenderer5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt53drenderer5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5contacts5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5core5a : Depends: libdouble-conversion1 (>= 2.0.0) but it is not installed
 libqt5designer5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5gui5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5location5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5multimedia5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5opengl5 : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5organizer5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5positioning5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5printsupport5 : Depends: libqt5gui5 (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5quick5 : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5quicktest5 : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5quickwidgets5 : Depends: libqt5gui5 (>= 5.6.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5script5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5sensors5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5sql5-sqlite : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5svg5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5waylandclient5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5webkit5 : Depends: qtbase-abi-5-5-1 but it is not installable
                 Depends: qtdeclarative-abi-5-5-0 but it is not installable
 libqt5websockets5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libqt5widgets5 : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 libqt5xmlpatterns5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libubuntutoolkit5 : Depends: qtbase-abi-5-5-1 but it is not installable
 libunity-webapps0 : Depends: unity-webapps-service but it is not installable
 libwayland-egl1-mesa : Depends: libegl1 but it is not installed
 onboard : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 pay-ui : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 python3-brlapi : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-cairo : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-cffi-backend : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-cryptography : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-cups : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-dbus : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-dbus.mainloop.qt : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-dev : Depends: python3 (= 3.5.1-3) but 3.6.5-3 is installed
 python3-evdev : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-gdbm : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-gi : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-gi-cairo : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-libapparmor : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-lxml : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-markupsafe : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-pil : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-psutil : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-pycurl : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-pyqt4 : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-renderpm : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-reportlab-accel : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-scipy : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-simplejson : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-sip : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-systemd : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-uno : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 python3-yaml : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 qml-module-qtlocation : Depends: qtbase-abi-5-5-1 but it is not installable
                         Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtpositioning : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtquick-controls : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 qml-module-qtquick-dialogs : Depends: libqt5gui5 (>= 5.9.0~beta) but 5.5.1+dfsg-16ubuntu7.5 is installed
 qml-module-qtquick-layouts : Depends: qtbase-abi-5-5-1 but it is not installable
                              Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtquick-localstorage : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtquick-particles2 : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtquick-privatewidgets : Depends: qtbase-abi-5-5-1 but it is not installable
                                     Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qtquick-xmllistmodel : Depends: qtbase-abi-5-5-1 but it is not installable
 qml-module-qtquick2 : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-qttest : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qml-module-ubuntu-test : Depends: qml-module-ubuntu-components but it is not installable
                          Depends: libubuntugestures5 but it is not installable
                          Depends: qtbase-abi-5-5-1 but it is not installable
 qml-module-ubuntu-web : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin (>= 1.3) but it is not installable or
                                  qtdeclarative5-ubuntu-ui-toolkit-plugin-gles (>= 1.3) but it is not installable
 qmlscene : Depends: qtbase-abi-5-5-1 but it is not installable
 qtbase5-dev : Depends: libqt5gui5 (= 5.9.5+dfsg-0ubuntu1) but 5.5.1+dfsg-16ubuntu7.5 is installed
 qtdeclarative5-dev-tools : Depends: qtdeclarative-abi-5-5-0 but it is not installable
 qtdeclarative5-ubuntu-push-plugin : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 qtdeclarative5-ubuntu-telephony-phonenumber0.1 : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 qtwayland5 : Depends: qtbase-abi-5-5-1 but it is not installable
 rhythmbox : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 rhythmbox-plugins : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 software-properties-gtk : Depends: python3-software-properties (= 0.96.20.7) but 0.96.24.32.1 is installed
 totem-plugins : Depends: python3 (< 3.6) but 3.6.5-3 is installed
 ubuntu-keyboard-data : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable
 unity-control-center : Depends: libgnome-desktop-3-17 (>= 3.27.90) but it is not installed
                        Recommends: system-config-printer but it is not installed
                        Recommends: gnome-control-center-faces but it is not installed
 unity-webapps-qml : Depends: qtdeclarative5-ubuntu-ui-toolkit-plugin but it is not installable or
                              qtdeclarative5-ubuntu-ui-toolkit-plugin-gles but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

How could I repair such issues?

  • 1
    18.04 is not ready for upgrading 16.04 in place. That comes after the first point release, 18.04.1, which comes in June. – Chai T. Rex Apr 28 '18 at 21:45
  • This is a great question that calls for an authoritative reference answer. – SDsolar Apr 29 '18 at 2:48
  • This is too late to help you but everyone reading should consider upgrading 16.04 to 18.04 in a test environment (cloned partition) first. You can manually do this booting with a Live USB or use this automated script without booting a Live USB: askubuntu.com/questions/1028604/… – WinEunuuchs2Unix Apr 29 '18 at 17:16
1
  1. After upgrading you must reboot.

  2. Make sure you sign-on selecting Unity from the drop down gear menu:

    Ubuntu 18.04 Five Desktops.jpg

  3. After signing in the first thing you must do is open a terminal and run:

    sudo apt update

    sudo apt upgrade

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.