31

After completing a fresh install of Ubuntu 18.04 LTS and rebooting, I closed the Acer Aspire ES1-511 laptop lid and took a little break. When I came back to continue exploring the new features of 18.04, the Laptop would not turn on. One of the internal fans was running quite loudly, but nothing more. I had to reboot once again.

This seems to be a recurring problem through the years of Ubuntu. I've looked into the issue since, first trying to change power settings in gnome-control-center and gnome-tweak-tool, then installing pm-utils, editing system files supposedly responsible for suspension, and plenty more attempts, all to no avail. I even tried running Ubuntu 18.04 Live from a USB drive, and the same problem still occurs.

I suspect it's an issue with the kernel, as I've seen this problem in the past with the kernel 4.15. Would an upgrade to the latest Linux kernel or a downgrade to a more stable version solve the problem? Has the problem been patched? Maybe I can just edit some file and this whole thing would be solved...

Some specifications: The Kernel currently running is 4.15. The computer, as mentioned above, is an Acer Aspire ES1-511. Desktop environment is Gnome 3.28.1. Ubuntu version is 64-bit 18.04.1 LTS.

Any help is appreciated. The computer is losing a lot of sleep over this.

  • Bleeding Edge! It was just released 2 days ago. I think bugs can be expected. – EODCraft Staff Apr 28 '18 at 21:10
  • 4
    Getting a very similar issue since upgrading to 18.04 on a XPS 9560. – collisionTwo Apr 30 '18 at 17:59
  • Matalak - I'm working on a bug report from experiencing the same issue. From the Acer Aspire ES1-511 specs it seems you have an Intel Celeron N2830. Can you tell me if you also have an SSD as your main storage device? – pHeLiOn Jun 6 '18 at 16:26
  • @collisionTwo - still working on the bug report and chasing down a vague theory that a Celeron based Atom style CPU coupled with an SSD is part of the problem. Your XPS 9560 doesn't fit my theory though :) Could you let me know if you fixed your suspend probem with the nouveau driver fix (XPS 9560 has nVidia graphics?) or whether that didn't work and you had to resort to using a 4.14 kernel to get suspend working again? – pHeLiOn Jun 6 '18 at 16:51
  • @pHeLiOn -- The hard drive is a Toshiba MQ01ABF050, not an SSD. However, it does indeed have an Intel Celeron N2830. – matalak Jun 13 '18 at 1:26
5

I have experienced the same issue with an HP Pavilion 11 x360.

The kern.log suggests that it thinks it has gone into suspend - PM: suspend entry (deep) - but the system seizes up at that point and there are then no further entries until you shutdown and reboot.

A 'successful suspend' would have futher entries PM: Syncing filesystems ... done., Freezing user space processes... etc

The screen goes blank but the power LED stays on (as does the fan if it is already running) and a hard reset (holding down the power button) is required to be able use the machine again.

Even using an 18.04 live USB results in the same suspend problem, which suggests it isn't because of any additonal programs I have installed.

Three other different laptops (friend's and my own) have no issues with suspend on 18.04, leading me to wonder what specific hardware combination causes this to occur.

All the laptops (including the 'problem child') have intel graphics.

The 'problem laptop' suspends fine with Ubuntu 17.10, Kubuntu 17.10, Devuan Jessie, Devuan ASCII and Windows 10 but fails to suspend with Ubuntu 18.04 and Kubuntu 18.04.

(Initially the suspend problem also occured when trying to use kernels 4.15, 4.16 and 4.17, but the more recent 4.17 and 4.18 kernels have an update that has allowed suspend to work again on this machine)

Using UKUU to install the most recent 4.14 kernel (4.14.47) on 18.04 fixed the problem. (The accepted answer by Matalak) - would now recommend trying a recent 4.17 or 4.18 kernel.


Edit - Please take a look at the steps here to see if any other fixes might resolve your issue first: Ubuntu 18.04 - Dell XPS13 9370 no longer suspends on lid close


I had trouble finding a bug report about suspend causing a completely unresponsive system on 18.04, which suggested that it was not affecting a large proportion of users.

Although it's good that it wasn't affecting a vast number of users, it can make it more difficult to find out where the issue lies if only a handful of people are experiencing problems with their specific hardware setup.


Edit - A bug report has been opened, the likely culprit appears to have been identified and a patched version of the 4.15 kernel was put together to resolve the suspend issue - the patch is now in the more recent 4.17 and 4.18 kernels https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1774950

Further Edit - As of 11th September 2018 the standard system update kernel (4.15.0-34) now has the patch, which has been backported by those kindly developers and suspend works again as it should on the problem laptop with the Intel N3540. Much praise to their work!


Just to be clear though, it's an issue with trying to suspend your machine on 18.04 where the screen goes blank (but it clearly hasn't gone into 'suspend') and then doesn't react to anything else except holding down the power button to shut it down.

5

I solved the problem by installing UKUU and downgrading to kernel 4.14.41. Perhaps there is an incompatibility with the hardware in later kernel versions.

  • 4.14.41 would include meltdown and spectre protection. – WinEunuuchs2Unix May 21 '18 at 0:30
  • That's confusing. What then are the differences between 4.14 and 4.15 + that might cause suspend/resume issues? Whatever they are, I hope they're restored in later kernels. – matalak May 21 '18 at 0:47
  • I'm also confused. I've tried 4.15, 4.16 and even the 4.17 kernel but they all have the same problem. But only on one laptop. Another 3 laptops (one with very similar hardware) suspend without any problems. The only fix that works for my 'problem laptop' is to use a 4.14 kernel (thanks matalak for the solution - i was just going to run 17.10 and hope 18.04 got fixed). Please help with the bug report (link in my 'answer') if you can, to help chase down this odd behaviour that only seems to affect a few specific machines. – pHeLiOn Jun 5 '18 at 0:45
  • I've finally joined the following bug report: bugs.launchpad.net/ubuntu/+source/linux/+bug/… . Thanks for putting it together! – matalak Jun 11 '18 at 4:51
  • Haha! Excellent! Thanks matalak. I've become slightly obsessed with this puzzle because it doesn't make much sense that it only affects a few specific machines. I was initially concerned that none of the devs would pay much attention to it, but they gave me the instructions to bisect the kernel between 4.14 and 4.15 and (13 kernel installations later) I got a result that should hopefully be of use in pinning down the sleeplessness. We might not be stuck on a 4.14 kernel forever after all :) – pHeLiOn Jun 11 '18 at 5:43
3

I believe it is the buggy nouveau driver. Try adding:

 nouveau.modeset=0

to GRUB_CMDLINE_LINUX in the /etc/default/grub file, after that run:

sudo update-grub
sudo reboot

And voila no more hangs on resume from suspend.

  • Unfortunately, this didn't work. Was the line supposed to look like GRUB_CMDLINE_LINUX="nouveau.modeset=0"? – matalak May 30 '18 at 3:34
  • I'm experiencing this same behaviour with a laptop that uses Intel Graphics. I suspect it isn't related to the graphics card because 3 other laptops using Intel Graphics suspend without any problems. – pHeLiOn Jun 5 '18 at 0:35
  • 1
    @pHeLiOn - do you also have a secondary graphics card in the laptop? Most of the responses I've seen here and elsewhere indicate that it's an issue with nVidia graphics. That's what I've got, and this answer did work for me. – kdgregory Jun 5 '18 at 10:30
  • @kdgregory - no, there's no secondary graphics card in my 'problem laptop'. It's just Intel Graphics. Matalak's Acer Aspire ES1-511 looks to be Intel Graphics only as far as I can tell from the specs. – pHeLiOn Jun 5 '18 at 13:32
  • @kdgregory - but yes, there are often problems with the nvidia graphics cards drivers that leave the screen blank. If Matalaks behaviour is the same as mine though, the problem seems to be that it's not actually going into suspend, but instead blanks the screen and seizes up and then can only be shutdown. – pHeLiOn Jun 5 '18 at 13:36
2
sudo add-apt-repository ppa:teejee2008/ppa
sudo apt update
sudo apt install ukuu
sudo ukuu --install v4.14.41

worked fine for me to solve this problem when booting using Advanced options for Ubuntu and selecting this kernel

  • Welcome to Ask Ubuntu! ;-) Erm, how is this answer different from the already accepted answer? – Fabby May 25 '18 at 19:57
  • 2
    for a start it has actual commands... perhaps suggesting an edit to the other answer would have been preferable – Zanna May 26 '18 at 14:41
  • Fortunately, those commands were included in the provided URL. Thanks for the help anyway! – matalak May 26 '18 at 20:42
1

I got a workaround for suspend working on Ubuntu 18.04 with a NVIDIA GeForce GTX 1050 Mobile and proprietary nvidia drivers 390. I installed pm-suspend via sudo apt-get install pm-utils. Then, I switch from Gnome Shell to the terminal via Ctrl+Alt+f6. After the login, I do sudo pm-suspend. After waking up from standby, I change back to Gnome Shell via Ctrl+Alt+f1. Done!

  • Suspend seems to work for me. It's hibernate which hangs on resume for me. – Stewart Dec 5 '18 at 17:35
  • 1
    I actually got rid of all problems by first removing the nvidia driver, installing the most recent kernel via ukuu and eventually installed the most recent nvidia driver from the nvidia website. – Gerhard Hagerer Dec 7 '18 at 9:20
0

I was also having this problem plague me ... and a fix after many manY maNY mANY MANY attempts was to re-install Ubuntu 18.04, and now it is working perfectly. I am also using Nvidia's "tested" Driver, as Nvidia was the culprit before.

Perhaps it was the "sudo add-apt-repository ppa:graphics-drivers" ppa which installed "Extra" Stuff from the PPA and/or the 396 driver itself which screwed up my laptop's hibernating ability.

Either way it works flawlessly at this time of writing with the NVidia's 390 tested driver. And just FYI, it was also working with the 396 driver for a long time, but became problematic last week - AGAIN! SO although I don't know the exact cause ...

It is/was definitely related to the NVidia driver as before switching to the Nouveau driver also worked, but I sure did not like that option.

Trying to help, Mark

p.s here are my other Tomboy notes for other issues with Ubuntu and Hibernating

18/07 Troubleshooting

‣ Prerequisites - does your kernel support suspend-to-disk?

• Kernel supports whatever is listed in /sys/power/state, so:

• cat /sys/power/state

• Allowed (to my knowledge) entries there include: mem, standby, freeze, disk. Explanation:

∘ mem - has several meanings, which one exactly on your system you'll find out via cat /sys/power/mem_sleep. I have: s2idle [deep]

∘ standby - Power-On Suspend (if supported)

∘ freeze - Suspend To Idle (STI)

∘ disk - Suspend To Disk (STD), hibernation. This - you want.

∘ mine says : freeze mem disk - PERFECT!

• Then we need to check

• $ cat /sys/power/disk

‣ [platform] shutdown reboot suspend test_resume

‣ [disabled]

• (not very good)

‣ Enable Hibernate and put it in menu - Easy-Peasy

• sudo apt install pm-utils cpufrequtils

• Then test if hibernate works in your computer by running command:

• sudo pm-hibernate

• After you computer turns off, switch it back on.

‣ Did your open applications re-open? If so it works, if not then hibernate does not work. You can check if your Swappiness partition is at least as large as your available RAM, as it may solve the problem.Problem! Hibernation not allowed!

∘ Test: pm-hibernate - (if pm-utils package is installed) , or

∘ works! after 18.04 re-install and no Nvidia yet

∘ systemctl hibernate

∘ works! after 18.04 re-install and no Nvidia yet

∘ Re-add Hibernate Option to Shutdown menu:

• 1. Edit a specific file with this command.

• sudo gedit /var/lib/polkit-1/localauthority/10-vendor.d /com.ubuntu.desktop.pkla

• 2. Scroll down the Text Document and find the below sections:

∘ [Disable hibernate by default in upower]

∘ [Disable hibernate by default in logind]

∘ Change both the values from no to yes in:

∘ ResultActive=no (change this to yes)

‣ Save, Exit & Reboot - Done!

0

My Acer ES1-512 was built on 18.04, updated to 18.04.1 now. Been having this suspend/sleep mode black screen problem ever since on 18.04.

The following steps solved the problem:

  1. The previous Kernel was 4.15.33 (took couple of auto updates) and that is the source of this problem.
  2. Downgrade to 4.14.41
  3. Modify Grub to take "Advanced Option" and point to 4.14.41
  4. Regenerate Grub
  5. Reboot

That's it! Suspend and Sleep function works fine now. Hope this helps.

0

Ok,I think the problem surely resides in the kernel. Because I v tried mint19.1, Ubuntu 18.04,18.10, manjaro18, solus3.9999,fedora29, all have the problem. And sometimes my laptop can’t even shutdown. Just hanging there with no keyboard or mouse inputs. My laptop is dell xps 9570. I ll try ukuu tomorrow

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.