16

I just upgraded my Ubuntu desktop 16.04 LTS to 18.04 LTS. After that it's not detecting sound devices. I have Lenovo laptop. Settings/Sound/Output

Settings/Sound/Input

I've tried these..
1.

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio pavucontrol
sudo alsa force-reload
reboot

2.

sudo apt-get install pavucontrol
pavucontrol

pavucontrol 3.

$ sudo lspci
[sudo] password for surjit: 
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Please help

39

I had a similiar issue that turned out to be a permissions problem with the pulse audio conf file, when I upgraded my Lenovo T440pclaptop to 17.10 last year.
The fix that finally worked for me (sorry, I cant find the original source for reference) was

killall pulseaudio; rm -r ~/.config/pulse/*

hth

  • 1
    thnx buddy.. now it's working :) – surjit Apr 28 '18 at 21:30
  • 1
    Yep. This is a solution for a lot of audio problems. Example: I had an install of Doom - the recent one crosscompiled not the old one in dosbox. You had to kill pulse so it could grab openal directly. Sometimes this resulted in a dangling lock-file for pulse and no audio on reboot. Probably could just delete the lockfile though. – RobotHumans Jul 23 '18 at 16:23
  • Work perfectly with that command in Ubuntu 18.4 – Douglas Mesquita Aug 5 '18 at 7:32
2

I had the same problem -- no sound after upgrade to 18.04.1 LTS -- and no audio profiles showed up. This eventually solved the problem:

  1. delete .config/pulse/ and .pulse (the latter might not exist)
  2. reboot
  3. pulseaudio --start
  4. pavucontrol, go to Configuration tab and choose profile analog stereo output
  5. gnome-alsamixer click unmute

I don't know if all these steps are necessary, but just killing pulseaudio and removing the pulse configuration files did not fix this. Without the reboot, alsamixer was already unmuted, yet there was no sound.

  • 1
    It's work for me! Ubuntu 18.04.2 LTS! – tadeubarbosa Feb 18 at 23:48
  • 1
    Worked for me as well... did – polynomial_donut May 20 at 16:07
  • ... also run the commands P.Péter suggested, although things didn't work before rebooting, so not sure if those were also necessary for me. – polynomial_donut May 20 at 16:20
0

Besides purging pulseaudio and pulseaudio-utils and its local lonfigs, I also had to remove all local gstreamer configs. This was on a Dell Latitude E5570.

apt purge pulseaudio.*
rm -r ~/.config/pulse/ ~/.cache/gstreamer-1.0/ ~/.local/share/gstreamer-1.0/
apt install pulseaudio

protected by Community Jul 23 '18 at 18:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.