I have just installed Ubuntu 16.04 and nether wire connection works or wirless. Now I have bought a PCI adapter from https://www.tp-link.com/us/download/Archer-T9E.html#videos I have followed the link: How to install TP-LINK Archer T4U driver? but it didn't worked for me ~/Desktop/rtl8812AU_8821AU_linux-master$ sudo modprobe rt18812au

modprobe: FATAL: Module rt18812au not found in directory /lib/modules/4.13.0-38-generic

Does anyone know what does it mean or how can solve this ?

  • You may have a typo - it is rtl (with lowercase L, not digit on 1). Try sudo modprobe rtl8812au instead of sudo modprobe rt18812au. Also you may try to install other driver with: sudo apt-get install rtl8812au-dkms. Please edit your question and add output of lspci -knn | grep -A3 "Network\|Wireless". – N0rbert Apr 28 '18 at 20:50
  • I tried sudo modprobe rtl8812au nothing happen after I have typed the password! Then I tried sudo apt-get install rtl8812au-dkms it gave: E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing? – naman Apr 28 '18 at 21:30

If you have internet while you install Ubuntu it will install the T9E driver by itself. I sadly do not know how to do it after install. I do have a working T9E driver. If you know any way I can help do ask.

  • I have first installed ubuntu 16.04 with wire connection (I don't know if I had internet access during installation) and after the installation I couldn't get access to internet! – naman Apr 28 '18 at 21:26
  • When you installed it, do you remember if the option about "Install drivers while installing Ubuntu, this will save time after installation" or something like that was an option or if it was greyed out? if it was greyed out you did not have internet. Just installed Ubuntu 18.04 3-4 times yesterday because of exactly this. – Bismuth83 Apr 28 '18 at 21:45
  • I have also selected that option during installation. I bought and mounted the PCI after I have installed ubuntu. so if can not solve this then maybe I should reinstall ubuntu ? – naman Apr 28 '18 at 21:50
  • It will work for sure if you have it installed in the computer while you install Ubuntu and have internet. It's probably not the correct way of handling things.. but it will get the job done. – Bismuth83 Apr 28 '18 at 21:51
  • Thanks @Bismuth83 I have internet know. It was solved by reinstallation. – naman May 8 '18 at 8:50

Okay so I just fell over something that could help you. I use the T9E network card as well and everything works for me:

  1. Open the Software & Updates application
  2. Go to the Additional Drivers tab
  3. Look for the Broadcom Limited: BCM4360 802.11ac Wireless Network Adapter device (this is your TP-Link)
  4. Choose the Broadcom 802.11 Linux STA wireless driver source from bcmwl-kernel-source (proprietary) option to enable it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.