2

I'm trying to get 144hz to work in ubuntu 18.04 with the proprietary nvidia 390 driver found in "software & updates" -> additional drivers I have tried the following and a lot more I dont even remember anymore:

  • Setting it to 144hz in NVIDIA x server. First off all it wont stick after restart even though I saved it to /etc/X11/xorg.conf configuration file. Furthermore it is not really 144hz. It seems very low and https://www.testufo.com/refreshrate reports 50-60 fps.
  • Setting it to 144hz in CompizConfig -> composite and disabled "detect refresh rate".
  • Setting it in "Displays"
  • Setting it in xrandr even though it should not mean anything when used with the propitary nvidia driver
  • Tried running: sh -c "sleep 2 && dconf write /org/compiz/profiles/unity/plugins/composite/refresh-rate "144" &"

I tried using the "X.org X server" driver that is activated with a clean Ubuntu install. This does seem to show 144 hz according to testufo. This driver preforms very very very badly in things such as games though.

Im using: NVIDIA GTX 1070

Non-relevant backstory: I've been at this problem for hours upon hours I even tried to fix it weeks ago in Mint OS 18.3 with Cinnamon desktop where I used days to try and fix it. I really cannot get it to work. I have really been working hard to leave Windows but if i cannot find a way to fix this frame rate issue I don't think I will be able to do the switch.

Edit:

It seems like I got NVIDIA to save the settings. I don't know why it changed its mind. So now NVIDIA is reporting 144hz even after reboots.

It still seems like its lower than 144hz though. Testufo still reports <60hz and a simple java program that is counting with a wait between each count that I recorded in slow mothing with my phone. This gave me a result of about 40hz while the same test in windows 10 gave me a result of about about 100hz. As you can see my test is not perfect - but it does give a picture of the difference.

I do think that my mouse moves pretty smooth in ubuntu though, this might lead me to think that its actually the windows in ubuntu that is running in lower than 144hz and not the whole system. If I move a window around it seems very laggy and very low FPS. while this looks perfectly clear in windows.

If my theory is correct, does that mean that it is GNOME that is running in low fps, or do I have something mixed up?

2

You are correct. Currently if you set your monitor's refresh rate to 144Hz then the mouse cursor will display at 144Hz but everything else will be stuck at 60Hz. I have not found any way around this, hopefully it gets fixed soon. It looks like this bug has already been reported: https://bugs.launchpad.net/ubuntu/+source/meta-gnome3/+bug/1767693

protected by Community Sep 23 '18 at 7:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.