• Version: VLC media player 3.0.1 Vetinari (revision 3.0.1-0-gec0f700fcc)
  • Ubuntu 18.04


cannot load module `/usr/lib/x86_64-linux-gnu/vlc/plugins/gui/libqt_plugin.so' (libQt5Svg.so.5: cannot open shared object file: No such file or directory)

How I got there:

  • Installed vlc: sudo apt install vlc
  • Installed qt5 (downloaded from the site, followed through the steps, and added to path. Followed the answer at Qt4 interface not working for VLC.

Here's my entire trace when I do vlc -vvv: https://pastebin.com/3wDmGhWV

  • Don't add 'more information' as answers. Use edits for that. Only post an answer when you actually have an answer (you don't state a true way to resolve the problem in your 'answer')
    – Thomas Ward
    Apr 28, 2018 at 22:05
  • 1
    Please don't use things like remove vlc*. It uses regexes instead of globs, and you'll be removing any package that starts with vl, not every package that starts with vlc. Apr 28, 2018 at 22:07
  • @Thomas The 'true way to resolve' was me installing VLC 1) through the software center and 2) the right VLC as there are two options in the software center. In my case that was the solution, and unless there's a reason why on 18.04 VLC via apt get install vlc doesn't work. In any case, my answer below solved the issue for me. No idea why, but it was the solution. Wasn't the solution I was expecting myself, but worked, at least for me.
    – KhoPhi
    Apr 29, 2018 at 10:06
  • @Thomas since you've deleted the answer that worked, you might as well delete the question, because I had an issue, had a solution and shared the solution but you don't see the solution as a 'true' solution, then you just delete the question as it isn't a 'true' issue. Geeeesh...
    – KhoPhi
    Apr 29, 2018 at 10:08
  • I misread your post at the time - but note this only works if something is using the "Ubuntu Software" method of managing the software; I'll undelete it, but it might not help others using one of the variants of Ubuntu that don't use Ubuntu Software center/installer for their packages.
    – Thomas Ward
    Apr 29, 2018 at 15:30

2 Answers 2


Ubuntu 18.04 seems to have a problem (at least on my instance) with shared object files that apt/dpkg believes are installed, but the files are missing.

I solved my problem by running vlc -vvv and looking for lines like the following:

main libvlc warning: cannot load module `/usr/lib/x86_64-linux-gnu/vlc/plugins/gui/libqt_plugin.so' (libQt5Svg.so.5: cannot open shared object file: No such file or directory)

In this case, it's missing the package libqt5svg, which you must reinstall:

sudo apt install --reinstall libqt5svg

Keep doing this until all the missing shared object files are restored, and vlc will launch.

Unfortunately, this is not just a vlc issue, many of my apps are having the same problem.

  • In my case, after several tries at re-installation of countless broken packages, I simply re-installed Ubuntu 18.04, but this time round, ticking the "install third party packages" whiles connected to internet.
    – KhoPhi
    May 24, 2018 at 10:36
  • Weird, I did that too. But I had other issues with the installation, which may have affected it.
    – datashaman
    Jun 12, 2018 at 7:49

I removed every trace of VLC

sudo apt remove '^vlc'

Then opened Ubuntu Software, searched "Vlc", then selected the first option.

Not sure what's going on there, but there are 2 VLC in the application store.

Doing sudo apt install vlc seems to install the second VLC in the list (with stars) which doesn't work.

But the first one works, yet has no ratings.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .