82

I installed Ubuntu 18.04 right now and after connecting to the internet instead of a network icon there is a question mark. There is no network issues, but that question mark is annoying.

Image of Ubuntu 18.04 question mark icon in place of wifi icon

2
  • 2
    See this bugreport - first seen on Ubuntu 14.10. Is it related to your issue? Could you add screenshot to your question?
    – N0rbert
    Commented Apr 28, 2018 at 19:34
  • 1
    works fine with Ubuntu 23.04..
    – Matías
    Commented Mar 23, 2023 at 17:50

9 Answers 9

154

Settings > Privacy > Connectivity Checking

screenshot

Set it OFF. (Then, restart your WiFi connection, thanks to @Dante's comment below).

This is the same fiasco as Microsoft's NCSI (Network Connectivity Status Indicator), a false negative to try ruin your mood.

And, yeah, it would be checking some URL like that one.

10
  • @dante is the answer the solution, or was it disconnect and reconnecting? The seem very different and if so, this should not be accepted answer (although can upvote since it helped you find the answer)
    – Oliver
    Commented Jul 23, 2018 at 18:07
  • 1
    @Oliver This answer is the solution but this change requires that you restart your computer.
    – Dante
    Commented Jul 24, 2018 at 7:49
  • 1
    Will turning it off disable any icon changes when the internet is really not working? @M K Commented Apr 24, 2019 at 16:25
  • @HomeroEsmeraldo Well, I did not get your question clearly, but since this is a new feature (sorrowfully mimicking the failed Microsoft Windows) I would guess you are talking about "Signal-Loss" icon? If that is the case, then NO, all normal icons will stay the same
    – M K
    Commented Jun 17, 2019 at 21:31
  • 1
    @HomeroEsmeraldo unfortunately, it will 99% of times be a false negative. Ask yourself: did Satya's fiasco (Windows) succeed doing it? Vendors should really stop mimicking each other in features that have always proved to be no more than fiasco. I had my comment changed, but it seems the first ironic one is a better reply!
    – M K
    Commented Jun 24, 2019 at 14:28
8

I solved it differently because I am able to find the root cause which is kind of different from what you get.

Open the log app and search for 'network', I see following error message

... result="fail" reason="Connection 'Ethernet connection 1' is not available on device ens33 because device is strictly unmanaged"

This is how I solved it:

Open

sudo nano /etc/NetworkManager/NetworkManager.conf

and change the line managed=false to managed=true

Then,

sudo service network-manager restart
2
  • 4
    Which `log'? ...and why does this fix it?
    – user643722
    Commented Dec 23, 2019 at 19:22
  • Thanks! This fix my problem! Commented Oct 28, 2021 at 12:58
7

I have the exact same problem, but it is sporadic: The icon is fine most of the time, except after some events, e.g. installing updates, it turns into a question mark, while the connection is still fine.

Rebooting works, sure, but I don't have the patience for that. OTOH, restarting the network manager seems to do the trick in most cases:

sudo service network-manager restart

Hope this helps to someone!

4

I've had that issue with other versions of Ubuntu. I had similar Theme issues after upgrading to 18.04.

Change the icon theme. You can do this with Gnome Tweaks.

It's not installed by default. Install it with:

$ apt install gnome-tweak

From there click on Appearance -> (click) Icons. Then select a different theme.

I've seen occasions where changing to a different theme and changing back sometimes resolved a glitch that was happening with the current preferred theme.

8
  • 1
    I really don't like installing another software just because of that. I installed Ubuntu 18.04 on two laptops and I got this problem on both of them.
    – Dante
    Commented Apr 28, 2018 at 19:46
  • 1
    The gnome-tweak tool is a significant part of the gnome environment. You can alternatively change the theme and icons from the commandline. This is the commandline for changing the icon theme: gsettings set org.gnome.desktop.interface icon-theme 'YourIconTheme' I understand the thought of installing other applications, but in this case, this tool really is a significant part of the environment. I'm really surprised it wasn't installed by default. You can view the themes with this command: ls /usr/share/themes Commented Apr 28, 2018 at 19:50
  • I see but I think the developers should fix this problem :-)
    – Dante
    Commented Apr 28, 2018 at 19:54
  • I installed Gnome Tweaks and only Breeze icon theme works! Unfortunately I don't like it :-)
    – Dante
    Commented Apr 28, 2018 at 19:57
  • 1
    They will. To me, they are good for listening to bug reports and feature request. Put in a feature request at Bug reports and Feature request. I'm sorry that you don't like the first choice you see. But I'm glad it works. You might also try a few different Application Themes and Icon Themes. Did you try the Adwaita theme? Commented Apr 28, 2018 at 19:59
2

I had this issue, along with a very slow internet connection - due to the fact that I had used expressvpn, and I recently uninstalled it.

The problem was that uninstalling with apt remove expressvpn didn't clean up after it completely, so I still had a broken expressvpn service trying to run in systemd.

After I ran apt purge expressvpn, everything started working nicely, and the questionmark over my WiFi icon is gone.

1

I had the same issue Ubuntu 20.04. None of the above solution worked. I turned Automatic DNS off and put in an IP 8.8.8.8 or what ever your DNS is.

1
  • Thank you. Your solution was a idea to try my solution. I change my DNS to default modem IP, 192.168.1.1 and it fixed. Commented Sep 1, 2022 at 21:28
0

The question mark seems, at least in my case, to signify that I am connected to a VPN. If you too are connected, disconnect and then restart your network manager using the command below.

sudo service network-manager restart
0

I had this error in ubuntu groovy. ping -c4 google.de told me temporary failure in name resolution

ping -c 8.8.8.8 instead works.

So access to internet was possible. Meaning no hardware issue or in my module. I create

/etc/NetworkManager/conf.d/no-systemd-resolv.conf 
# wlan-verbindung für NetworkManager fixen
[main]
systemd-resolved=false

I restarted systemd-resolved and NetworkManager Services.

0

No one above has answered the reason behind this behavior so I will try to explain the most probable cause.

I also recently encountered this issue when I left VPN enabled on my system. This was resolved by either disabling the VPN or disabling the connectivity check feature of Linux(Ubuntu).

The most probable reason for this behavior might be that this connectivity checks feature act as a third-party network manager and hence when it tries to read network endpoints, which VPN services like Cloudflare warp restrict, we get the warning in network logs and question marks appears on wifi icon.

Ps: If anyone would like to elaborate in-depth on it feel free to edit this answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .