4

I've been running 17.10, which is completely updated and current, and trying to upgrade to 18.04. My system should be perfectly capable of the new distribution, it's a quad-core AMD system running nVidia GTX 550 graphics. (I also run Windows 10 on it, with all the latest upgrades, and a copy of Win 7 just for old times' sake.)

I've tried it multiple times using command-line (both with and without the Developer option) and using the GUI method, and every time, the upgrade seems to complete flawlessly, but in the end, it reboots to a black screen with command-line only. It wants a login and password (which I've never used before, always login automatically), then tells me "Welcome to Ubuntu 18.04 LTS", and some further tidbits of info, then returns to a command prompt, still on an otherwise black screen.

Obviously, this is a problem, so I've wiped it and restored to the previous build (again). Anybody have any ideas as to what's going wrong? The full text of how my screen appears after upgrading follows:


Ubuntu 18.04 LTS BigBoy tty1 [NOTE:  BigBoy is my computer's name, no laughing]

BigBoy login:dave

Password:

Welcome to Ubuntu 18.04 LTS (GNU/Linux 4.15.0-20-generic x86_64)

* Documentation:  https://help.ubuntu.com
* Management:  https://landscape.canonical.com
* Support:  https:ubuntu.com/advantage

* Meltdown, Spectre and Ubuntu:  What are the attack vectors, how the fixes work, 
and everything else you need to know -- https:ubu.one/u2know

0 packages can be updated
0 updates are security updates

You have packages from the Hardware Enablement Stack (HWE) installed that are going 
out of support on 2016-08-04.

There is a graphics stack installed on this system.  An upgrade to a configuration 
supported for the full lifetime of the LTS will become available on 2016-07-21 and 
can be installed by running "update manager" in the Dash.

The programs included with the Ubuntu system are free software;  the exact 
distribution terms for each program are described in the individual files in 
/usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by applicable law.

dave@BigBoy:"$
3
  • 2
    I had the same problem, and this fixed it: askubuntu.com/questions/1029509/… – Helene Apr 29 '18 at 10:20
  • That sounds promising, considering the nature of the messages that came up in the above login text. (Although why anything "becoming available on 2016-07-21", as if it's a future date, is showing up in a 2018 upgrade is beyond me.) I'll give that a shot in a few days, when I have time to re-run the upgrade, login, kick-start the GUI, and then run that command in a terminal. – djroff Apr 30 '18 at 0:41
  • That took care of it. – djroff May 5 '18 at 11:54
5

"startx" will indeed get you into the normal desktop environment from command-line purgatory. Once in, from the link Helene gave me, the problem was easy to fix. Apparently the upgrade process leaves display manager package "lightdm" in a broken state, and it has to be reinstalled (then selected in place of "gdm"). So it was just a matter of running "sudo apt-get install lightdm", once the system was up. Now everything boots normally.

1

type startx in the terminal.

this should bring up the new environment.

Or it might give you lots of errors, that you can add to your question!

2
  • As I said, I've already wiped it by restoring to a still-functional 17.10. What I want to know is what I can do differently to create an upgrade that DOESN'T go straight to a command-line terminal, not how to work around it. I want an upgrade that boots into Ubuntu's GUI. – djroff Apr 28 '18 at 23:42
  • I imagine the Ubuntu experts are up to their necks in it at the moment, so you are not going to get a proper answer. – user795750 Apr 29 '18 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.