6

Was working great on Ubuntu 16.04 for a long time. I got a new computer 2 weeks ago and waited til this week to install Ubuntu. I followed the Mullvad client instructions here:

https://mullvad.net/en/guides/installing-mullvad-client-linux/

They assume Ubuntu 16.04, so their guide is not yet updated. But I followed the instructions exactly. I'm not a great innovator.

Once the client is installed, it won't launch. When I open a terminal and command it to launch, nothing happens. I get a bunch of errors. Any help? (screenshot of errors in link below)

Using GTK2 Gtk-Message: 11:33:06.240: Failed to load module "canberra-
gtk-module"
changing directory to /usr/lib/python2.7/dist-package/mullvad
Setting logging directory to /home/snarf/.cache/mullvad/log
        
(mullvad:9312): GLib-GObject-WARNING **: 11:33:06.248: cannot register
existing type 'GdkDisplayManager'
    
(mullvad:9312): GLib-CRITICAL **: 11:33:06.248: g_once_init_leave:
assertion 'result != 0' failed
        
(mullvad:9312): GLib-GObject-CRITICAL **: 11:33:06.248:
g_object_new_with_properties: assertion 'G_TYPE_IS_OBJECT (object_type)'
failed  

Error message in Terminal

3

I tried Ole's solution and get the following error:

$ env MULLVAD_USE_GTK3=yes mullvad
Using GTK3
/usr/lib/python2.7/dist-packages/mullvad/mui.py:60: PyGIWarning: AppIndicator3 was imported without specifying a version first. Use gi.require_version('AppIndicator3', '0.1') before import to ensure that the right version gets loaded.
  from gi.repository import AppIndicator3 as appindicator
changing directory to /usr/lib/python2.7/dist-packages/mullvad
Setting logging directory to /home/ms/.cache/mullvad/log

(mullvad:15452): Gtk-WARNING **: 22:28:12.209: gtk_disable_setlocale() must be called before gtk_init()
Setting logging directory to /home/ms/.cache/mullvad/log
CRITICAL: An uncaught exception occured: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/wx-3.0-gtk3/wx/_core.py", line 16765, in <lambda>
lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.7/dist-packages/mullvad/mui.py", line 2088, in _start
_start_gui(app, root_window, log, settings, tunnel)
  File "/usr/lib/python2.7/dist-packages/mullvad/mui.py", line 2138, in _start_gui
tray_ui = AppIndicator(root_window, tunnel, settings)
  File "/usr/lib/python2.7/dist-packages/mullvad/mui.py", line 295, in __init__
appindicator.CATEGORY_COMMUNICATIONS)
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 137, in __getattr__
self.__name__, name))
AttributeError: 'gi.repository.AppIndicator3' object has no attribute 'CATEGORY_COMMUNICATIONS'

Anyone had a similar problem/suggestion for a fix?

2

This is due to an issue seen on other distros too.

First test this:

env MULLVAD_USE_GTK3=yes mullvad

If it works, changing your .desktop file for mullvad should be all you need to fix it permanently.

This is how:

nano /usr/share/applications/mullvad.desktop
Change "Exec=mullvad" to "Exec=env MULLVAD_USE_GTK3=yes mullvad"
3
  • Sorry I wasn't able to try this yesterday. But it failed. Same errors as before. I wish your suggestions had worked. – Danny Apr 30 '18 at 4:01
  • Nevermind. I failed to remember that terminal stuff is case sensitive. Tried again with CAPS in the right places and it worked. Thanks! – Danny Apr 30 '18 at 4:19
  • 3
    It's better if you don't edit .desktop files under /usr/share/applications/, but copy them into ~/.local/share/applications/ and edit the copy there. (Otherwise software upgrades will likely overwrite it again.) – JanC May 1 '18 at 18:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.