2

I am running Lubuntu 17.10. Loading qpaeg with:

pactl unload-module module-equalizer-sink
pactl unload-module module-dbus-protocol
pactl load-module module-equalizer-sink
pactl load-module module-dbus-protocol
qpaeq

I get no module load errors and the qpaeq pops up correctly. When I change any of the sound levels it has no effect on sound output, and on the console above I get,

Traceback (most recent call last):

 File "/usr/bin/qpaeq", line 450, in write_coefficient
    self.filter_state.seed()
  File "/usr/bin/qpaeq", line 511, in seed
    self.sink.SeedFilter(self.channel,self.filter_frequencies,self.coefficients,self.preamp)
  File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in __call__
    **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.InvalidArgs: xs must be monotonic and 0<=x<=16384

Does anyone have any helpful suggestions? I have tried the many suggestions I have seen on the web, but nothing works.

Is there a way to revert to an older version that works? I tried
pulseaudio-equalizer not working
but after following the procedure I was not offered the old version by synaptic.

  • My thanks to Vlad for tidying this up. I made the mistake of not checking that cut&paste had come out correctly. – user823295 Apr 30 '18 at 7:29
1

I have resolved this. Because it happened inadvertently the details are incomplete, but there it is.

I had upgraded to 18.04 as per the auto recommend. The problem persisted with the same behaviour, but a slightly different error message.

I installed pulseeffects. Following another Ubuntu post, pulse audio equaliser not working in ubuntu 18.04

So as root:

wget https://launchpad.net/~yunnxx/+archive/ubuntu/gnome3/+files/pulseeffects_1.313entornosgnulinuxenial-1ubuntu1_amd64.deb

dpkg -i pulseeffects_1.313entornosgnulinuxenial-1ubuntu1_amd64.deb

The dpkg install failed lacking python-cairo, so

apt install python-cairo

That failed also, but suggested:

apt --fix-broken install

which installed python-cairo and a various other stuff (that is where I lack detail here - I didn't save the list).

Then I re-tried the dpkg install and it worked.

I now had pulseeffects installed and working.

I tried pulseaudio-equalizer again out of interest and it now worked. I guess that python-cairo or the stuff that got installed with it fixed the problem.

BTW I would recommend pulseeffects. The up/down keys can be used to make precise 1Db changes in each frequency range bar, and the 'tone' facility has enabled calibrating a 'flat' response from my amp & speakers. It revealed a massive hole in the response at 250cps. It all sounds so much better now.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.