I have recently installed Ubuntu mate 18.04 on my XPS 15 9560. I cannot adjust the display brightness through any means. I have tried the following:

  1. Set the acpi_backlight=vendor in boot parameters
  2. used xbacklight, which gives the following results


xypnox@xypnox-xps:~$ xbacklight -set 50
No outputs have backlight property

also I followed another question at xbacklight: No outputs have backlight property - No /sys/class/backlight folder, and the output for sudo find /sys/ -type f -iname '*brightness*' is

xypnox@xypnox-xps:~$ sudo find /sys/ -type f -iname '*brightness*'

10 Answers 10


An alternative method is to install a PPA and brightness APP which also adjusts gamma - AWESOME!, and ... for any individual screen TOO!

Here are the 3 simple steps:

$ sudo add-apt-repository ppa:apandada1/brightness-controller
$ sudo apt update
$ sudo apt install brightness-controller

Then find it ...

Brightness Controller

in your App's/Accessories

Always Trying to help, Mark

  • it works but this won't help you control it using the hardware keys or the in system controls. (at least with the KDE controls) Oct 26, 2019 at 17:39
  • I installed 'brightness-controller' on ubuntu 18.04, but it wouldn't completely load when it was launched. The app's GUI was mostly greyed out or missing. I tried rebooting, but no joy.
    – Charles
    May 2, 2020 at 18:10

I had the same issue on a Dell XPS 13. Found this link that solved the problem for me : https://bugs.archlinux.org/task/58296#comment168869

What I did:

  • changed the content of /etc/default/grub by adding video.only_lcd=0 to GRUB_CMDLINE_LINUX_DEFAULT
  • updated grub with sudo update-grub

After restarting the laptop, I was able to control the brightness.

  • 5
    I tried this but it did not work
    – xypnox
    May 3, 2018 at 16:13
  • 1
    Tried this as well for 9560 but did not work. On Kernel version 4.15.0
    – xamox
    Sep 5, 2018 at 0:51
  • worked like charm in Sony Vaio. I had same issue after I upgraded to Ubuntu 18.04. Apr 14, 2020 at 10:08

I had the same problem some years ago and was having the same problem again after installing ubuntu 18.04. it was a kernel problem then, and i think it may be a kernel problem now.

After updating the kernel the problem was fixed for me.

To update kernel see: Updating kernel question

To download last stable kernel (which worked for me): http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16.6/

In my case i downloaded:




  • After download did they install without error using sudo dpkg -i *.deb? Did you do apt install -f afterwards to ensure no errors? Someone else today reported problems with 4.16.3. Apr 30, 2018 at 21:46
  • 3
    A better link with hundreds of votes for updating latest kernel:askubuntu.com/q/119080/307523 Apr 30, 2018 at 21:54
  • I followed the exact instructions of the link above that you suggested (in particular, I didn't use -f). The packages were installed without errors.
    – user824210
    May 1, 2018 at 0:41
  • If you have no errors count yourself lucky I just tried 4.14.38 also released on April 30, 2018 and it still has errors. The OP using 4.16.3 with errors hasn't replied back on his situation yet: askubuntu.com/questions/1030043/… You might want to to post an answer there how 4.16.6 works fine. BTW the hole command to type is sudo apt install -f with no package name. It verifies your installation is ok. May 1, 2018 at 0:47
  • I'll leave a comment there. I was trying to update using the software UKUU and it didn't work. Then I used the terminal following the instructions of the link you suggested and it worked perfectly. Maybe the software has a problem.
    – user824210
    May 1, 2018 at 0:51

I've been struggling for the past week on trying to get Ubuntu working on my Dell XPS 15 9570 and I've had it working for a while with nomodeset but it's been killing my eyes having the display stuck on full brightness.

I finally fixed it today! I updated my kernel to 4.17 (http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17/) which was last updated two days ago and then restarted, and then finally restarted again without the nomodeset option (and didn't have to replace it with anything) and the display works now!!!

Hope this helps :)

  • Hi, can you please provide the .deb files I need to install? I am confused with several options in amd64 and several tutorials only install 3 or 4 out of the provided 7
    – xypnox
    Jun 6, 2018 at 18:34
  • I installed the following: linux-headers-4.17.0-041700_4.17.0-041700.201806041953_all.deb, linux-headers-4.17.0-041700-generic_4.17.0-041700.201806041953_amd64.deb, linux-image-unsigned-4.17.0-041700-generic_4.17.0-041700.201806041953_amd64.deb, linux-modules-4.17.0-041700-generic_4.17.0-041700.201806041953_amd64.deb Jun 6, 2018 at 20:54

I have an XPS 15, and the following solved it for me:

  1. Updating to the latest kernel (4.17.5 is the one I used, following instructions from this answer)
  2. Reboot
  3. Remove any video options (nomodeset, video.only_lcd=0, etc.) from the GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub file.
  4. Run update-grub to update
  5. Reboot

This made it possible to adjust from the keyboard and made "night mode" actually change screen colors.


I have finally found the solution to the problem. There display drivers for Ubuntu did not work out of the box for me. I started fresh from a 18.04.1 release and used nomodeset to boot into the live USB. Obviously, I could not set the brightness. I installed regularly and rebooted.

I installed the latest nvidia drivers from the ppa: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

Then I restarted the system and also added the boot parameters acpi_rev_override=5 nouveau.runpm=0.

After the restart the desktop worked fine and I could change between the nvidia and intel graphics and could set my brightness.

Also, updating the kernel did not solve the problem for me.

  • This is why the eight answers didn't work: they were focused on intel_backlight directory but you had a nVidia problem. Oct 14, 2018 at 17:12
  • This is basically the answer, even I tried updating kernel with v5.1, no sucess. Thanks for this one. Jul 3, 2019 at 15:46

None of the previous instructions here didn't worked for me Then I watch this video https://www.youtube.com/watch?v=BO-kKKi_ERM and I find out that whole Rc.local file was missing.

I created a new file:

printf '%s\n' '#!/bin/bash' 'exit 0' | sudo tee -a /etc/rc.local sudo chmod +x /etc/rc.local sudo -i sudo gedit /etc/rc.local

I removed all and replace new text with these..

ec#!/bin/sh -e echo 490 > /sys/class/backlight/intel_backlight/brightness exit 0

Then reboot and it worked

I have Xubuntu 18 and after this brightness came up a lot, but still it's not in full mode. I can't adjust it with FN + right/left arrow key. It will show up but does not go anywhere. Volume adjust with up an down arrow keys works fine... weird... Xubuntu 18 seems to have bugss..


It may be related to the display driver.

My issue is solved with the following steps. Dell latitude 5590 with intel VGA compatible driver.

  1. Installed ubuntu with nomodeset option
  2. Updated BIOS to 1.2.3
  3. Updated /etc/default/grub.






  • That did not work. Moreover the Laptop froze when i removed the nomodeset parameter. Had to readd it.
    – xypnox
    May 4, 2018 at 8:16
  • As long as nomodeset there, you will not be able to use display settings, so you should try all grub options without nomodeset. If you never removed nomodeset, you might want to retry other grub options again witout nomodeset. make sure you are using i915 kernel module. Check your driver's bus info with lshw -C Display. Then lspci -vv -s bus info after pci@ i.e. lspci -vv -s 0000:00:02.0 Check the Kernel modules. If its other than i915, you should seek the related grub option. May 4, 2018 at 10:19

I had the same isssue and I added video.only_lcd=0 to GRUB_CMDLINE_LINUX_DEFAULT after quiet splash in /etc/default/grub then updated grub with sudo update-grub rebooted then lcd backlight worked. This was done on a dell xps 14 l421x


On Xubuntu 18.04 (Ubuntu with xfce desktop) my brightness problem finally solved.

I opened 'Onboard Settings' under the 'Settings' menu. If your desktop doesn't have one, you can download it from Software Center.

On the 'Onboard Preferences' window, click the Layout menu, then choose the 'Full Keyboard' (Desktop keyboard with edit and function keys). Click here to view the Onboard Preferences window

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .