1

This question already has an answer here:

I upgraded to Ubuntu 18.04 from 16.04. On startup the display is black for 15 minutes, doesn’t boot and is stuck indefinitely displaying Ubuntu logo. Kindly let me know how do I boot successfully as I don’t want to lose my important files.

Stuck indefinitely displaying Ubuntu logo

marked as duplicate by David Foerster, Fabby, waltinator, Kevin Bowen, Melebius May 23 '18 at 8:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4

Try setting nomodeset in kernel parameters.

When grub loads and you get a screen to choose OS to load (if in dual-boot) or press Shift to load grub menu if you have only Ubuntu installed. Then with the Ubuntu option highlighted press e.

You will see something like this:

recordfall=1
save_env recordfall
set quiet=1
insmod ext2
set roothd(0,1)
search --no-floppy --fs-uuld --set 9009-9234
linux /boot,mlinuz-2.6.91.-9 root=i1U10=90.7bf99-923.1 ro quiet  splash
                                                                       ^
                                                                       |
initrd /boot/initrd.ing-2.6.91-9-generic 

Add the nomodeset at the arrow indicated so the line looks like:

linux /boot,mlinuz-2.6.91.-9 root=i1U10=90.7bf99-923.1 ro quiet  splash nomodeset

Now press F10 to boot.

If this works we set the nomodeset permanently as follows:

Do the above again, and...

Open a terminal app and type "sudo nano /etc/default/grub" Enter your password if prompted. Move the cursor to the line that looks like the following:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Add the nomodeset here so that the line looks:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Press Ctrl-O the Enter to save, Then Ctrl-X to exit.

In the terminal, type sudo update-grub and hit enter. Once complete, you should be able to reboot your computer with this change made.

  • Many thanks for your response xypnox. The issue was 'unmet dependencies' which I resolved from root shell. – Suhas Gowda Apr 29 '18 at 5:43
  • @SuhasGowda If you found a suitable way to tackle your problem you should post an answer so that people having the same problem can see what worked – xypnox May 1 '18 at 7:47
  • It worked for me. I set up a virtual machine and had this error – Svetoslav Marinov Jun 26 at 14:05
0

I followed the steps below in order;

1) To connect to Wi-Fi from command line, I followed the instructions from this link -> https://www.addictivetips.com/ubuntu-linux-tips/connect-to-the-internet-from-the-command-line-on-linux/

2) Once the Wi-Fi connection was established, broken packages were fixed referring to the link below;

http://www.iasptk.com/ubuntu-fix-broken-package-best-solution/

3) Finally, the OS was upgraded according to this article → https://www.digitalocean.com/community/tutorials/how-to-upgrade-to-ubuntu-18-04

  • Please click the gray checkmark beside your answer to mark it as accepted which will change its color from gray to green. – karel May 8 '18 at 11:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.