8

I upgraded to the new 18.04 version of ubuntu, coming from the latest 17. release. In both versions I have the same problem using my JBL Charge 3 bluetooth speaker. The sound is lagging and is being interrupted in uneven sequences, sometimes sounding OK for two seconds, then being interrupted in bursts.

I have tried disconnecting, re-connecting, switching HSP/HFP and A2DP Sink on and off, also "forgetting" the device and reconfiguring it.

My kernel (dmesg) says (repeatedly):

[ 5903.702600] input: FC:A8:9A:9B:81:E9 as /devices/virtual/input/input23
[ 5917.523365] Bluetooth: hci0: last event is not cmd complete (0x0f)
[ 5933.525358] Bluetooth: hci0: last event is not cmd complete (0x0f)
[ 5949.523345] Bluetooth: hci0: last event is not cmd complete (0x0f)
[ 5965.524317] Bluetooth: hci0: last event is not cmd complete (0x0f)
[ 5981.524464] Bluetooth: hci0: last event is not cmd complete (0x0f)

I have also tried this workaround without success.

1
  • have same one. I also can reproduce it on 17.10. [ 2165.605629] Bluetooth: hci0: SCO packet for unknown connection handle 0 [ 2170.010235] Bluetooth: hci0: last event is not cmd complete (0x0f) [ 4746.012661] Bluetooth: hci0: last event is not cmd complete (0x0f) [ 4762.012971] Bluetooth: hci0: setting interface failed (19) [ 4764.412328] Bluetooth: hci0: command 0xfc05 tx timeout [ 4764.412348] Bluetooth: hci0: Reading Intel version information failed (-110) bluetooth 548864 16 btrtl,btintel,bnep,btbcm,rfcomm,ath3k,btusb ecdh_generic 24576 1 bluetooth – Grigoriev Nick May 10 '18 at 9:31
1

The sound is distorted as long as the "bluetooth setting" windows is open and searching. Closing the windows clears the sound and stops the messages in the dmesg.

Blueman (alternative bluetooth manager) shows the same behavior while searching for devices, but the default bluetooth manager is constantly searching when open.

It would be interesting to discover if this affects only JBL speakers, and if it is a problem of some bluetooth controllers only (mine is a Intel 3165).

0

I have this speaker and Intel integrated bluetooth. I think it's just bad controller, because I had issues with other devices before. The only thing you can do is to locate your speaker as close to your pc/laptop as possible, on distances more than 2 meters it won't work reliably. The other thing to consider if you are on 18.04 and using intel's bluetooth is updating firmware from here https://unix.stackexchange.com/questions/257270/get-rid-of-no-caching-mode-page-found-message-during-boot and installing fresh version of bluez from this PPA https://launchpad.net/~bluetooth/+archive/ubuntu/bluez. It might not be the cause of your particular problem, but you definitely will see this bug later if you will get your speaker to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.