9

How to fix broken nautilus-dropbox icon in ubuntu 18.04 GNOME-Flashback in top Panel?

See screenshot below:

image for Dropbox Nautilus bug

9

To sum up:

  1. Run

    dropbox stop && env XDG_CURRENT_DESKTOP=Unity dropbox start
    
  2. Click on Dropbox icon after it starts up. Go to the "Preferences" and uncheck "Start Dropbox on system startup" (to prevent dropbox from changing the startup command after reboot.)

  3. Go to Applications > Preferences > Startup Applications, if Dropbox is already there click on Edit, and if not click on Add.

    Enter
    Name: Dropbox
    Command: env XDG_CURRENT_DESKTOP=Unity dropbox start
    Comment: Sync your files across computers and to the web

  4. Run

    gedit ~/.config/autostart/dropbox.desktop
    

    replace Exec=dropbox start -i with

    Exec=env XDG_CURRENT_DESKTOP=Unity dropbox start
    

and

  1. Run

    sudo gedit /usr/share/applications/dropbox.desktop
    

    replace Exec=dropbox start -i with

    Exec=env XDG_CURRENT_DESKTOP=Unity dropbox start
    
  • 1
    Prettified the formatting of your answer. – N0rbert May 1 '18 at 20:59
  • After doing these steps, the dropbox icon came back, but if I left or right click on the icon, I just get an emptry menu. I'm running xubuntu 18.04. – user26866 Aug 15 '18 at 18:27
6

I can confirm it on clean Ubuntu 18.04 LTS install with GNOME FlashBack session, so I installed only GNOME Panel new package and Nautilus Dropbox plug-in

sudo apt-get install gnome-panel nautilus-dropbox

After installing of nautilus-dropbox I have logged-in to my Dropbox account.

Then after rebooting system I get the same image as OP, so I reported bug 1767665.

It may be fixed locally as @Alberts Muktupāvels (muktupavels) suggested on launchpad.
I shorten method to just two simple lines:

mkdir -p ~/.config/autostart/
cp  /usr/share/applications/dropbox.desktop ~/.config/autostart/dropbox.desktop
sed -i "s/dropbox start -i/env XDG_CURRENT_DESKTOP=Unity dropbox start -i/" ~/.config/autostart/dropbox.desktop

The first finds Exec line dropbox start -i in it and changes it to env XDG_CURRENT_DESKTOP=Unity dropbox start (it forces dropbox to "use" Unity desktop even if we are using GNOME), the second creates user XDG-autostart directory, the third line copies XDG-autostart desktop-file to user XDG-autostart directory.

Afterwards Dropbox menu is in place and works as expected.

  • I edited both question and answer (see above). Voted to reopen. – N0rbert May 1 '18 at 17:17
  • I suggest that 1. dropbox stop && env XDG_CURRENT_DESKTOP=Unity dropbox start 2. Go to the settings in dropbox after it starts up and select to not start at startup. 3. Add or edit the start up application for dropbox with the command "env XDG_CURRENT_DESKTOP=Unity dropbox start" – Vijay May 1 '18 at 20:27
  • 1
    I tested my approach on clean installation of 18.04 LTS. It just works. So I prefer KISS principle here :) – N0rbert May 1 '18 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.