11

Since the upgrade to Ubuntu 18.04 (from 17.10) I started experiencing huge performance issues with video playback, both using VLC and the browser (Youtube).

The problem gets more apparent the higher quality the video is (starts at 480p, 1080p is completely unwatchable). The video is choppy to say the least.

I had no such problem using Ubuntu 17.10.

I wonder if there's someone who also had same problem and found a potential cause and perhaps a solution?

cpuinfo:

AMD A6-6310 APU with AMD Radeon R4 Graphics

glxinfo (tidied up):

name of display: :1
display: :1  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
client glx vendor string: Mesa Project and SGI
client glx version string: 1.4
client glx extensions:
GLX version: 1.4
GLX extensions:
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: VMware, Inc. (0xffffffff)
    Device: llvmpipe (LLVM 6.0, 128 bits) (0xffffffff)
    Version: 18.0.0
    Accelerated: no
    Video memory: 10965MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 6.0, 128 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 18.0.0-rc5
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 18.0.0-rc5
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 18.0.0-rc5
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:
264 GLXFBConfigs:

UPDATE:

It seems that it's a general issue with hardware acceleration / rendering not enabled / recognised / working.

The things I have tried so far:

  1. Reboot.

  2. Add xorg.conf configuration file with:

    Section "Device"
        Identifier     "Device0"
        Driver         "radeon"
    EndSection
    
  3. Reinstall xserver-xorg-video-radeon.

None of these things had any effect unfortunately.

Update #2

Output produced by ubuntu-drivers debug:

=== log messages from detection ===
DEBUG:root:_get_db_name: output
ID_PCI_CLASS_FROM_DATABASE=Network controller
ID_PCI_SUBCLASS_FROM_DATABASE=Network controller
ID_VENDOR_FROM_DATABASE=Broadcom Limited
ID_MODEL_FROM_DATABASE=BCM43142 802.11b/g/n


DEBUG:root:_get_db_name(/sys/devices/pci0000:00/0000:00:02.3/0000:01:00.0, pci:v000014E4d00004365sv000017AAsd00000621bc02sc80i00): vendor "Broadcom Limited", model "BCM43142 802.11b/g/n"
DEBUG:root:Loading custom detection plugin /usr/share/ubuntu-drivers-common/detect/sl-modem.py
DEBUG:root:plugin /usr/share/ubuntu-drivers-common/detect/sl-modem.py return value: None
DEBUG:root:Loading custom detection plugin /usr/share/ubuntu-drivers-common/detect/arm-gles.py
DEBUG:root:plugin /usr/share/ubuntu-drivers-common/detect/arm-gles.py return value: None
DEBUG:root:Loading custom detection plugin /usr/share/ubuntu-drivers-common/detect/open-vm-dkms.py
DEBUG:root:plugin /usr/share/ubuntu-drivers-common/detect/open-vm-dkms.py return value: None
=== modaliases in the system ===
acpi:PNP0103:
pci:v00001022d00001566sv000017AAsd00003801bc06sc00i00
pci:v00001022d00001584sv00000000sd00000000bc06sc00i00
usb:v0BDAp0129d3960dcFFdscFFdpFFicFFisc06ip50in00
platform:rtsx_usb_ms
platform:rtsx_usb_sdmmc
usb:v0438p7900d0018dc09dsc00dp01ic09isc00ip00in00
usb:v1D6Bp0002d0415dc09dsc00dp00ic09isc00ip00in00
pci:v00001022d00001582sv00000000sd00000000bc06sc00i00
pci:v00001002d00009840sv000017AAsd00003801bc04sc03i00
input:b0000v0000p0000e0000-e0,5,kramlsfw6,8,
hdaudio:v1002AA01r00100500a01
pci:v000010ECd00008168sv000017AAsd00003812bc02sc00i00
pci:v00001022d00001580sv00000000sd00000000bc06sc00i00
pci:v00001022d0000780Dsv000017AAsd00003801bc04sc03i00
hdaudio:v14F1510Fr00100100a01
input:b0000v0000p0000e0000-e0,5,kramlsfw2,
input:b0000v0000p0000e0000-e0,5,kramlsfw4,
pci:v00001022d00007801sv000017AAsd00003801bc01sc06i01
pci:v00001022d0000156Bsv00000000sd00000000bc06sc00i00
pci:v00001022d0000780Bsv000017AAsd00003801bc0Csc05i00
pci:v00001022d00001585sv00000000sd00000000bc06sc00i00
pci:v00001022d00001537sv000017AAsd00003801bc10sc80i00
pci:v00001022d00001583sv00000000sd00000000bc06sc00i00
pci:v00001022d00007813sv000017AAsd00003801bc08sc05i01
usb:v1D6Bp0002d0415dc09dsc00dp01ic09isc00ip00in00
usb:v1D6Bp0003d0415dc09dsc00dp03ic09isc00ip00in00
pci:v00001022d00001581sv00000000sd00000000bc06sc00i00
pci:v00001002d00009851sv000017AAsd00003801bc03sc00i00
pci:v000014E4d00004365sv000017AAsd00000621bc02sc80i00
usb:v5986p0652d3652dcEFdsc02dp01ic0Eisc01ip00in00
input:b0003v5986p0652e3652-e0,1,kD4,ramlsfw
usb:v5986p0652d3652dcEFdsc02dp01ic0Eisc02ip00in01
usb:v105BpE065d0112dcFFdsc01dp01icFFisc01ip01in01
usb:v105BpE065d0112dcFFdsc01dp01icFFiscFFipFFin02
usb:v105BpE065d0112dcFFdsc01dp01icFFisc01ip01in00
usb:v105BpE065d0112dcFFdsc01dp01icFEisc01ip01in03
pci:v00001022d0000780Esv000017AAsd00003801bc06sc01i00
acpi:PNP0800:
acpi:PNP0C04:
acpi:PNP0C09:
acpi:VPC2004:
input:b0019v0000p0000e0000-e0,1,4,k94,95,BA,BE,C0,C1,CA,CB,D4,E3,F0,F7,ram4,lsfw
acpi:PNP0C0A:
acpi:ACPI0003:
platform:regulatory
platform:microcode
acpi:PNP0C0D:
platform:vboxdrv
platform:pcspkr
platform:Fixed MDIO bus
acpi:PNP0C0C:
serio:ty01pr00id00ex00
input:b0011v0002p000Ee0000-e0,1,3,k110,111,145,14A,14D,14E,14F,ra0,1,18,1C,2F,30,35,36,39,3A,mlsfw
input:b0011v0001p0001eAB83-e0,1,4,11,14,k71,72,73,74,75,76,77,79,7A,7B,7C,7D,7E,7F,80,8C,8E,8F,9B,9C,9D,9E,9F,A3,A4,A5,A6,AC,AD,B7,B8,B9,D9,E2,ram4,l0,1,2,sfw
cpu:type:x86,ven0002fam0016mod0030:feature:,0000,0001,0002,0003,0004,0005,0006,0007,0008,0009,000B,000C,000D,000E,000F,0010,0011,0013,0017,0018,0019,001A,001C,0020,0021,0022,0023,0024,0025,0026,0027,0028,0029,002B,002C,002D,002E,002F,0030,0031,0034,0036,0037,0038,0039,003A,003B,003D,0064,0068,006E,0070,0072,0073,0074,0075,0078,0079,007A,007C,0080,0081,0083,0089,008D,0093,0094,0096,0097,0099,009A,009B,009C,009D,009E,00C0,00C1,00C2,00C3,00C4,00C5,00C6,00C7,00C8,00C9,00CA,00CC,00CD,00D6,00D8,00DA,00DB,00DC,00E2,00E8,00EC,00ED,00F3,010F,0123,0140,01C2,01E0,01E1,01E2,01E3,01E4,01E6,01E7,01EA,01EB,01EC,0220
acpi:LNXSYSTM:
acpi:LNXSYBUS:
acpi:LNXCPU:
input:b0019v0000p0001e0000-e0,1,k74,ramlsfw
acpi:PNP0C0F:
acpi:PNP0A08:PNP0A03:
acpi:LNXVIDEO:
acpi:PNP0100:
acpi:PNP0C01:
acpi:PNP0000:
acpi:PNP0C02:
acpi:ETD0624:ETD0000:PNP0F13:
acpi:MSFT0001:PNP0303:
acpi:PNP0B00:
acpi:PNP0200:
input:b0019v0000p0006e0000-e0,1,kE0,E1,E3,F1,F2,F3,F4,F5,ramlsfw
input:b0019v0000p0005e0000-e0,5,kramlsfw0,
dmi:bvnLENOVO:bvrA2CN36WW(V2.04):bd04/30/2015:svnLENOVO:pn80E3:pvrLenovoG50-45:rvnLENOVO:rnLancer5B2:rvrNotDefined:cvnLENOVO:ct10:cvrLenovoG50-45:
=== matching driver packages ===
bcmwl-kernel-source: installed: 6.30.223.271+bdcom-0ubuntu4   available: 6.30.223.271+bdcom-0ubuntu4 (auto-install)  [distro]  non-free  modalias: pci:v000014E4d00004365sv000017AAsd00000621bc02sc80i00  path: /sys/devices/pci0000:00/0000:00:02.3/0000:01:00.0  vendor: Broadcom Limited  model: BCM43142 802.11b/g/n

Output produced by sudo lspci -nnk | grep -i vga -A3:

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] [1002:9851]
Subsystem: Lenovo Mullins [Radeon R4/R5 Graphics] [17aa:3801]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

Output produced by sudo lshw -c display:

  *-display                 
       description: VGA compatible controller
       product: Mullins [Radeon R4/R5 Graphics]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:37 memory:e0000000-efffffff memory:f0000000-f07fffff ioport:3000(size=256) memory:f0c00000-f0c3ffff memory:c0000-dffff
  • Why do you watch videos in a virtual machine? Performance won't be great no matter what is installed. – mikewhatever Apr 28 '18 at 12:42
  • I don't quite understand. Where does you assumption that I use VM come from? – pzaj Apr 28 '18 at 13:03
  • 1
    The output of glxinfo is full of "VMware, Inc" string. – mikewhatever Apr 28 '18 at 13:09
  • Alright, I didn't notice that. So to be clear, I'm running Ubuntu directly on HW, not inside the VM. Could the problem be OpenGL configuration of some kind? – pzaj Apr 28 '18 at 13:15
  • 1
    Will you add the output of this command to your question: sudo lspci -nnk | grep -i vga -A3 && sudo lshw -c display – L. D. James Apr 28 '18 at 16:28
3

This bug is worth a look at.

https://bugs.launchpad.net/ubuntu/+source/nux/+bug/1767468

The system is looking for unity support, doesn't find it (because the tool that checks for it has been remove) and so disables hardware.

Worked for me anyway.

Edit: issue the command sudo rm /etc/X11/Xsession.d/50_check_unity_support this has been reported as a successful workaround to the issue.

  • I'm unable to confirm this is the correct solution, since I've switched back to 17.10 and don't feel like upgrading anytime soon. If there's anyone who has the same issue and it was solved by this answer please add your comment and I will mark the answer as correct! – pzaj May 5 '18 at 14:26
  • This solution worked for me, with the Intel® HD Graphics 520 (Skylake GT2) graphics. – Hugo May 9 '18 at 22:30
  • I have an NVIDIA 01:00.0 VGA compatible controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev a2)... trying this solution now – Joshua Besneatte May 13 '18 at 18:43
  • Didn't work for me in 18.04 – retorquere May 20 '18 at 22:45
  • didn't work for me too... i get no such file is present – siva Jun 14 '18 at 6:14
0

I've encountered same issue. Only available renderer was llvm.

After lot of googling I realised, because of different bug,
I put nomodeset into grub (/etc/default/grub) in the line GRUB_CMDLINE_LINUX_DEFAULT

In my setup the machine works without this parameter just fine.

Check, if there is parameter nomodeset in grub and remove it.
Try if it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.