59

I installed Ubuntu 18.04 and then while installing Virtualbox i get the 'i386' error message after I did:

$ sudo apt-get update
Get:1 http://nl.archive.ubuntu.com/ubuntu bionic InRelease [242 kB]
Hit:2 http://security.ubuntu.com/ubuntu bionic-security InRelease                                                                
Hit:3 http://ppa.launchpad.net/danielrichter2007/grub-customizer/ubuntu bionic InRelease                                         
Hit:4 http://nl.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:5 http://nl.archive.ubuntu.com/ubuntu bionic-backports InRelease
Get:6 http://download.virtualbox.org/virtualbox/debian bionic InRelease [4429 B]
Get:7 http://download.virtualbox.org/virtualbox/debian bionic/contrib amd64 Packages [1426 B]
Fetched 248 kB in 1s (209 kB/s)     
Reading package lists... Done
N: Skipping acquire of configured file 'contrib/binary-i386/Packages' as repository 'http://download.virtualbox.org/virtualbox/debian bionic InRelease' doesn't support architecture 'i386'

I found several answers on Askubuntu for the 'i386' message but I don't know how to apply this to my situation

111

Edit:

sudo nano /etc/apt/sources.list.d/virtualbox.list

and change:

deb https://download.virtualbox.org/virtualbox/debian bionic contrib

for

deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian bionic contrib

Or open terminal an execute the following command:

echo "deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list

Update:

I leave a bash script, which installs completely virtualbox without errors and that may be useful (tested in Ubuntu 18.04/20.04).

chmod +x VboxInstall.sh && ./VboxInstall.sh

#!/bin/bash
# Oracle Repository
echo "deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list.d/virtualbox.list
wget -q https://www.virtualbox.org/download/oracle_vbox.asc -O- | sudo apt-key add -
sudo apt-get update
sudo apt-get -y install linux-headers-$(uname -r) build-essential gcc make perl dkms bridge-utils
sudo apt-get -y install virtualbox-6.1
sudo dpkg --configure -a && sudo apt-get -f -y install
export VBOX_VER=`VBoxManage --version | awk -Fr '{print $1}'`
wget -c http://download.virtualbox.org/virtualbox/$VBOX_VER/Oracle_VM_VirtualBox_Extension_Pack-$VBOX_VER.vbox-extpack
sudo VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack-$VBOX_VER.vbox-extpack
sudo usermod -a -G vboxusers $USER
sudo update-grub
sudo /sbin/vboxconfig

Note: If you have a previous version (from the Oracle or Ubuntu repositories), delete it and Backup VMs and config before running it

#!/bin/bash
if echo $(VBoxManage --version | awk -Fr '{print $1}'); then
        echo "virtualbox has been detected"
   else
        echo "virtualbox not detected"
fi

Source: Virtualbox kernel service is not running

| improve this answer | |
  • Hello Thomas, problem solved, I succesfully installed Virualbox now, Thanks – Newbie May 1 '18 at 12:22
  • This really helped me resolve my VirtualBox installation issues, THANK YOU!!!! – Jackspace Aug 8 '19 at 1:05
  • you are welcome. I'm glad to hear that – ajcg Aug 8 '19 at 19:54
  • 1
    COOL! After upgrade to virtualbox 6.1 (on my 18.04 LTS) the VMs were gone. To get them back I opened VirtualBox (i.e. the Virtualbox Manager), clicked on "Add" and navigated to the *.vbox-File. The next machines I added via the menu (Machine -> Add). Now all VMs are back. Then downloaded and installed extension pack 6.1.6. Then, in the settings under "Display", deselected 3D-acceleration (not compatible with the VBoxVGA Graphics Controller). Finally, installed the guest additions (as recommended by Oracle). In Windows 10 (guest) this worked only after a reboot. Now all is well :-)) – Stefan May 15 at 11:24
9

You should try with a https deb source:

deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian bionic contrib
| improve this answer | |
9

I wanted to add a comment to secretAgent regarding this but I don't have enough reputation for that.

We need not use https for apt packages for the reasons listed on this site: https://whydoesaptnotusehttps.com/

Also, incase your virtualbox source is in /etc/apt/sources.list, ajcg's answer can be modified to:

sudo nano /etc/apt/sources.list

Edit the line

deb http://download.virtualbox.org/virtualbox/debian bionic contrib

to

deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian bionic contrib

Or you could just fire up your terminal and type

echo "deb [arch=amd64] http://download.virtualbox.org/virtualbox/debian $(lsb_release -sc) contrib" | sudo tee /etc/apt/sources.list
| improve this answer | |
  • Well, yeah, we don't need to use HTTPS with apt, but at this point why bother? If the repository supports HTTPS, I would use it. – YtvwlD May 6 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.