3

I just installed Kubuntu 18.04 and i tried to disable mouse acceleration. I had a script file that i was usually using with the following commands but it doesnt work anymore :

xinput set-prop 8 "Device Accel Profile" -1
xinput set-prop 8 "Device Accel Constant Deceleration" 4

The output of xinput is:

Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Razer Razer Abyssus                       id=8    [slave  pointer  (2)]
⎜   ↳ Gaming KB  Gaming KB                      id=10   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Power Button                              id=7    [slave  keyboard (3)]
    ↳ Gaming KB  Gaming KB                      id=9    [slave  keyboard (3)]
    ↳ Gaming KB  Gaming KB                      id=11   [slave  keyboard (3)]

and xinput -list-props

Device 'Razer Razer Abyssus':
        Device Enabled (139):   1
        Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
        libinput Natural Scrolling Enabled (274):       0
        libinput Natural Scrolling Enabled Default (275):       0
        libinput Scroll Methods Available (276):        0, 0, 1
        libinput Scroll Method Enabled (277):   0, 0, 0
        libinput Scroll Method Enabled Default (278):   0, 0, 0
        libinput Button Scrolling Button (279): 2
        libinput Button Scrolling Button Default (280): 2
        libinput Middle Emulation Enabled (281):        0
        libinput Middle Emulation Enabled Default (282):        0
        libinput Accel Speed (283):     0.000000
        libinput Accel Speed Default (284):     0.000000
        libinput Accel Profiles Available (285):        1, 1
        libinput Accel Profile Enabled (286):   1, 0
        libinput Accel Profile Enabled Default (287):   1, 0
        libinput Left Handed Enabled (288):     0
        libinput Left Handed Enabled Default (289):     0
        libinput Send Events Modes Available (259):     1, 0
        libinput Send Events Mode Enabled (260):        0, 0
        libinput Send Events Mode Enabled Default (261):        0, 0
        Device Node (262):      "/dev/input/event2"
        Device Product ID (263):        5426, 66
        libinput Drag Lock Buttons (290):       <no items>
        libinput Horizontal Scroll Enabled (291):

I tried changing Accel Profile Enabled but it doesnt work (unless i'm doing something wrong).

any ideas?

1
  • Can't you use kcmshell5 mouse or the same accessed via the K menu and settings? That has an option to disable mouse acceleration. Mind you sometimes (when switching between fullscreen games and KDE) I'm getting an unsetting of my changes made in that settings screen.
    – pbhj
    Aug 10 '18 at 19:33
1

This worked for me on Ubuntu.
You have to change Accel Speed.

xinput set-prop <mouse_id> <accel_speed_id> <number>

So in your case:

xinput set-prop 8 283 -0.5

note: i used -0.5 as an example, use what ever value you want.
This will last till the next reboot or logout. If you want it permanent use a X11 conf file (/usr/share/X11/xorg.conf.d), there are some tutorials online, but i had no luck getting it to work.
An alternative is creating a startup script that would execute the command for you.

0
1

Set

System Settings -> Input Devices -> Mouse -> Advanced -> Acceleration Profile

to None.

-1

I haven't figured out how to disable mouse accel. yet, and I'm quite sure Jubast's way isn't the best one. If it was, 0.0 should give a 1:1 ratio, but it doesn't. xset m 0 0 is also useless (and ffs, why tf is it still so hard to do stuff like this on Linux? Jesus). Regarding storing the settings, you can make the configuration permanent by writing it to the ~/.config/kcminputrc file. Here's mine


[Keyboard]
KeyboardRepeating=0
NumLock=0
RepeatDelay=200
RepeatRate=25

[Mouse]
XLbInptAccelProfileFlat=true
XLbInptNaturalScroll=false
XLbInptPointerAcceleration=-0.75
cursorTheme=breeze_cursors

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.