I have followed this tutorial to install MySQL but after successfully installed MySQL, I could not access database.

ERROR 1698 (28000): Access denied for user 'root'@'localhost'

  • 1
    I faced the same issue, after some digging, got it that u have to set root password your self following instructions at the StackOverFlow. – Mohammad.H Fathi May 7 '18 at 10:51

I found a solution at here link, by following this solution I have solved my problem.

Short steps are:

sudo mysql -u root
ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'test'; 

Note: here test is a new password for the root user. Also, remember to run the command sudo service mysql restart after altering the user.

  • Thank you. It is odd mysql-server not propting to enter password anymore. – gamofe May 19 '18 at 13:45
  • 1
    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'b230mehonot'' at line 1 – alhelal Jun 5 '18 at 3:40
  • same error here... :( – user1111929 Jun 8 '18 at 20:57
  • @alhelal, The solution is for MySQL not for MariaDB. So you can try another solution. – Ashrafuzzaman Sujan Jun 21 '18 at 1:43
  • Do not write mysql -u root, Just write "sudo mysql", In Ubuntu systems running MySQL 5.7 (and later), the root user is authenticated by the auth_socket plugin by default. – ravisoni Jan 12 at 11:07

I found another way that is much better as we need not to give any password for local system.
It is as followed.

Open terminal and type

sudo mysql -u root -p

It will prompt you in mysql, here you can fire any mysql commands.

Use mysql table for change table type, so we can use empty password. Bellow is command for it

USE mysql;

Now we change type of table by following command

UPDATE user SET plugin='mysql_native_password' WHERE User='root';

now we have to flush the privileges, because we have used UPDATE. If you use INSERT, UPDATE or DELETE on grant tables directly you need use FLUSH PRIVILEGES in order to reload the grant tables.


now exit from mysql by following command


now restart mysql server by following command

service mysql restart

Hope this may help

Thank you.

  • 2
    This is the right answer – Ningappa Dec 15 '18 at 10:01
  • Thank you Happy to help :) – Krunal Pathak Jun 5 at 5:46

protected by Community Jan 30 at 9:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.