8

I have installed clean Ubuntu MATE 18.04 LTS and installed Scilab from repository here with

sudo apt-get update
sudo apt-get install scilab

After installation I tried to launch it from GUI (Applications → Other → Scilab) - it does not start.
Then I tried to launch it from terminal with scilab command. Terminal output is as follows:

$ scilab
/usr/bin/scilab-bin: error while loading shared libraries: libjava.so: cannot open shared object file: No such file or directory

so it can't find Java. I reported bug 1762999 about this problem.

I checked existence of libjava.so:

$ dpkg -S libjava.so  
openjdk-11-jre-headless:amd64: /usr/lib/jvm/java-11-openjdk-amd64/lib/libjava.so

so it is in place.

What should I do to get Scilab 6.0.1 working on Ubuntu 18.04 LTS?

16

* Repository-based method (Scilab itself and ATOMS will not work)

Update 2020-12-07. Nowadays Scilab is broken again as indicated in bug 1884277.


* Binary download method (fully-functional, seems to be really recommended)

So if you need fully-functional Scilab you should remove deb-packaged version with

sudo apt-get purge scilab scilab scilab-cli scilab-data scilab-doc scilab-full-bin scilab-include scilab-minimal-bin scilab-sivp scilab-test
sudo apt-get autoremove

and use latest binary archive 6.1.0 from official site and run the commands below (download, extract, add to PATH, set shortcuts and MIME-association):

mkdir ~/Software
cd  ~/Software
wget https://www.scilab.org/download/6.1.0/scilab-6.1.0.bin.linux-x86_64.tar.gz
tar -xzf scilab-6.1.0.bin.linux-x86_64.tar.gz
cd scilab-6.1.0
echo "PATH=$PATH:/home/$USER/Software/scilab-6.1.0/bin" >> ~/.bashrc
echo "PATH=$PATH:/home/$USER/Software/scilab-6.1.0/bin" >> ~/.profile
mkdir -p ~/.local/share/applications
cp -a ~/Software/scilab-6.1.0/share/{icons,applications,mime} ~/.local/share/
update-mime-database ~/.local/share/mime/
update-menus

The ATOMS and other components will work as expected. Do not forget to install build-essential package to run Xcos Modelica simulations.

* AppImage download method (fully-functional)

We need to download the latest release from corresponding page or manually:

mkdir ~/Software
cd ~/Software
wget https://github.com/davidcl/Scilab.AppDir/releases/download/6.1.0-1/Scilab-x86_64.AppImage
chmod +x Scilab-x86_64.AppImage
ln -s Scilab-x86_64.AppImage scilab

and then add it to PATH with

echo "PATH=$PATH:/home/$USER/Software/" >> ~/.bashrc
echo "PATH=$PATH:/home/$USER/Software/" >> ~/.profile

As the result you will get Scilab working. But there is no MIME associations (yet).


If you want to get Scilab 5.5.2 working on Ubuntu 18.04.1 LTS see other answer. But be careful with libcurl4 removal!

1

I followed these steps to run scilab on (x)ubuntu 18.04 (Bionic Beaver):

  1. Install openjdk8 via:

    sudo apt-get install openjdk-8-jre openjdk-8-jre-headless 
    sudo update-java-alternatives -s java-1.8.0-openjdk-$(dpkg --print-architecture)
    
  2. Enter this command via terminal to open SciLab-GUI:

    scilab
    
  3. Hit ENTER (after jlatexmath warning)

it's (the GUI and all of it's features) running without any problems including XCos (very good Simulink alternative).

By pressing enter I just skipped the warning

Could not find Java package '/usr/share/java/jlatexmath-fop-1.0.6.jar

If you don't need it, just don't install it.

3
  • 1
    You may want to write a comment below my answer about skipping jlatexmath part. Otherwise your answer do not contain new information and you should delete it. ATOMS in such case remain broken, to there are no tradeoffs. Scilab will continue to crash when started from Applcations menu/dash. – N0rbert Nov 9 '18 at 7:15
  • jlatexmath problem is now fixed. Consider to remove your answer as outdated. – N0rbert Apr 16 '19 at 20:06
  • This just worked for me – Graham Aug 1 '19 at 21:14
1

Following the answer to a question raised in https://bugs.mageia.org/show_bug.cgi?id=15390, I am able to run SCILAB 6.0.2 (debian package) without the error ("libjava.so: cannot open shared object file: No such file or directory").

It seems SCILAB 6.0.2 requires OpenJDK 11. I just added the path of the installed java to the .bashrc file:

export JAVA_HOME=/usr/lib/jvm/java-11-openjdk-amd64

The scilab GUI works fine for now, however, there are few minor errors.

Not the answer you're looking for? Browse other questions tagged or ask your own question.