I am trying to enable the Edit button in Shutter. I installed the application from Ubuntu Software and are using Ubuntu 18.04.

After taking a screenshot the Edit button is disabled. And when hovering the mouse pointer over the button the text "Goo::Canvas/libgoo-canvas-perl needs to be installed for this feature" is shown.

enter image description here

I have tried to install the package libgoocanvas2-perl and restarted the computer, but the edit button is still not enabled:

sudo apt install libgoocanvas2-perl

That is the only package I can find.

Anyone that knows how to fix this?


6 Answers 6


I found a solution here: http://ubuntuhandbook.org/index.php/2018/04/fix-edit-option-disabled-shutter-ubuntu-18-04/. I can confirm that it works for Budgie 18.04.

  1. Download and install the libgoocanvas-common and libgoocanvas3 packages.

    Either use Gdebi package installer (available in Ubuntu Software) or run command in terminal (press Ctrl+Alt+T) to install the package:

    sudo dpkg -i ~/Downloads/libgoocanvas3_1.0.0-1_amd64.deb
    sudo dpkg -i ~/Downloads/libgoocanvas-common_1.0.0-1_all.deb
    sudo apt-get -f install
  2. Finally download & install libgoo-canvas-perl package:

    Also install the package via Gdebi or terminal command, since Ubuntu Software doesn’t solve dependencies automatically:

    sudo dpkg -i ~/Downloads/libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb
    sudo apt-get -f install

To apply changes, kill Shutter process or restart your computer!

  • 3
    budgie, I tested it in Lubuntu 18.04 and it worked, too! Great!
    – Redbob
    Commented May 4, 2018 at 16:30
  • 2
    This solution worked on kde plasma as well.
    – EricC
    Commented Jul 19, 2018 at 18:31
  • 3
    I had to install "libgoocanvas-common" before "libgoocanvas3". Otherwise, fab! Let this stand as an example of how to write a great answer! Just spell it all out. Wish i could give you more than one upvote!
    – Reb.Cabin
    Commented Aug 22, 2018 at 20:07
  • 1
    Shutter can not be killed by killall it will not complete shutter on tab because it is ran under perl process. So it is needed to killall perl, or, more safe ps ax | grep shutter then kill <shutter PID>. Commented Sep 7, 2018 at 3:49
  • 1
    How about adding the (official?) shutter PPA (which seems to also contain the libgoo libs) and do it all in sudo apt-get install libgoocanvas-common libgoo...? Update: apparently a bad idea: various errors around the liboo packages... PPA appears in poor shape.
    – Frank N
    Commented Oct 14, 2018 at 19:24

There is unofficial PPA with newer version of Shutter plus the required dependencies for Ubuntu 18.04 and 18.10. See https://www.linuxuprising.com/2018/10/shutter-removed-from-ubuntu-1810-and.html

sudo add-apt-repository ppa:linuxuprising/shutter
sudo apt-get update
sudo apt install shutter

and restart Shutter.

  • 4
    This is the better solution in my opinion. Commented Jan 30, 2019 at 20:43
  • 3
    didn't work for me no Edit button
    – scythargon
    Commented Feb 22, 2019 at 18:57
  • 3
    Doesn't give me a working Edit button either. Commented Apr 4, 2019 at 23:18
  • 2
    Make sure your restart Shutter after installing it from the PPA.
    – Logix
    Commented May 28, 2019 at 14:09
  • 9
    restart shutter is not really a good instruction. Better would be: pkill shutter then open shutter again. Like this it worked for me, as closing it is not enough (an instance still runs in the background)
    – firepol
    Commented Nov 9, 2019 at 14:44

Thanks to the answer of budgie. That solution worked fine for me as well.

Just to clarify in this thread, this is what I did:

  1. Downloaded these three packages in Chrome:

  2. Clicked on the downloaded files in Chrome (or File Browser) and installed the package with Ubuntu Software.

  3. Restarted the computer and then the Edit button was enabled.

  • 4
    You don't have to restart the computer. Just kill the Shutter process.
    – Omar Tariq
    Commented Jul 19, 2018 at 18:16

How to fix this in a Snap! (Dad joke)
Another option, if you don't feel comfortable installing dependencies that aren't in the repo or adding a ppa, is to use the snap package.

You can search for Shutter in the Ubuntu Software store. There should be two packages: the snap and the old package with missing dependencies. To tell which is which, click on each one and go down to the details section. Under Details, make sure the Source says "Snap Store" (and not ubuntu-bionic-universe). Then go back to the top, and click the Install button. Oh snap! You're done.

To install from terminal, simply type:

sudo snap install shutter

To test it out: launch Shutter, take a screenshot, and test out the Edit functionality. If this was helpful, please consider an up-vote. Thanks!

PS: At the time of writing this, the package in the store was on version 0.94-1. The snap was on version 0.94.3, which is the newest release at https://launchpad.net/shutter #winning

  • Best solution!!
    – Kane
    Commented May 22, 2020 at 16:22
  • good solution. I agree with that. Commented Nov 2, 2021 at 6:26
  • love the dad joke :) Commented Feb 15, 2022 at 13:43

Quick solution, just copy and paste these to your terminal:

wget https://launchpad.net/ubuntu/+archive/primary/+files/libgoocanvas-common_1.0.0-1_all.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libgoocanvas3_1.0.0-1_amd64.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb
sudo dpkg -i libgoocanvas-common_1.0.0-1_all.deb
sudo dpkg -i libgoocanvas3_1.0.0-1_amd64.deb
sudo dpkg -i libgoo-canvas-perl_0.06-2ubuntu3_amd64.deb
sudo apt -f install

Then restart Shutter and enjoy!

More details here: https://medium.com/@thucnc/how-to-enable-edit-option-in-shutter-on-ubuntu-18-04-e8b2c8dcc58

  • 1
    didn't work for me - no Edit button
    – scythargon
    Commented Feb 22, 2019 at 18:58
  • 1
    @scythargon what version of Ubuntu do you have, and can you share the output of the commands?
    – thucnguyen
    Commented Feb 26, 2019 at 10:38
  • 1
    thank you I've already managed to do this somehow
    – scythargon
    Commented Feb 28, 2019 at 8:43
  • Worked on Ubuntu 18.04.2 LTS
    – WooYek
    Commented Aug 6, 2019 at 9:11
  • How the author located the correct deb file in launchpad? Commented Dec 28, 2019 at 21:58

Just to add to other answers here after you install required dependencies


You need to kill and restart the shutter process, else the edit button will still be disabled.

You can do this with following commands:

athakur:~/Downloads$ ps -eaf | grep shutter
athakur  13246  1815  2 22:53 tty2     00:00:13 /usr/bin/perl /usr/bin/shutter
athakur  14467  8059  0 23:01 pts/0    00:00:00 grep --color=auto shutter
athakur:~/Downloads$ kill -9 13246
athakur:~/Downloads$ shutter

Kill the process that's running /usr/bin/shutter. Now start shutter program again (It will again load the plugins required) and now the edit button should be enabled.

You must log in to answer this question.