21

I am having this weird problem in Ubuntu 18.04. My laptop gets stuck at the shutdown screen every time I use shutdown and I have to manually press the power button for 5 seconds to turn the machine off.

Before 18.04, I was using Ubuntu 16.04 and it never got stuck at shutdown.

Any fix for this?

  • Does it freeze on a black screen? – YoureSOStubborn Apr 28 '18 at 7:03
  • Until the problem is solved it may help with SysRq REISUB. It will reboot the computer gracefully. The corresponding shutdown/poweroff is SysRq REISUO – sudodus Apr 28 '18 at 7:45
  • 1
    It freezes when it shows ubuntu logo – Peter Apr 28 '18 at 8:08
  • Have you tried SysRq REISUB or SysRq REISUO yet? In that case, does it help? – sudodus Apr 28 '18 at 9:08
  • 1
    How long did you wait? I see a 90 second CUPS timeout sometimes on 18.04 shutdown. – ubfan1 Apr 28 '18 at 15:17

13 Answers 13

5

Same problem here on my laptop. After some observation, I found out that it has something to do with power saving mode specially automatic suspend.

Go to Settings > Power then turn off all Automatic Suspend options. Also choose Blank screen to Never.

Till Ubuntu team will figure out why suspend mode is interfering with shutdown process, this solved my problem.

Hope this helps

  • I will try this :) – Peter Jun 2 '18 at 14:37
  • This fixed the problem. Hope ubuntu will send a fix soon – Buddhika.Ranaweera Sep 6 '18 at 7:40
3

Interestingly, this problems seems to have many fixes/causes. While none of the above helped for me (encountering the same problem), I fixed it by switching from the X.org graphics driver to the propietary nvidia driver that is recommended under software&updates. Since then, reboot works flawlessly.

My setup: Asus G Series Laptop G501VW, with Nvidia 960M graphics card.

  • For me, no solution has worked till now. Whatsoever I tried, I might have to switch back to previous version as this issue has no solution. – Peter Jun 28 '18 at 5:21
  • I'm using Elementary OS Juno with the same hardware (ASUS ROG G501VW). And I can confirm this solution has solved the problem. – frm.adiputra Oct 19 '18 at 8:11
2

Had the same problem on a brand new ASUS N705u. Found had to do with how the video driver installs which causes a conflict with the "secure boot" function of the BIOS. Solution: Turn the "secure boot" function off until other solution will become available.

  • Do you have any more information, like which video driver causes the problem, and how it causes a problem with secure boot that inhibits shutdown? – Hee Jin May 8 '18 at 15:44
  • That laptop comes with a NVIDIA GeForce MX150 graphics card. During installation of Ubuntu 18.04 a remark is made that a third party driver is needed which requires safe boot option to be turned off. It also asks for a password to allow safe boot disabling process. However, this password is never being asked for and it appears safe boot remains on regardless. (BIOS -ASUS 302). – Karl S. May 9 '18 at 23:04
  • Also after initial installation a third party driver "GP107M" is being downloaded and installed. A second computer - same model, that initial question doesn't come up during install once safe boot is disabled in BIOS – Karl S. May 9 '18 at 23:11
  • 1
    UPDATE: As mentioned above got two new computers with new Kubuntu 18.04 installs. Both kept playing up either on shutdown or then suddenly during the final stages of starting up. - Turns out it's the WIFI Manager ! Turn my WIFI Repeater off - all good. But if it's on those problems are back! – Karl S. May 10 '18 at 7:35
  • In my case, Wifi router was not even switching off/on even when pressing the Wifi button. – Peter Jul 9 '18 at 7:19
1

Try a couple of sudo reboots from terminal to see if it clears things up: 1st to try, reboot without writing wtmp file:

sudo reboot -d

If that reboots successfully then try your natural close down. If it doesn't reboot, try forced reboot:

sudo reboot -f

If this was an upgrade from 16.04 to 18.04, it may be worth considering a clean install.

  • I will give it a try if it happens again. – Peter May 1 '18 at 17:53
  • 1
    I had 16.04 (stucking on shutdown) upgraded to 18.04 - the same stuff. <br>Tried clean install of 18.04 - the same problem. – R S May 15 '18 at 21:50
1

There are scores of scripts that run when you shutdown. I'm still on 16.04 and for me these are the ones in /etc/rc0.d (which are really links to /etc/init.d). One of them may have a long delay set in what it does for stop.

AFAIK these scripts are run in alphabetical order, so you can insert a few that would just log their execution somewhere, helping you spot where the delay is.

1

I had this problem and I was researching into it for couple of days now.

I think I have found the source of the issue, it's the Intel Bay trail cores which is causing some firmware bugs.

Anyway I have a solution which isn't the best but good enough for now

Solution:

  • Open the terminal
  • sudo gedit /etc/default/grub
  • Edit GRUB_CMDLINE_LINUX_DEFAULT="quite splash" into GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1"
  • Update the grub :sudo update-grub
  • Restart your computer forcefully for one last time

Let me know if it worked or when you have a better solution

  • I've been stuck with this for a few months, upgrading to every new kernel, but this finally worked! Thanks. – Tihomir Nedev Jan 11 at 12:35
0

After doing more testing on two computers found it is in fact the Wifi Manager and the way it connects / identifies with the network. On two identical computers the problem disappears once the Wifi manager is turned off. Also tried USB Wifi dongle which worked on one computer but once again caused system to freeze at moment of registration on network. Have already tried a different Wifi manager with improved conditions. Also noticed in BIOS if secure boot is disabled then there is a list of drivers rejected bi BIOS due to security issues. Perhaps this is the underlying issue related to the Wifi manager.

  • Temporary fix: a) Turn Wifi off or b) Try disabling original Wifi Manager and install different one instead. – Karl S. May 13 '18 at 1:04
  • The unsecure driver theory and wifi makes sense to me. In my case, I installed a modified WiFi driver and since then the problem began. Will be trying disabling secureboot. – Rohitt Vashishtha May 25 '18 at 7:11
0

I had success turning off usb 3.0 driver in bios, not ideal, but it is fixed until more research is done.

0

My system is an older Dell Dimension E521 desktop, dual core, with Lubuntu 18.04, 64-bit.

In /etc/default/grub, I removed acpi=off and the system started behaving normally.

More specifically, I changed this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic acpi=off"

to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapci"

Now my box once again shuts down when I tell it to, and is refreshingly responsive.

0

I noticed that it happens to me too if i use my laptop for more than 10 hours, the gnome-shell uses more memory with time starting from 200 and going up to 500, firefox too starts with memory usage of 150 and goes all the way up to 900, restarting my laptop every 4 to 5 hours solved the issue of shutdown freezing for me I hope it helps you.

0

I had the same problem after installing 18.04 on a Fujitsu Scaleo.

During the install I had to add the acpi=off to be able to install Ubuntu because of a conflict with the Intel 82G33/G31 Express Integrated Graphics Controller. After that Ubuntu would just halt at System Halted when I shut it down.

In the end I changed the BIOS ACPI Suspend Type from S3 to Auto. I did this in Power Management. After this the PC would power down and I could even remove the acpi=off from Grub.

0

I had similar problem with ubuntu 18.04. I installed nvidia driver and now it works fine. Install your driver as described in https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux

0

I don't know why but for me, when I remove whole "quite splash acpi=off" and leave it blank, the issue is gone. Now my PC boot and reboot smoothly

  • Hi! This is truly more of a comment rather than an answer. Your 'fix' is probably the acpi=off part - the quiet suppresses boot messages, and the splash displays a pretty image during boot. – Charles Green Dec 28 '18 at 16:48
  • Yeah I'm just a newbie. But tried all above solution but it didn't work for me. So I tried remove all three of it and magically it reboot and boot without stuck. – Lemaire Dec 28 '18 at 18:38
  • Nothing works like success! Why did your system have that boot option set? – Charles Green Dec 28 '18 at 19:17
  • It is there by default – Lemaire Dec 30 '18 at 10:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.