8

I just installed Ubuntu 18.04 on my laptop (Asus Aspire 15, Intel i3-6100U) this morning, and everything seems to be working just fine except for the somewhat long boot time. I've ran 17.10 in the past and the boot time was pretty fast on my SSD, but it takes almost a minute for 18.04 to boot.

I ran systemd-analyze blame and it seems that plymouth-quit-wait.service is causing the problem:

      20.626s plymouth-quit-wait.service
      6.082s NetworkManager-wait-online.service
      1.090s dev-mapper-ubuntu\x2d\x2dvg\x2droot.device
       984ms motd-news.service
       804ms dev-loop8.device
       782ms dev-loop9.device
       757ms dev-loop10.device
       755ms dev-loop11.device
       744ms fwupd.service
       709ms dev-loop2.device
       695ms dev-loop1.device
       679ms dev-loop3.device
       677ms dev-loop4.device
       671ms dev-loop7.device
       666ms dev-loop5.device
       641ms dev-loop6.device
       374ms plymouth-start.service
       367ms systemd-logind.service
       287ms udisks2.service
       261ms apparmor.service
       259ms NetworkManager.service
       256ms systemd-rfkill.service
       213ms snap-core-4486.mount

I've tried masking and disabling the process but it didn't do anything. Also, if it helps solve anything, I've switched the desktop environment from Gnome to Cinnamon. The first boot into Gnome after installation had the same long boot issue.

2
  • I have the same issue, but didn't make a difference for me, it actually slowed down exit. I believe that even if Plymoouth is slow the issue is somewhere else, graphic drivers I believe. I run the 18.04 on Thinkpad t460 and up to 17.10 startup was real fast. I have started another discussion here: askubuntu.com/questions/1034279/…
    – RickSlash
    May 15, 2018 at 21:47
  • askubuntu.com/questions/1030867/…
    – Adam
    Jul 7, 2018 at 4:11

1 Answer 1

3

I just did a test conversion from 16.04 to 18.04 and did not have this problem. But you can suppress Plymouth by using sudo powers to edit the file /etc/default/grub.

sudo -H gedit /etc/default/grub

Look for the line containing:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and remove the word splash (which causes Plymouth to load).

Then save your file and run

sudo update-grub

Now Plymouth will no longer run on boot. This is a band-aid fix and you should keep searching for a real fix.

Not the answer you're looking for? Browse other questions tagged or ask your own question.