4

Upgraded from 16.04 to 18.04 today and want to start using netplan, but it doesn't appear to be installed? I tried to install it with apt install netplan but none of the files/directories listed on the Migrating to Netplan page exist.

5

Netplan is shipped in the netplan.io package. Running apt install netplan.io will give you the /etc/netplan directory; you will need to provide your own config files in this directory, with a .yaml extension.

If the netplan.io package was not installed for you on upgrade from Ubuntu 16.04 to Ubuntu 18.04, then it appears you are missing the ubuntu-minimal package. It is recommended that you install this package to ensure you have the standard Ubuntu experience.

| improve this answer | |
  • I migrated to 18.0.4 and I do have the /etc/netplan directory but when I ran sudo netplan generate nothing happened. Command does exist. See askubuntu.com/questions/1053757/… – rhand Jul 10 '18 at 7:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.