I'm running a fresh Ubuntu 18.04 installation. I have an issue with my fan, which is working non-stop. The CPU seems OK. My previous version of Ubuntu (16.04) did not have such a problem.

How do I find the source of this problem?

  • What make and model is your laptop? Do you still have 16.04 on another partition or did you wipe it out for the fresh 18.04 install? May 7, 2018 at 4:01

7 Answers 7


Posts by TomFreudenberg on github were very helpful. i8kutils is working like a champ on Dell Inspiron laptop but was hard to find a single procedure to get installed and configured for a Dell WITH bios fan control disabling. These are my detailed steps and machine:

  • Ubuntu 18.04 Bionic Beaver
  • Laptop: Dell Inspiron 7000 series (7737)
  • CPU: Intel® Core™ i7-4510U CPU @ 2.00GHz × 4

My solution steps (fans immediately shut off on last step):

  1. Download .zip file (or git clone) to disable BIOS fan control for Dell laptops.

  2. Then, as root:

    • cd Downloads
    • unzip -t dell-bios-fan-control-master.zip (test zipfile; everything looked fine, so unzip files...)
    • unzip dell-bios-fan-control-master.zip
    • cd dell-bios-fan-control-master/
    • more Makefile (look what it's going to do; looks fine, so compile with...)
    • make
  3. Compiled fine, so:

    • ./dell-bios-fan-control 0 (turn off dell bios fan control)
  4. Fan was still idling around 2500rpm. Hmmm.. recalled post indicating uninstall then reinstall i8kutils with the same /etc/i8kutils.conf config file.

  5. Uninstalled and reinstalled i8kutils with:

    • apt-get remove i8kutils
    • apt-get install i8kutils
  6. Fan immediately stopped upon reinstalling i8kutils.

Looks like it's working. Fan turns on properly when cpu temp hits 55C then turns off quickly because fan came on at the high setting.

Will continue to monitor temperature and fan states with 'sensors' to ensure all is working as configured in /etc/i8kutils.conf.

Thanks for the pointers and code. This is the only solution that worked for me.

tlp did nothing but that may be because bios was controlling the fans.


You may install tlp app from its ppa source and cpufreqd and indicator-cpufreq.
It's possible it will be enough to solve the problem.

Trying kernels via ukuu app may solve some issues about power usage.

Note: It was experienced the same issue upgrading to 17.xx and now again with the 18.04 which is weird as the kernels seem to be more and more efficient in the power management.


I had the same issue on a new DELL XPS 9560 Laptop - non stop fans.

For me it was the SMBIOS control of my Dell. When enabled (default), all i8kctl settings will be overwritten by SMBIOS control.

With help from others, I posted this project on github

This small tool allows to disable SMBIOS controls on Dell XPS 9560 so that i8kmon will work.

Maybe its sense-full to some others as well.

  • Hey Tom. Thanks for your efforts. When I run it I get: sudo ./dell-bios-fan-control 0 ioperm:: Operation not permitted ioperm:: Operation not permitted [1] 4701 segmentation fault sudo ./dell-bios-fan-control 0 Any hints?
    – Marc Dix
    Apr 22, 2020 at 19:33
  • Hey @marc-dix maybe try once: "switch off secure boot in bios". I read about people that were helped with that. Cheers, Tom Apr 23, 2020 at 8:27
  • Holy cow Tom, that WORKED! Thank you soo much!
    – Marc Dix
    Apr 24, 2020 at 9:32
  • I found a thread with a similar problem and wrote a how to on how I got it working. askubuntu.com/questions/1227489/…
    – Marc Dix
    Apr 24, 2020 at 9:48
  • Hey Marc, thats cool - thanks for documentation. Cheers, Tom Apr 24, 2020 at 12:17

I recently bought a new Dell Precision 3520 that came installed with 16.04. I upgraded to 17.10 and the cpu fan was working fine. It only came on intermittently, only when required.

Then I upgraded to 18.04 a few days ago. Initially I didn't notice anything odd about the cpu fan. Then a day or so later I noticed that the fan was running more than usual. I also noticed that the battery life also went down faster than what I was normally used to seeing.

The CPU I have, i7 7700HQ, runs between 2.8 GHz and 3.8 GHz in Turbo mode. I was keeping an eye on the cpu frequency and temperature using cpufreq-info and sensors. After upgrading to 18.04 I saw that the cpu was running at 3.8 GHz even though I wasn't running any applications. So, I went into the BIOS settings and disabled the Turbo mode. This seems to have solved my issue. I'm also running the cpufreq governor on powersave. Hope this helps.


If you are using a Dell Inspiron 3521 please see my blog fixing-constantly-running-fans-on-dell-laptops for ubuntu 16.04, if Ubuntu 18.04 still uses the same kernel module dell-smm-hwmon as in ubuntu 16.04 this should still be valid.


Had same problem, fan was working not stop. I discovered that cpu was always at max frequnecy. Intel pstate enabled and powersave governor selected.

cpupower frequency-info
analyzing CPU 0:
    driver: intel_pstate
   CPUs which run at the same hardware frequency: 0
   CPUs which need to have their frequency coordinated by software: 0
   maximum transition latency:  Cannot determine or is not supported.
   hardware limits: 800 MHz - 3.80 GHz
   current policy: frequency should be within 3.80 GHz and 3.80 GHz.
              The governor "powersave" may decide which speed to use
              within this range.

For some unknown reason CPU min and max frequnecy was 3.80GHz. I used https://github.com/pyamsoft/pstate-frequency tool to set powersave governor and this time correct values for CPU minimum and maximum frequencies was set. CPU temp dropped few degrees and battery life is over 7 hours again(was ~3-4 hours). First time after installing 18.04, fan stopped working. (Dell XPS 9560, i7-7700HQ)

  • Hi henri17, can you give some more information about the cpupower command, as well as your kernel version? It looks like cpupower is provided by linux-tools-common, but you need to install a version that's specific to your kernel.
    – Hee Jin
    May 7, 2018 at 15:58
  • I have : 4.15.0-20-generic #21-Ubuntu SMP Tue Apr 24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux cpupower 4.15.17
    – henri17
    May 9, 2018 at 12:56

try my personal solution. It's working fine on a Dell Inspiron 3521 15R Intel i3 CPU on Kubuntu 18.04.

Persistent High-Fan Speed Ubuntu 14.04

Not the answer you're looking for? Browse other questions tagged or ask your own question.