23

I have been trying to upgrade to Ubuntu 18.04 but when I try

do-release-upgrade -c

I get this output

Checking for a new Ubuntu release
No new release found.

I have checked the release date to be 26th April but still, I didn't get any update...

I am a little new to Linux, so pardon me if I am mistaken on any point.

  • You should test the upgrade on new partition with a clone copy of your data first. Some users have been burnt by an upgrade that crashes or programs that don't work after upgrade. See this script for cloning example: askubuntu.com/questions/1028604/…. You can also boot with a live USB and clone manually. Instructions are available when you google search. – WinEunuuchs2Unix Apr 29 '18 at 19:31
  • @WinEunuuchs2Unix I have around 10 clients who switched from Windows to Ubuntu on my recommendation. They are in no way computer experts. They all upgrade to every LTS, and some of them upgrade to the each between release. I also maintain 5 Ubuntu computers in my shop, of which I always upgrade to the latest LTS versions. On the very rare occasion where there is a problem, there have always been two solutions that resolved them. Removing a PPA (identified by an error message), or running sudo apt update and sudo apt dist-upgrade. – L. D. James Apr 30 '18 at 11:09
  • @WinEunuuchs2Unix You're right about the the not working programs after an upgrade. I have experienced that. Most of the time, the release upgrade will disable the PPA entry, of which, reenabling it after the upgrade fixes. If there are error messages after enabling the PPA's, they are usually dealt with during the regular addressing the error message issues. – L. D. James Apr 30 '18 at 11:15
  • What Ubuntu version are you trying to upgrade from? – WinEunuuchs2Unix Apr 30 '18 at 11:42
  • Try do-release-upgrade -c. Finally upgrade got released today. – Aravind Aug 14 '18 at 17:35
13

The Release Notes have this:

Upgrading from Ubuntu 16.04 LTS or 17.10

Upgrades from 17.10 will not be enabled until a few days after 18.04's release. Upgrades from 16.04 LTS will not be enabled until a few days after the 18.04.1 release expected in late July.

  • 1
    Is there a difference between the upgrades we are getting now with the sudo do-releaes-update and the one that the quoted text is saying wait for? – L. D. James Apr 29 '18 at 23:20
  • 5
    It's now a few days after the 18.04.1 release. Are you aware of any information for when exactly LTS upgrades will be allowed? – jrennie Jul 30 '18 at 18:19
10

A thorough guide for upgrading is presented here. Other answers already mention you need to use:

do-release-upgrade -d     # Use this until 18.04.1 comes out
do-release-upgrade        # Use this after 18.04.1 comes out

Additionally though you need to check the file:

~$ cat /etc/update-manager/release-upgrades
# Default behavior for the release upgrader.

[DEFAULT]
# Default prompting behavior, valid options:
#
#  never  - Never check for a new release.
#  normal - Check to see if a new release is available.  If more than one new
#           release is found, the release upgrader will attempt to upgrade to
#           the release that immediately succeeds the currently-running
#           release.
#  lts    - Check to see if a new LTS release is available.  The upgrader
#           will attempt to upgrade to the first LTS release available after
#           the currently-running one.  Note that this option should not be
#           used if the currently-running release is not itself an LTS
#           release, since in that case the upgrader won't be able to
#           determine if a newer release is available.
Prompt=never

If the last line says "never" change it to "normal" for Ubuntu 17.10 users. For Ubuntu 16.04 LTS users, change it to "LTS". Otherwise you will get the upgrade...um "never":

rick@alien:~$ do-release-upgrade
Checking for a new Ubuntu release
No new release found.
───────────────────────────────────────────────────────────────────────────────────────────
rick@alien:~$ do-release-upgrade -d
Checking for a new Ubuntu release
Upgrades to the development release are only 
available from the latest supported release.
───────────────────────────────────────────────────────────────────────────────────────────
rick@alien:~$ do-release-upgrade -c
Checking for a new Ubuntu release
No new release found.

These commands were issued with Prompt=never under Ubuntu 16.04 where it is available for upgrading yesterday (April 28, 2018). Changing the prompt to lts solved the problem.


You should either backup your data first or clone your data and run the upgrade in a test environment. Here is one script I wrote for such a purpose (but you can also do it manually with Live USB): Bash script to clone Ubuntu to new partition for testing 18.04 LTS upgrade

I made some notes during the upgrade process and here is what you can look forward to:

Step 1: confirmation to proceed: Press [ENTER]
Step 2: packages will be removed: Y
Step 3: replace '/etc/systemd/longind.conf': Y
Step 4: Configuration file '/etc/sane.d/dll.conf', default N, take Y
Step 5: Configuration file '/etc/NetworkManager/conf.d/default-wifi-powersave-on.conf' Take default N
Step 6: Configuration file '/etc/pulse/default.pa' default N, take Y
Step 7: Configuration file '/etc/grub.d/30_os-prober'' default N, take N
Step 8: Full screen grub menu config appears. Take option: keep the local version currently installed
Step 9: Configuration file '/etc/cron.d/anacron', default N, take Y to see what
Error Message multiple times: /sbin/ldconfig.real: Warning: ignoring configuration file that cannot be opened: /etc/ld.so.conf.d/x86_64-linux-gnu_EGL.conf: No such file or directory
Step 10: Non-standard: Configuration file '/etc/vnstat.conf' (display differences 1.13 vs 1.18) take Y
Step 11: 220 packages are going to be removed. (can take hours) enter Y
Step 12: To finish the upgrade, a restart is required. Take Y

Note your steps will vary depending on software installed.

All the more reason for cloning is you can test what happens when you accept default of N or you use Y to get the most current configuration which may or many not be better.

Because your original Ubuntu version is left intact you can run the diff command against the new 18.04 configuration files if you chose to install them.

6

All the meta information hasn't been released/configured yet. You can wait a few days or run this as an alternative now:

$ do-release-upgrade -d

It works flawlessly!

The -d is for the latest development release which is the current Ubuntu 18.04 LTS release. The same one referred in the release notes.

4

There is an explanation here:

As already mentioned above, upgrades from 17.10 will not be enabled until a few days after 18.04's release and upgrades from 16.04 LTS will not be enabled until a few days after the 18.04.1 release which is expected in late July 2018.

As a result, your upgrade attempt may result in a message No new release found while trying to upgrade your Ubuntu system by using sudo do-release-upgrade command. In this case read the following sections.

As to how to upgrade anyway:

Start by executing the sudo do-release-upgrade command. In case you receive the No new release found message you have four options:

  • The first and recommended approach is to simply wait. Direct upgrades from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS will most likely be unavailable until late July 2018.

  • Force direct upgrade by using the -d switch. In this case sudo do-release-upgrade -d will force upgrade from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS. In case you receive an "Upgrades to the development release are only available from the latest supported release." message, make sure that release upgrader default behavior is set to ltswithin /etc/update-manager/release-upgrades.

  • Upgrade to 17.10 first by changing the default behavior of the release upgrader to normal within the /etc/update-manager/release-upgrades file. When ready, execute the sudo do-release-upgrade command again. Once your system is upgraded to Ubuntu 17.10 then follow the Ubuntu 17.10 to Ubuntu 18.04 upgrade procedure while keeping the release upgrader behavior set to normal.

  • Use the Debian way described below to upgrade your Ubuntu 16.04 system.

And that Debian method is:

If you've selected the traditional Debian path, you're going to need to change the /etc/apt/sources.list file and replace the name of your previous release with bionic. So, if you're on 16.04, replace every instance of xenial with bionic. If you currently have 17.10, replace artful with bionic.

This process can be automated by using the following sed command:

$ sudo sed -i 's/xenial/bionic/g' /etc/apt/sources.list

Then, look in /etc/apt/sources.list.d/. Change any files in there the same way. If you end up getting an error when you try to update Ubuntu, use artful until those repositories are updated.

Now, you can run the Ubuntu dist upgrade. First, update the Apt sources. Then, run the Ubuntu upgrade.

$ sudo apt update && sudo apt -y dist-upgrade

The upgrade should take a bit of time. Chances are, every package on the system will be upgraded. When the Ubuntu upgrade does finish, reboot the system. When the system comes back up, you'll be running Ubuntu 18.04 LTS Bionic Beaver!

However, something to take note of is that the traditional Debian method apparently doesn't take care of the changes in system configuration, which is why the recommended method is to use Update Manager, whether through the graphical tool (update-manager) or the command-line tool (do-release-upgrade).

0

I had trouble getting it upgrade ("no new release found") until I tried to do that on the other account.

If you have multiple accounts, then you may want to try the one that is created first when you install the system.

The update manager will show the new release available use the command

update-manager -c

in the Alt+F2 pop-up window.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.