3

I have just installed Ubuntu 18.04 on my Asus UX490 and now I cannot change the volume but I can mute/unmute.

I can move the volume bar right/left but volume does not change. However, when I move it to left most side or just click the sound icon, computer mutes/unmutes correctly.

Also when I try to change the volume with fn+f11/f12 I see the volume level thingy changing in the middle of the screen but sound does not change as well. However, again, I can mute/unmute with fn+f10.

Similar things happen when I try from Setting > Sound. Under this menu in the "Choose a device for sound output:" list I only see "Speakers - Built-in Audio".

Another thing, if I change the sound in a player (let's say youtube) sound changes.

I tried these two but they did not help.

PS: Just to make it clear, this is the first time I installed any Ubuntu version on this laptop. I mean, I do not say "it was working and got broken after I installed 18.04"

  • Have you tried Fn + F7/F8 as it is the keys i use? – YoureSOStubborn Apr 27 '18 at 19:45
  • 1
    Seems like it is an Asus specific issue. This solved: askubuntu.com/questions/906303 – Mehmet Ataş Apr 27 '18 at 19:47
  • Try going to the settings>Region and Language and under the keyboard input, click on the small keyboard then click and test to see if the keyboard is receiving data, as it may be because your keyboard isn't receiving input? – YoureSOStubborn Apr 27 '18 at 19:51
  • I have the same problem with Dell XPS 13 and now with ASUS UX390. You can control the volume using the alsamixer PCM control. However, I am not sure how to get the hotkeys to recognize the alsa drivers. I dont think this is an issue with ASUS in particular. Somehow the alsa driver and pulseaudio driver (this one controls the hotkeys) are not compatible. Edit: I answered on the fly while installing Ubuntu 18.04 on my ASUS UX390. I found this suggestion very useful and worked for me: askubuntu.com/questions/906303/volume-control-on-asus-zenbook-3 Hope this works for you as well! :) – Aritra Aug 6 '18 at 18:34
  • 2
    Possible duplicate of Volume control on asus zenbook 3 – Zanna Aug 7 '18 at 9:57
0

try the solution from this question? Volume control not working

I think I may have solved the issue. Upon examining /etc/modprobe.d/alsa-base.conf, I noticed that it no longer had the following line.

options snd-hda-intel model=auto

I re-added this line, saved, rebooted, and everything seems to be working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.