Fresh install of 18.04 on an Intel NUC. Worked at first but now when I get to the login screen, it takes about a minute before my keyboard and mouse respond. My password is not accepted on the first attempt but on the second it is. On finally being allowed to log in, I am presented with a purple screen with no desktop.

Edit: I managed to get back in via a hard reboot but that's not an ideal solution.

Edit 2: Complete shutdown followed by disconnecting from the mains allows me to start up normally next time. Reboot or REISUB leads to issues described above.

video from fail

  • Check you memory and do an update! Commented Apr 27, 2018 at 16:10
  • Since the keyboard isn't recognised while booting, I can't get into recovery mode run a memory check.
    – Lolwhites
    Commented Apr 27, 2018 at 19:34
  • 'My password is not accepted on the first attempt but on the second it is. On finally being allowed to log in, I am presented with a purple screen with no desktop.' Please mark yourself as affected by this bug, thanks! :)
    – Ads20000
    Commented May 1, 2018 at 0:06

4 Answers 4


I ran into a very similar issue, but even a hard reset did not allow me to log in. The last thing I had done before the issue presented itself was install the indicator-multiload package.

I was lucky, and simply logging into a console (CTRL + ALT + F2) and uninstalling the package (sudo apt remove --purge indicator-multiload) fixed the problem.

I have not dived any deeper into this issue to see why (or even whether) this package caused said issue, but I postulate that it has something to do with the package's integration with the Gnome desktop.

Maybe you can try to think what packages you might have installed recently that could have interfered with Gnome and attempt to uninstall them. If doing so works, at least you can get back into your desktop environment and troubleshoot further.

  • 1
    This is my main machine and I really don't have the time to laboriously troubleshoot something like this. Furthermore, all the hard reboots can't have been doing it any good, so I "solved" the issue by installing another flavour - MATE.
    – Lolwhites
    Commented Apr 28, 2018 at 20:08

This problem could be resolved easily by following commands Go to terminal mode by CTRL + ALT + F3 and login then

sudo apt install --reinstall ubuntu-desktop
sudo apt install --reinstall ubuntu-session

If it does not work, try as follow:

chown $USER:$USER .Xauthority

or try to rebuild .Xauthority

  mv .Xauthority .Xauthority.bak
  • 1
    I upgraded from ubuntu 16.04 to 18.04 and had similar issues to OP. This solution worked perfectly for me. Thanks!
    – mildewey
    Commented Aug 21, 2018 at 16:42
  • upgrade from 16.04 to 18-04. The chown solved this problem. Thanks!!
    – Yaskier
    Commented Dec 14, 2018 at 0:34

I had the same problem, I removed the last package I had installed (Numix theme from PPA), reboot and the session could access.


This fixed it for me on 20.04. None of the ideas above did work unfortunately.

  sudo chown -R NEWUSER:NEWUSER *
  sudo chown -R NEWUSER:NEWUSER .*   # to include hidden files and directories

My issue was caused by a mismatch of USER ID, for more explanation see Ubuntu 20.04 - Can’t login after upgrade

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .