0

I'm a newbie on Ubuntu ! Yesterday I tried fixing the problem of Bluetooth (connecting my computer with a speaker) and pulseaudio suddenly disappeared from my computer. Now I have no sound system anymore.

I try now to reinstall pulseaudio but i cant :

sudo apt-get install pulseaudio

[sudo] Mot de passe de matisse : Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait

Vous pouvez lancer « apt-get -f install » pour corriger ces problèmes : Les paquets suivants contiennent des dépendances non satisfaites : libasound2-plugins : Dépend: libpulse0 (>= 0.99.1) mais ne sera pas installé libsdl1.2debian : Dépend: libpulse0 (>= 0.99.1) mais ne sera pas installé libsdl2-2.0-0 : Dépend: libpulse0 (>= 0.99.1) mais ne sera pas installé openjdk-8-jre : Dépend: libpulse0 (>= 0.99.1) mais ne sera pas installé

pulseaudio : Dépend: libpulse0 (= 1:8.0-0ubuntu3) mais ne sera pas installé Dépend: pulseaudio-utils mais ne sera pas installé Recommande: pulseaudio-module-x11 mais ne sera pas installé speech-dispatcher-audio-plugins : Dépend: libpulse0 (>= 0.99.1) mais ne sera pas installé

E: Dépendances non satisfaites. Essayez « apt-get -f install » sans paquet (ou indiquez une solution).

>> Actually, 5 packages are broken regarding to Synaptic : <<

Result for Synaptic

>> When i want to install libpulse0 : <<

matisse@Matisse:~$ sudo apt-get install libpulse0

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires : libasyncns0:i386 libflac8:i386 libjack-jackd2-0:i386 libjson-c2:i386 libogg0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 Veuillez utiliser « sudo apt autoremove » pour les supprimer.

Paquets suggérés : pulseaudio

Les NOUVEAUX paquets suivants seront installés : libpulse0 0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour.

Il est nécessaire de prendre 0 o/247 ko dans les archives. Après cette opération, 965 ko d'espace disque supplémentaires seront utilisés. (Lecture de la base de données... 396686 fichiers et répertoires déjà installés.) Préparation du dépaquetage de .../libpulse0_1%3a8.0-0ubuntu3_amd64.deb ... Dépaquetage de libpulse0:amd64 (1:8.0-0ubuntu3) ... dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb (--unpack) : tentative de remplacement de « /etc/pulse/client.conf », qui est différent d'autres instances du paquet libpulse0:amd64 dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe)) Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...

Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

>> And when i want to -f install, it is the same result : <<

matisse@Matisse:~$ sudo apt-get -f install

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait Correction des dépendances... Fait

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :

libasyncns0:i386 libflac8:i386 libjack-jackd2-0:i386 libjson-c2:i386 libogg0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 Veuillez utiliser « sudo apt autoremove » pour les supprimer.

The following additional packages will be installed: libpulse0

Paquets suggérés : pulseaudio

Les NOUVEAUX paquets suivants seront installés : libpulse0

0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour. Il est nécessaire de prendre 0 o/247 ko dans les archives. Après cette opération, 965 ko d'espace disque supplémentaires seront utilisés.

Souhaitez-vous continuer ? [O/n]

(Lecture de la base de données... 396686 fichiers et répertoires déjà installés.)

Préparation du dépaquetage de .../libpulse0_1%3a8.0-0ubuntu3_amd64.deb ... Dépaquetage de libpulse0:amd64 (1:8.0-0ubuntu3) ... dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb (--unpack) : tentative de remplacement de « /etc/pulse/client.conf », qui est différent d'autres instances du paquet libpulse0:amd64 dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))

Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...

Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

Lecture des listes de paquets... Fait Construction de l'arbre des dépendances
Lecture des informations d'état... Fait Correction des dépendances... Fait

Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :

libasyncns0:i386 libflac8:i386 libjack-jackd2-0:i386 libjson-c2:i386 libogg0:i386 libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libvorbis0a:i386 libvorbisenc2:i386 libwrap0:i386 Veuillez utiliser « sudo apt autoremove » pour les supprimer.

The following additional packages will be installed: libpulse0

Paquets suggérés : pulseaudio

Les NOUVEAUX paquets suivants seront installés : libpulse0

0 mis à jour, 1 nouvellement installés, 0 à enlever et 0 non mis à jour. Il est nécessaire de prendre 0 o/247 ko dans les archives. Après cette opération, 965 ko d'espace disque supplémentaires seront utilisés.

Souhaitez-vous continuer ? [O/n]

(Lecture de la base de données... 396686 fichiers et répertoires déjà installés.)

Préparation du dépaquetage de .../libpulse0_1%3a8.0-0ubuntu3_amd64.deb ... Dépaquetage de libpulse0:amd64 (1:8.0-0ubuntu3) ... dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb (--unpack) : tentative de remplacement de « /etc/pulse/client.conf », qui est différent d'autres instances du paquet libpulse0:amd64 dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))

Traitement des actions différées (« triggers ») pour libc-bin (2.23-0ubuntu10) ...

Des erreurs ont été rencontrées pendant l'exécution : /var/cache/apt/archives/libpulse0_1%3a8.0-0ubuntu3_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

>> Of course Ubuntu shows an update available but when i want to update : <<

Update

Problem

>> How can i fix this problem ? I'm confused ! <<

PS : Sorry i am french and so is my computer (maybe i can change the language ? How ?).

0

You have to reinstall the bluez-tools by doing this:

sudo apt-get download bluez-tools && sudo dpkg -i <insert bluez package.deb>

The package is saved in the directory You're actually in so make sure that you're in a directory with write capabilities (i recomand ~/) and you should also have root rights

  • root means that you can run a command with "sudo" and you have the user's password so you can run it with sudo.by default when you open a terminal window you're already in home direcory (~/ or /home/matisse/).It's very likely to the Windows echosystem.Sudo means Run as administrator and home means that folder where you have the desktop,downloads etc folders – tuddyftw Apr 27 '18 at 15:49
  • ok but when i do sudo dpkg -i <insert bluez package.deb>, it answers : bash: erreur de syntaxe près du symbole inattendu « newline ». – Matisse Apr 27 '18 at 15:50
  • that depends on the version that is on your repo.i have ubuntu 18.04 so i can't tell you the complete name of the actual package.to do that use the dir command and check for bluez file.You cand also do this: type sudo dpkg -i bluez and hit TAB key on the keyboard – tuddyftw Apr 27 '18 at 15:53
  • Ok i found it (bluez-tools_0.2.0~20140808-5_amd64.deb). I used dpkg -i bluez-tools_0.2.0~20140808-5_amd64.deb. I think it works. But what next ? (I tried to sudo apt-get -f install but it doesn't change anything). – Matisse Apr 27 '18 at 16:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.