23

Last night I upgraded 16.04 to 18.04. After the upgrade when I logged into the account I had been using the display is like super zoom.

Kindly assist with solution.

2
  • Could you please edit your question to include the output of the terminal commands lspci -nnk | grep -A3 -Fe '[0300]' and xrandr? Thanks. Apr 27, 2018 at 21:21
  • I have an issue like this in the current 20.04. At the login screen and after login menus are enlarged. If I goto settings->Display and set screen to 200% then revert, the screen displays as expected/normal. Still haven't figured out how to fix this so it doesn't happen initially.
    – monkut
    Sep 6, 2020 at 1:57

8 Answers 8

27

I had the same problem, but figure it out that Zoom was active. Just go to Universal Access in Settings and disable Zoom.

Hope it helps.

4
  • I have no such an option as Zoom in my Universal Access settings. I had to switch the desktop manager to Unity in order to be able to view my desktop properly. With the Zoom on, I can't see much on my screen. Aug 26, 2018 at 15:05
  • 1
    It worked! :) btw does anyone know why is zoom on by default? Sep 17, 2018 at 11:59
  • @AhmadShahwan In Ubuntu 18.04 I could find 'Universal Access' in Settings under 'Region and Language' ... and Zoom is the 4th option under 'Seeing'
    – andzep
    Oct 30, 2018 at 15:29
  • I had the Universal Access it in the top-right. I reinstalled drivers twice before finding this answer. This is a very bad default setting. Feb 22, 2019 at 13:01
4

I have nvidia GeoForce GTX 1080 graphics card.

I went to Software & Updates and then to the Additional Drivers tab and selected what is given in the below image. It installed the drivers after which I rebooted and it was fine.

enter image description here

0

Firstly check if your resolution is the highest avaible and is the same as your graphic's card. If no just change to highest.

If it is the highest just download from Ubuntu Store Gnome Utils (It may be called as Gnome center as something kike this) and change display scaling from 1.0 to e.g 0.75). This should help you.

2
  • I tried to change resolution to 800*600 using tab, it shrink the screen but still showing zoomed.
    – lovalim
    Apr 27, 2018 at 15:49
  • What's your graphic card's resolution?
    – Domin
    Apr 27, 2018 at 16:17
0

Your screen seems to be ultra magnified. I think it's due to a configuration problem. To solve it, try to find the Settings button (normally should be on the left). Then click on 'Universal Access' and find the Zoom setting. You can reduce the magnification of your screen to 1, but I recommend you just disable the zoom (at the top right part of the screen).

1
  • 1
    Can you post a screenshot of where this zoom setting is suppose to be? I've clicked all the menus in All settings > Universal access with no sight of any Zoom-like option (that would be turned on). May 25, 2018 at 8:27
0

I had a similar issue. I have a laptop with an external 23" monitor and used to work fine in ubuntu mate 16.04. When I updated to ubuntu mate 18.04 everything was like zoomed. The issue was that it was not detected properly. I run

export QT_AUTO_SCREEN_SCALE_FACTOR=0

then reboot and the monitor was detected right! This was my source: https://ubuntuforums.org/showthread.php?t=2390362

My problem was also described here: Ubuntu 18.04 not detecting monitor size properly

Hope this helps!

0

I had a similar issue after switching to a new external monitor. As the screen had changed I had to update the configuration by using xrandr --auto which solved it.

0

I had this same issue, and none of the above solutions seemed to help. I knew it was a GPU driver problem, but I found finding the right version of my drivers in the PPA confusing, I couldn't install any additional drivers in Software & Updates, and the zoom setting in Universal Access was already disabled. If your GPU is made by NVIDIA and you're on 18.04LTS, this guide was what helped me figure it out. I'll summarize the main part:

ubuntu-drivers devices

to find the name of the drivers you need, and then, assuming you agree with the output,

sudo ubuntu-drivers autoinstall

will install the drivers. Alternatively, you can also do

sudo apt install nvidia-xxx

where xxx is replaced by whatever number is output by the first command. In my case, after restarting my computer, the problem was fixed and I had a nice, much more high-def display.

0

This was exactly my problem some days ago. After around 5 hours trying to solve it and thinking the worst about Linux or Ubuntu :-/ (I tested almost every posted solution and reboot my pc more than 15 times without result, including updated the kernel, sw/systems updates, sw changes, config files edition, and etc...); I realized in my case that actually my problem was not. During installation, the TV was turned on, and the TV is connected to my computer through the HDMI port. So the system configured the TV as the first display and the embedded monitor (of my all in one PC) as the second one. So the system got configured for my TV instead of my actual monitor. As the TV was being used to watch stream media, not as a monitor (input:HDMI), I did not realize this until several attempts and research.

The solution was to use shortcuts keys to zoomed out[1] the screen and then I was able to understand what happened, access system configuration, and configure my primary monitor as the main one.

This problem was for me at the end a bit funny...

  1. How to zoom in & zoom out

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.