I'm experiencing a serious problem with the new Ubuntu 18.04:

Dell XPS 13 with a freshly installed Ubuntu 18.04 LTS.

Problem description
The touchpad provides only primary button (single click and double click), but no secondary button. In particular, when using the "test Your Settings" option in Settings -> Devices -> Mouse & Touchpad, any click on the touchpad is signaled as primary button, no matter where I click (left or right side of the touchpad). This remains the case even after I change the Primary Button from Left to Right (in Settings -> Devices -> Mouse & Touchpad -> General).

In comparison, an external mouse connected to my laptop (via usb) works fine: it provides both primary and secondary buttons with sides corresponding to the choice of Primary Button (in Settings -> Devices -> Mouse & Touchpad -> General).

This may be related to Touchpad right click doesn't work on touchpad, only the buttons above it. Thinkpad E480 Ubuntu 18.04 LTS

Any ideas?

Meanwhile, I found out that in addition to the solution proposed by EntropyWins, one can also control this touchpad behavior via the Tweaks tool (a.k.a. gnome-tweaks) under Keyboard & Mouse -> Touchpad -> Mouse Click Emulation. In any case, as EntropyWins explains in his answer, this is not a bug.

  • See if this useful: askubuntu.com/questions/957099/…
    – pomsky
    Apr 27, 2018 at 13:15
  • The above fix might work because as I understand it, it overrides the newer libinput driver with the older synaptics driver. My fix below requires a simpler settings flip and still uses the new driver, so hopefully it is a bit less likely to cause other problems in the future. It also doesn't require a reboot!
    – PatKilg
    Apr 27, 2018 at 16:41

3 Answers 3


Basically, Ubuntu 18.04 currently defaults to "Mac" behavior on the touchpad. The technical details are that Ubuntu defaults libinput touchpads to "clickfingers" behavior.

To revert that, run this in a terminal:

gsettings set org.gnome.desktop.peripherals.touchpad click-method areas

Another option (thanks OP) is to install gnome-tweak-tool (either through your software manager or through sudo apt install gnome-tweak-tool in the terminal). Navigate to the “Keyboard & Mouse” sub-menu in the left menu of gnome-tweak-tool, and select “Areas” from the touchpad’s “Mouse Click Emulation” options in the right side panel, as shown in the red box in the image below: Relevant setting in gnome-tweak highlighted

[Warning: This fix is for the libinput driver that ships as the default input driver for Ubuntu 18.04. YMMV if you've installed the (different) synaptics driver before trying this fix.]

  • 3
    Worked like a charm, thanks heaps! I wonder if the default MAC setting is a smart thing...
    – Yuvalem
    Apr 27, 2018 at 19:16
  • 10
    Also, I take Linus' approach to what is a bug: Don't f**k with things the user expects to work as it always has worked...
    – PatKilg
    Apr 29, 2018 at 1:48
  • 4
    Switching to the "area" method disables the right click altogether in my case (18.04, Acer Extensa 2510G). And I DO HATE the "fingers" method because you have to keep one finger on the touchpad or the menu disappears. Useless acrobatics just.
    – Pavel
    Apr 29, 2018 at 22:51
  • 2
    Both methods now work correctly after renaming 50-libinput.conf to 90-libinput.conf to make sure it's read after 70-synaptics.conf. Hmm.
    – Pavel
    Apr 29, 2018 at 23:17
  • 2
    Pavel--the reason my fix didn't work for you is (likely) because you have the synaptics drivers installed. 18.04 does not ship with the synaptics driver controlling the touchpad, you likely installed it yourself (or your flavor included them). My fix is for the libinput driver, not the synaptics driver.
    – PatKilg
    Apr 30, 2018 at 13:19

Right button event is generated when two fingers are held down on the touchpad when a physical click is generated. The location of the fingers does not matter and there are no software-defined button areas.

This is the default behavior on Ubuntu 18+ and Apple touchpads.

  • In 18.04 I had no problems with this, just updated to 20.04.1 LTS and now secondary/right clicks are REALLY problematic, intermittent and difficult to get constantly. I can't see how to map the secondary stylus button to one of the buttons on my CTH-480 wacom and I can't see how to affect the sensitivity to correct this either. I can map a key combination to a physical button but I can't assign a right/secondary click. big problem...
    – Tom Rhodes
    Oct 3, 2020 at 9:22

Switching to the "area" method disables the right click altogether

solution- reboot or logout required to apply the tweak

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .